CNET también está disponible en español.

Ir a español

Don't show this again

Phones

HTC Desire won't get Gingerbread update, users up in arms

The HTC Desire won't be officially upgraded to Android Gingerbread because there isn't room for it to sit alongside HTC Sense. Users are understandably annoyed.

The HTC Desire won't be getting the long-awaited Android update to version 2.3 Gingerbread. HTC said it wouldn't be possible to have both the newer version of Google's software and its own HTC Sense user interface on the phone, due to memory constraints.

Many users are angry that the phone, which is only a year old, will not be updated. Regular updates are an increasingly important part of Android phones' appeal.

The full statement published on HTC's Facebook page reads: "Our engineering teams have been working hard for the past few months to find a way to bring Gingerbread to the HTC Desire without compromising the HTC Sense experience you've come to expect from our phones.

"However, we're sorry to announce that we've been forced to accept there isn't enough memory to allow us both to bring Gingerbread and keep the HTC Sense experience on the HTC Desire. We're sincerely sorry for the disappointment that this news may bring to some of you."

As you'd expect, a huge number of users aren't happy by the apparent U-turn -- the Facebook thread has over 350 comments already. Owners expected the high-end handset to be supported with updates for much longer, with many pointing out that the homebrew devs at XDA Developers had got both to work on the Desire some weeks ago.

As Ed O'Sullivan notes on the thread, "Everyone here should remember the Desire 2.3.3 ROMs on XDA are using the SD card to host a lot of the ROMs. The internal memory of the Desire isn't big enough to include 2.3.3 and the new version of Sense." As SD cards are provided separately, HTC has to put all the phone's preloaded software on the installed memory.

The fact remains, however, that HTC has created a user interface that's so memory intensive it's effectively making a very recent phone obsolete.

The Desire's hardware was designed at a time when Froyo and Sense 1.9 were on the scene, both requiring fewer system resources. For whatever reason, HTC decided to put in a relatively small amount of internal memory and configured it in such a way that it could never accept the more resource-hungry Gingerbread and Sense 2.1 together.

There's an interesting question as to why the Wildfire S, which at first glance has a lower spec, can run Gingerbread but the Desire can't. It seems to be that the Wildfire S, a newer phone created with more recent software in mind, has more of its internal memory reserved for core system software.

HTC was applauded when it reversed its decision to keep the bootloader locked on its smart phones, but it does appear to have shot itself in the foot this time. Those happy to hack their Desire can get Gingerbread on to it, but everyone else is now stuck unless they buy a new handset.

In fairness, Froyo is still an admirable version of Android and HTC have done a decent enough job with its Sense overlay. That said, we understand the frustration for users who paid a lot of money or are stuck in a long contract and are desperate for the latest software.

We're also intrigued to know what will happen when Ice Cream Sandwich launches. Google said the OS will work on all handsets, even if some features don't, so we presume there'll be a cut-down Froyo-esque version for handsets that find themselves in a similar predicament to the Desire.

Will there be a mass exodus from HTC? A few vocal dissenters have threatened to defect to Samsung, but we don't expect a boycott by regular users. Let us know what you think in the comments section below.