CNET también está disponible en español.

Ir a español

Don't show this again

Apple Watch apps could get zippier with new requirement for app makers

Apple says third-party Watch apps for the App Store must be able to run without the help of an iPhone.

James Martin/CNET

Dear iPhone, I love you, but I think I just need to be alone for a while. Yours, Apple Watch.

Could your Apple Watch and iPhone soon be going their separate ways for good?

This week, Apple gave third-party developers of Apple Watch apps a new requirement. Come June 1, apps submitted to the company's App Store must be built for the more recent versions of the software that runs the Apple Watch: watchOS 2 or later.

Yeah, so? Well, Apple unveiled watchOS 2 in October. Among other things, the upgraded operating system added more Wi-Fi support, which meant you could run apps, make calls and issue voice commands without the need for an iPhone nearby. As of June, new App Store apps will have to, well, support that beefier Wi-Fi support, by running the newer OSes. That suggests a faster, better app experience on the Apple Watch.

Apple released incremental updates with watchOS 2.2 last month. It could also unveil new features and improvements to the OS at its WWDC developers conference, which begins June 13. We may also see a second-generation Apple Watch sometime this year.

The new watchOS 2 requirement comes as the Apple Watch celebrates its first birthday. The gadget first began shipping on April 24 last year.

Apple didn't respond to a request for more information.

Update, 4:14 p.m. PT: Clarifies information regarding WWDC.

Close
Drag
Autoplay: ON Autoplay: OFF