KZPBA UWSCSI ADPT FOR APX

Quick Specifications

  • Compatibility Unix
  • Bus Type PCI
  • OS Required DEC OpenVMS 7.1 or later
    Microsoft Windows NT 3.51 or later
  • Type PCI
  • Type none

Discuss: KZPBA UWSCSI ADPT FOR APX