Tesla Model S Plaid arrives E3 2021 schedule Amazon Prime Day 2021 Best gifts for Dad Millions more stimulus checks sent

Q&A: MacFixIt Answers

We answer Mac-related questions about Flashback, network file permissions, Time Machine, and more.

MacFixIt Answers is a feature in which we answer questions e-mailed in by our readers.

This week people wrote in with questions about permissions errors after network file transfers, a system always booting to Verbose mode, the threat of the Flashback malware for iOS users and the potential for the removal tools to cause problems with Java installations, and Time Machine being stuck in a "Preparing Backup" mode after a crash. We welcome alternative approaches and views from readers, so if you have any suggestions, post them in the comments!

Question: Permissions errors after network file transfer
MacFixIt reader Tom asks:

My wife's white MacBook died during a backup...so I put in a new hard disk, and copied back a recent backup from MY MacBook. Then I added a new user in her name with admin privileges, and removed my account. Then I set that MacBook up for file sharing and, over our Wi-Fi, put back as many of her photos, documents, etc as I could find in a two-month-old backup from an external hard disk attached to my desktop Mac.

Ever since I've had trouble with permissions. If I drop a folder full of photos on her desktop by file sharing, she can't change the name of it or delete it. The contents, yes, but the folder has the permission "Nobody can read/write" in Get Info. Is there a way to clean up all the permissions on her MacBook so I can just drop stuff onto it without all the drama?

Have you tried resetting the home folder permissions for her new account? If not, try doing this as outlined in this article on home folder permissions.

Question: System always booting in Verbose mode
MacFixIt reader Rick asks:

I tried to defragment my HD using Drive Genius 3, and now my Mac starts up in verbose mode even when verbose mode is off. Can you guys help me please? Also, what's the topic/debate over defragmenting your Mac. Thanks in advance.

Verbose mode and other alternate boot modes are triggered by boot variables held in the PRAM, so try resetting the system's PRAM by restarting with the Option-Command-P-R keys all held down. Hold them until the system automatically resets, and then release them and allow the system to boot normally.

Generally Mac systems do not need to be defragged, as there is an automatic file management system that keeps files in contiguous 20MB chunks, so most files will not be fragmented. If you do want to try defragmenting your hard drive you can use a tool like iDefrag. Just be aware you might not see much benefit.

Question: The threat of the Flashback malware for iPhone and iPad users
MacFixIt reader Teresa asks:

Does the Flashback malware affect iPhones or iPads?

The iPhone and iPad do not run Java, so they will not be affected. While there is talk of Java getting to the iPhone at some point, so far it is not available for iOS, so iPhones and iPads aren't vulnerable to Flashback.

Question: The potential for Apple's Flashback remover to cause Java problems
MacFixIt reader Faye asks:

I'm concerned because I frequently go to chats which are Java-based (These are non-frivolous chats I've been attending for years). The chat rooms require a Java applet to run. Will [the Flashback removal tools] cause a problem? Would I be better off taking the manual route?

No, it won't harm your Java installation. It does not alter the Java installation at all, and only scans the system for known malware. Apple's removal option comes with a slightly updated version of Java (version 31, build 415 as opposed to build 414), but this should not affect the Java runtime's ability to run your applets should they be working properly for other builds of the latest version.

Question: Time Machine inaccessible and stuck in 'Preparing Backup...' status
MacFixIt reader Eric asks:

I am using a 1TB iMac with Lion OS. Recently, I've had two issues creep up with my Time Capsule and Time Machine. First, I lost power during a backup and I believe it corrupted the backup file. I have tried deleting the in-progress file but am unable to access it any way. Every time I try to delete the file I get an error code. The second issue is that Time Machine is stuck in preparing backup mode. This seems to correlate with when the power loss incident occurred. How can I remove the in-progress backup file and do you know if in doing such, will Time Machine be able to come out of preparing backup mode and finish a backup?

Have you tried using Disk Utility to check the Time Machine drive for errors? Try doing that first. If you can't fix the problem using Disk Utility then it is likely that the drive is corrupted to the point where the easiest solution would be to format the backup drive and start over.

Questions? Comments? Have a fix? Post them below or email us!
Be sure to check us out on Twitter and the CNET Mac forums.