CNET también está disponible en español.

Ir a español

Don't show this again


Q&A: MacFixIt Answers

MacFixIt Answers is a weekly feature in which we answer questions e-mailed in by our readers. We welcome alternative approaches and views from readers and encourage you to post your own suggestions in the comments.

MacFixIt Answers is a feature in which we answer questions e-mailed in by our readers. This week readers wrote in asking questions on optical media no longer working, the OS requirements for installing OS X 10.7 Lion, how to determine SATA controller link speed, and Keynote crashing because of font problems. We continually answer e-mail questions, and though we present a few answers here, we welcome alternative approaches and views from readers and encourage you to post your suggestions in the comments.

Question: CDs and DVDs no longer working
MacFixIt reader "mikart" asks:

My mac rarely reads DVDs and CDs unlike in the past...what might be the cause and how can i resolve it?

Try using compressed air to blow into the drive, in an effort to clear off any dirt or debris from the drive's lens. If this does not work then it is likely that your drive is failing and needs to be replaced. This is not uncommon for DVD drives.

Question: OS requirements for upgrading to Lion
MacFixIt reader Ann asks:

I currently have the "Leopard" version of Mac's operating system (10.5.8). Will I need to upgrade to Snow Leopard before then upgrading to Lion?

Apple has stated that Lion will be available only through the Mac App Store, which is only available on Snow Leopard (or later), so you will have to upgrade in order to download and install Lion. There may be workarounds to this that will appear in the future, but at this point there is no guarantee of alternatives, so your best bet would be to upgrade.

Question: SATA controller link speeds
MacFixIt reader Matthias asks:

Hello, I took off the Superdrive and mounted a second HD with a mounting Kit in my MacBook Pro Model A1297. I tried to capture video with FCP on this second drive at the SATA Controller for the Superdrive and FCP announced me that I lost Frames. Same procedure with a PCIe -> eSata Controller onto an external disk worked fine. Is there a difference in speed at the internal controllers?

You can check the link speed of the drive by going to the System Profiler, choosing "Serial-ATA" in the Hardware section, and selecting the controller. Under here you should see entries for the vendor, model number, link speed, negotiated link speed, and description. The hard drive in the new slot should not have read/write problems, and speed should not cause it to drop frames. It could be that your drive is faulty.

Question: Keynote crashing in one user account
MacFixIt reader Andy asks:

Keynote 09 keeps crashing! I've tried everything -- searched the web - apparently a number of folks have this problem -- on the latest os 10.6.6 latest 15 inch macbook pro (Feb '11); I read somewhere about font conflict and disabled some user fonts -- it works fine when I create a new user account. I have repaired permissions, used ONYX, and trashed Keynote preferences, but nothing works. Any ideas? Here's the crash log:

Process:         Keynote [1096]
Path:            /Applications/iWork '09/
Version:         5.0.5 (942)
Build Info:      Keynote-9420000~2
Code Type:       X86 (Native)
Parent Process:  launchd [155]

Date/Time:       2011-06-17 00:31:21.746 -0400
OS Version:      Mac OS X 10.6.7 (10J3250)
Report Version:  6

Interval Since Last Report:          7244 sec
Crashes Since Last Report:           3
Per-App Interval Since Last Report:  82 sec
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      1DC1660D-CF0E-4B7F-8B73-E90C6EB1ECF3

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000044
Crashed Thread:  11

[removed code]

Thread 11 Crashed:
0   libTrueTypeScaler.dylib           0x90d76957 fnt_SH_Common(fnt_LocalGraphicStateType*, long*, long*, int*) + 61
1   libTrueTypeScaler.dylib           0x90d76904 fnt_SHP(fnt_LocalGraphicStateType*) + 29
2   libTrueTypeScaler.dylib           0x90d72668 fnt_InnerExecute(fnt_LocalGraphicStateType*, unsigned char*, unsigned char*) + 89
3   libTrueTypeScaler.dylib           0x90d72ec7 fnt_CALL(fnt_LocalGraphicStateType*) + 203
4   libTrueTypeScaler.dylib           0x90d72668 fnt_InnerExecute(fnt_LocalGraphicStateType*, unsigned char*, unsigned char*) + 89
5   libTrueTypeScaler.dylib           0x90d725c9 fnt_Execute(fnt_ElementType**, fnt_GlobalGraphicStateType*, unsigned char*, unsigned char*, void (*)(), memoryContext*, unsigned char, unsigned char, unsigned char) + 466
6   libTrueTypeScaler.dylib           0x90d72c60 RunPreProgram(fsg_SplineKey*, transformState const*, void (*)()) + 310
7   libTrueTypeScaler.dylib           0x90d722f9 CreateGlyphElement(fsg_SplineKey*, long, unsigned char, unsigned char) + 344
8   libTrueTypeScaler.dylib           0x90d6f471 CreateScalerGlyphBlock(fsg_SplineKey*, memoryContext*, scalerGlyph const*) + 229
9   libTrueTypeScaler.dylib           0x90d6f2db AssureGlyphBlock(fsg_SplineKey*, memoryContext*, transformBlockCacheNode*, scalerGlyph*) + 180
10  libTrueTypeScaler.dylib           0x90d6b4e5 TTGetStrikeSpecs + 598
11  libFontParser.dylib               0x98fe7906 TConcreteFontScaler::GetFontMetrics() const + 46
12  libFontParser.dylib               0x990324d1 TConcreteFontScaler::GetATSCompatibleMetrics(int&, int&, int&, int&, int&, int&, int&) const + 25
13  libFontParser.dylib               0x98fe8b27 FPFontGetGlyphsForUnichars + 428

The problem you are experiencing is definitely with the handling of fonts; the system is crashing when it is calling the functions for parsing and scaling true-type fonts. This could arise from having either corrupt fonts on your system or duplicates. Have you used Font Book to run a font verification on the fonts in your system? If not then you can do this by selecting all your fonts in the Font Book program (press Command-A) and then choosing "Validate Fonts" in the File menu.

Do you have any fonts in your /username/Library/Fonts/ folder? If so then try removing them and starting Keynote again. If these fonts are conflicting with system fonts then it may cause these types of problems.

Questions? Comments? Have a fix? Post them below or e-mail us!
Be sure to check us out on Twitter and the CNET Mac forums.