Using Vista here, and when I right click an existing ZIP folder I have, and select Properties, I see that it says "Opens with: Windows Explorer". I suspect that gives the zip file it's folder icon.

Why don't you try this. Highlight a ZIP file, right click and select "Open with". Browse to "%SystemRoot%\explorer.exe", and select that.

If it works, do the same again and select the "Always use the selected program to open this kind of file" option.