Computer Help forum

General discussion

XP Won't Boot in any mode

by 475MBlack / November 1, 2010 3:30 AM PDT

Last Monday a fake Microsoft Security Essentials alert popped up, closing firefox saying it was a dangerous virus threat (lol). I tried to remove it with Malwarebytes antimalware but the virus kept closing it and locking it so I couldn't open mbam back up. I tried using Bleepingcomputer's rkill as a .com and renamed as ieXplore.exe and eXplorer.exe. rkill apparently did what it was programmed to do but the virus kept opening back up. I tried reinstalling mbam several times, but each time I ran the program, it was shut down by the virus. I tried to open mbam in safe mode but the virus popped up in safe mode too. I went back to normal mode and tried several different anti virus programs (S&D, Emsisoft, I was going to install Panda Cloud but I can't remember if I actually did) but all were shut down after starting a scan. I think that one scanner wasn't shut down (can't remember which) but my computer froze while it was scanning so I was forced to hit the restart button on my machine. I went back into Windows and tried the scan twice more but each time it froze forcing me to restart.
Here is where the my main current problem begins. After restarting for the third time I tried to enter Windows and it wouldn't load in any mode. For normal mode it stops at a blank black screen, and in safe mode it stops loading the files at a certain file (I'm away from my computer right now so I'll post the file name later today). After this I found the Ultimate Boot CD for Windows and I'm currently running off that. I loaded the CD and ran S&D several times until it turned up clean. But I still couldn't load Windows. Then I found this: http://msinfluentials.com/blogs/jesper/archive/2008/05/08/does-your-amd-based-computer-boot-after-installing-xp-sp3.aspx

Now I was following this part:
[QUOTE]If you booted into WinPE, you have to manually edit the registry. Do this:

1. Run regedit
2. Click on HKEY_LOCAL_MACHINE
3. From the File menu, select "Load hive"
4. Navigate to %systemdriver%\Windows\System32\Config on the dead system and select the file name System
5. Name it something you can remember, such as "horked"
6. Navigate to horked\<the current control set>\Services\IntelPPM. See below for how to determine which one is the current control set.
7.
Double click the Start value and set it to 4
8. If you did what I did and completely destroyed things by running a disk check, navigate to <the current control set>\Control\SessionManager. Open the BootExecute value and clear out the autochk entries
9. Reboot

Step 6 asks you to navigate to <the current control set>. Under HKEY_LOCAL_MACHINE\SYSTEM there are typically at least two numbered control sets, and sometimes there are up to four. They are called ControlSet001, ControlSet002, and so on. Control sets hold all the configuration data for the computer, including all drivers that load. One of them is designated the current one, and the others are backups of previous configurations that worked. The control set that is currently used as the current one is the one listed in the "Current" value under HKEY_LOCAL_MACHINE\SYSTEM\Select. That is the control set that you need to modify in step 6. If you modify one of the other control sets it will not solve the problem. You need to modify the current one. If you manage to boot the computer, CurrentControlSet will be a pointer to the current one and you can modify that one. If you boot from the recovery disk you have to figure out which one is the current to modify the proper one. It will not always be ControlSet001.

If this was your problem, the computer should now reboot just fine.[QUOTE/]
While I didn't find the IntelPPM file I did find that I had 4 ControlSets. Now this could be normal but the 3rd and 4th ControlSets are apparently duplicates of the 1st and 2nd, respectively. I say apparently because I haven't gone over every single entry seeing if "A=A, B=B" etc. But from just eyeing the ControlSets they appear to be duplicates.
Please help.

Side Note: this is a similar thing that happened about 2 months ago when I couldn't boot Windows (there was no virus, just freezing programs). I tried a repair install, but it didn't work. Ultimately I ended up reinstalling Windows with a sp3 slipstream. I want to avoid that option, if possible, because it was a real pain going through that.

Windows XP 32-Bit SP3 (OEM)
2GB RAM
1TB HDD (Split roughly into half for partitions)
AMD Athlon 64 x2 Dual Core 4000+ Processor @ 2.11GHz

Discussion is locked
You are posting a reply to: XP Won't Boot in any mode
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: XP Won't Boot in any mode
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Forgot to mention
by 475MBlack / November 1, 2010 3:33 AM PDT

My PC is home built. Even though it has a oem I didn't purchase a computer from HP, Dell, etc.

Collapse -
In Such Situations Here..
by Grif Thomas Forum moderator / November 1, 2010 4:07 AM PDT

..we first attempt to run a repair install of the operating system using the Windows CD or the slipstreamed SP3 disc. There should be no reason why a repair install doesn't work unless you're using an older version of XP on the OEM disc .. If needed, here are those instructions, either screenshots included:

http://www.windowsxphome.windowsreinstall.com/installxpcdrepair/indexfullpage.htm

One other thought.. I don't see where you attempt to run "Last Known Good configuration" from the F8 boot options.. It might be worth a try.. Restart the computer and immediately start pressing F8 till a selection screen loads. Once there, use the up/down arrow keys to select "Last Known Good Configuration", then press the "Enter" key.. It should restore back to a time when things worked correctly.

Hope this helps.

Grif

Collapse -
Last Known Good Config
by 475MBlack / November 1, 2010 9:52 AM PDT

I tried Last known at one point but it didn't work. But that was before it couldn't boot so I'll try that in a little bit, I have the boot cd scanning for viruses right now.

Collapse -
Repair Installation...
by 475MBlack / November 2, 2010 8:53 AM PDT
In reply to: Last Known Good Config

...Didn't work.
Well, it "worked" it finished in the DOS-style mode, but after it reboots to finish in GUI I still get the blank black screen.

Collapse -
Since This Happened Once Before...
by Grif Thomas Forum moderator / November 2, 2010 9:37 AM PDT
In reply to: Repair Installation...

...and you fixed the problem by running a full format and reinstall, I'll guess the hard drive is heading south.. The full format allows the system to identify and "work around" the bad sectors and reinstall itself.. Eventually, the drive gets worse and you have the same thing happen again.. Although it's not what you want to hear, I'd replace the hard drive and reinstall from scratch.

Hope this helps.

Grif

Collapse -
Yep, That's the last thing I want to hear
by 475MBlack / November 2, 2010 9:43 AM PDT

Last time I didn't format the entire drive. I just made a new partition and installed Windows, and then moved my files over.
In fact I still haven't deleted the old partition yet, just in case I missed a file that I needed.
I'm thinking about getting an external drive to copy all of my files to it and then completely format my internal drive. Should I? Or will I just be back here in another 2 months complaining that Windows won't boot?

Collapse -
Your Choice...
by Grif Thomas Forum moderator / November 3, 2010 12:28 AM PDT

..but new internal hard drives are fairly cheap and if your current one does fail, it's possible you'll lose data.. Only you can decide how important your personal files, pictures, and music are.

Hope this helps.

Grif

Popular Forums
icon
Computer Help 51,912 discussions
icon
Computer Newbies 10,498 discussions
icon
Laptops 20,411 discussions
icon
Security 30,882 discussions
icon
TVs & Home Theaters 21,253 discussions
icon
Windows 10 1,672 discussions
icon
Phones 16,494 discussions
icon
Windows 7 7,855 discussions
icon
Networking & Wireless 15,504 discussions

REVIEW

Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.