uninstall the lan driver on your laptop and restart and let it reload the driver. you also need to right click on any folders you want to share in xp and choose the sharing and check the boxes to share. make sure you have different computer names on each computer but the same workgroup name like MSHOME or something. run the setup wizard in xp network places. the first computer on your router choose custom and connects directly to the internet. the second and rest of your computers choose connects directly or through a network hub. make sure in xp network connections you have the xp firewall off. go into properties and click advance tab and uncheck firewall. then restart your laptop. skip