Windows 10 forum

Question

Wrong time displayed in Windows 10

I have Windows 10 Home version 1607 build 14393.321 installed on my Lenovo Z51-70 80K6.
My displayed time is always 2h behind.
The time is set to sync automatically.
The time zone is set to UTC+1 Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna.
Daylight savings time is set to adjust automatically.
The internet time server is set to be: pool.ntp.org. I also had the same issue also when it was syncing to time.microsoft.com, so this is not the problem.
If I sync the time manually it will display the correct time, though it switches back to the wrong time when I restart it and I have to sync it manually every time.
I already tried using services.msc and setting Windows Time to automatic, but it didn't work.
I have dual boot Windows 10 - Ubuntu 16.04. In Ubuntu time is correct. So this is not a hardware problem, it's a Windows 10 bug.
Prior to installing Ubuntu I had the same time issue, so it's not the case that the Ubuntu installation messed up.
Example: it's 20:44 right now, but it displays 18:44, unless I sync it manually every time.
Date is correct.
How do I solve this? Have I missed any information?

Discussion is locked
You are posting a reply to: Wrong time displayed in Windows 10
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Wrong time displayed in Windows 10
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Since it works after the sync.

In reply to: Wrong time displayed in Windows 10

I'd try other time servers. Also I ran into this with an overreaching security suite when it was set to maximum security.

Remember it's not a bug if there's a time server or security issue. This can inflame folk that want to find a Windows bug.

Also, I was able to duplicate this by booting (it was a few years back) to a Linux and then to Windows. It seems the two OSes disagree on the RTC setting so you get this apparent bug. I don't consider it a bug.

Collapse -
other time servers also yeld the same result.

In reply to: Since it works after the sync.

it's ok right after syncing, but the clock is behind by 2 hours aftrer rebooting.
i've had this issue ever since i got the pc, that is last week. even prior to dual booting the clock would display -2h after rebooting. this is independent on the operating system, it also happened when i only had windows. so this is not a problem of dual booting, as i said in the original post

Collapse -
I was able to recreate this issue.

In reply to: other time servers also yeld the same result.

I'll repeat I don't think it's a bug but how things work. I had to recall how I deal with it, google some more to get you an article that was clear about how to make it work (see the howtogeek and other places.)

-> Do you think that today, we shouldn't have to tweak like this?

Collapse -
Clarification Request
Remember I don't call it a bug. Read this idea to fix it.

In reply to: Wrong time displayed in Windows 10

All Answers

Collapse -
Answer
re:

In reply to: Wrong time displayed in Windows 10

Check to make sure the BIOS also has the correct time.

Collapse -
There's a thing.

In reply to: re:

Collapse -
Answer
Solved

In reply to: Wrong time displayed in Windows 10

Thank you all for replying!
I found a solution to my issue in another forum where they directed me to this wiki. I put the links so other users in my situation can hopefully solve this ussue. I fixed the registry as suggested adding a QWORD (for 64-bit system) with value 1. Which is by the way similar to what some of you suggested. More info on the procedure in the link to the wiki. Now time is fine both in Windows and Ubuntu.

Collapse -
Re: solved

In reply to: Solved

I would have done it easier. In my Windows 10 settings, the time zone is set to manual (not automatic), so setting it to UTC+3 (Bagdad, Minsk, Moscow, Nairobi, etc) would add the missing 2 hours without a long search for a registry fix.

When the summertime ends you might need a one hour correction, but it's not yet proven that is not necessary with your solution.

Collapse -
We'll see...

In reply to: Re: solved

Daylight saving time ends on Oct, 30th here and the clock seems to have detected this: it's notifying me about this. It should make the one-hour correction, otherwise I will post about this or other issues. Thank you!

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.