General discussion

Workgroup is not accessible. You might not have permission

I have the following problem:
- I have a home network which consists of 3 desktops
- 2 of the units run XP Pro SP3, 1 unit runs Vista
- 2 of the units, the XP machines, are connected by wire to a router; the Vista machine is wirelessly connected to the router
- all 3 units connect to the internet w/o a hitch
- 1 XP desktop and the Vista unit can see each other in the workgroup I've defined and can share files and printers w/o any problems at all
- the other XP desktop can see the workgroup, but cannot open it; you get the error message as in the subject title of this thread
- unfortunately, this is the main machine in the house and most of the peripheral hardware (B&W laserprinter, colour inkjet printer, 1TB external HDD) is connected to it, which means that all of that stuff is inaccessible to the other users!
I'm more or less at my wits' end. It all used to work seamlessly and suddenly, from one day to the next, it went pear-shaped. I'm running virus and spyware scans from just about every package I can lay my hands on to discover whether that causes the problem, so far completely w/o any success at all.
Can anybody please, please, shed some light on this?

Discussion is locked
Reply to: Workgroup is not accessible. You might not have permission
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Workgroup is not accessible. You might not have permission
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
Just the basics.

I see you have browsing of the network working but no where did I see you write about the accounts.

IN SHORT -> If your account is called bob then bob must have an account on the machine he wants to attach to or that message should occur.

In closing. Its a common issue so let's see what you are doing about accounts.

- Collapse -

Bob, thnx for the reply. I realise I haven't been complete in my description of the problem:
Normally when you try to to browse a workgroup in the network, at the very least you can see the machine you're working currently from, if you have declared it as a member of the workgroup, that is, which I have done. Well, I cannot even see myself, because I cannot get access to the workgroup at all. So to be clear, it's not just that I cannot access from another pc in the network, I cannot get access to the workgroup from the main pc in the house.

The other thing I'd realised is that there is an additional piece of information that may be relevant. The complete error message when I try to open up the workgroup from the main pc is:

"<Workgroup> is not accessible. You might not have permission to use this resource. Contact the administrator of this server to find out if you have access permissions.

Incorrect function."

Does that ring a bell with anyone?

- Collapse -
So browsing is dead?

That's a sign of a firewall. Again my reading of the post does not find what firewall is in use. And I will not offer how to configure your firewall to allow network shares and browsing (well discussed area.)

There is also issues if you are doing this over WIFI. Let me toss out the name of this so you can say it's not or is in play. "Client Isolation."

There are also SERVICES that must be running for all this to work and the firewall in the router set to allow browsing and network shares.

I know it sounds cruel or short but I can't ask all the questions as this is not tech support. This is more like someone that stopped to help you change the tire. They may not know where the spare tire is so you go get it for them.

-> Yes it's a common headache of networking with a long list of things to check. The problem I'm running into today is that many owners tinker with services, run registry cleaners and install firewalls (that they don't know how to configure.) Here's the drill:

1. Set services back to default. Read
2. Set the firewall to allow networking. (sorry, but as there are dozens of firewalls and versions of each I ask you to figure this out.)
3. Set the name of the network to be a single word.
4. KNOW the accounts issue. This is also a stumbling block for many new networkers as it can be the cause of the browse issue. My patience is getting thin on the accounts issue.

- Collapse -

Bob, far be it from me to try your patience on accounts or anything else for that matter. To go thru you points:
- Firewall: has been completely disabled in my desperation, even tho' the network worked fine earlier with it enabled
- WIFI: it's one of the wire connected pcs that's the problem here
- Services: have been reset to default
- Where do I go to find out about accounts? NB: I haven't tinkered wiht any account anywhere, but my file & printer sharing ceased to work overnight anyway

- Collapse -
Accounts is simple.

You are logged in as "somebody". Now over at the other machine you log in as that somebody.

As many forget these accounts can expire and then what worked before stops working. This is why we do the log in test.

-> Have you done the log in as "somebody" test? And repeat for each account name that you use.

- Collapse -
PS. To disable password expiring.
- Collapse -

Rob, thanx. However, I'm a bit puzzled. I cannot even see myself on my own machine in the network and since I'm always logged in as myself on my own machine, there can hardly be any confusion about my user name can there?

- Collapse -
The browser service and more.

Sorry but I can't find where you completed the login test on the machine you want to connect to the share.

As to why your machine does not show, tell the forum about the share you created.

- Collapse -
Just so we're clear.

The network browsing could be as simple as the MASTER BROWSER is not your machine and your account on the other PC has an expired password.
It would be a shame to go so long without testing if you can login on each machine that is on the network.

There is another item and that is these firewalls. It is not good enough to disable some like Zone Alarm as I've caught them still working even when they are disabled. I never offer how to configure a firewall as that would be duplicate web pages and manuals. The short answer here is to allow local traffic.

- Collapse -
Shares etc


To be specific: I have 3 machines

- 1 is called Study4 and runs XP Pro SP3; it is connected to the workgroup FAMILY
- 1 is called Playroom_3 and runs XP Pro SP3; it is connected to the workgroup FAMILY
- 1 is called Pieps; it runs Vista and it is connected to the workgroup FAMILY
- Pieps and Playroom_3 have complete file and printer sharing
- Pieps and Playroom_3 can see that a machine called Study4 exists in the workgroup FAMILY but there's no way they can get at it
- Study4 can see that a workgroup called FAMILY exists in Microsoft Windows Network, but it cannot penetrate inside the workgroup, not even to see itself there

- Collapse -
Which I can duplicate this error with ease.

Either you have a firewall up (router or somewhere), someone turned on client isolation (see google) or it's the same old account issue.

I'm a little dazed here. Why isn't the login check done on each machine?

To recap.

Let's say I'm bob on my machine. I walk to each machine in the workground and log out who's there then log in as bob for a test. Seems simple yet I've seen 20 and more posts in long drawn discussions and this one simple test is avoided.

Why is that?

- Collapse -


I didn't think this could be the issue, simply because it already fails at the first test: the machine itself is not visible in Microsoft Windows Networking in its own Windows Explorer window. So you don't need to go to another machine to test whether you can see it when everyone is logged in under the same name, when the machine cannot even see itself.

Also, previously, networking worked just fine when I was logged in as 'Frank' on 'Study4', my wife was logged in as 'Caroline' on 'Playroom_3' and my youngest daughter was logged in as 'Eline' on 'Pieps'.

Nevertheless, I did as you suggested, but no joy I'm afraid. The result is exactly the same as before.

- Collapse -

There is the issue of the Master Browser which may not be on your machine. I have offered a simple test and it appears it will not be done.

Again, the master browser (a windows networking thing) may not be on your machine so the account issue can be still in play.

I'll unsubscribe and let others try.

Good luck,

- Collapse -
I don't understand!

I don't understand why I need to go to other machines when the machine cannot even see itself! I would understand if the machine _could_ see itself, but could not be detected from other nodes in the network, but that is not the case here.

Anyway, where do I find the MASTER BROWSER?

- Collapse -

Bob, BTW I _did_ perform the test you suggested, but it didn't do any good.

- Collapse -
The next test is to open a command line.

The command we try next is NET VIEW (read )

As we spent so much time on getting the password and account check done I must reduce my replies to short as possible.

- Collapse -

NET VIEW yields:

"System error 1 has occurred.

Incorrect function."

- Collapse -
I only encountered that one years ago with

Norton. You claim you disabled the firewall but was Norton ever on this machine? Actually any expired protection software or damaged "stack" will provoke this error. Yes, Mcafee has done this too.

Research how to remove and reinstall TCPIP in XP. Here's some starter material.

Be aware I also know of trouble with SFCure and other such things. Share if you tried such.

There are dozens of reasons for this failure. Let's nail down one common cause. No "localhost". Try this.

ping localhost on a command line and if it fails, fix your hosts file.

- Collapse -
In sequence

I'll take those in sequence:

- Norton has never been near this machine, nor has McAfee; the machine has seen security products from AVG, PCTools & NOD32
- Do you want me to remove TCP/IP & re-install?
- Never heard of SFCure; hasn't been anywhere near this machine
- pinged localhost: no problems there

- Collapse -
That's progress.
- Collapse -
More reading.
- Collapse -
I followed up on the reading you suggested

I followed this one:

"Everyone having this problem should follow this...
You must have administrator rights to do this.
Enable the IPX/SPX protocol and follow all instructions.
To enable file and print sharing on the IPX/SPX protocol
Only perform this procedure if your home or small office computers are connected directly to the Internet through individual connections or using a DSL or cable modem connected to an Ethernet network hub.

1. Open Network Connections.
2. In Local Area Network, Right click on top of your connection and select Properties, click Install.
3. In Select Network Component Type, click Protocol, and then click Add.
4. Click NWLink IPX/SPX/NetBIOS Compatible Transport Protocol, click OK, and then click Close.
5. In Network Connections, on the Advanced menu (on top menu bar), click Advanced Settings.
6. On the Adapters and Bindings tab, under Connections, click the local area connection on which you are enabling IPX/SPX file and print sharing.
Under Bindings for Local Area Connection, under File and Printer Sharing for Microsoft Networks, clear the Internet Protocol (TCP/IP) check box, and then click OK."

and it seems to have done the trick! I'm going to keep my fingers crossed and hope it lasts.

Thanx for the advice, hope I haven't bored you too much.

- Collapse -
Finally Found a Fix

I know this is an old discussion but it may help somebody else that might stuble across it. I tried about half a dozen fixes including the official MS fixes that i found online and nothing worked. Like the orig poster, everything was fine then one day my win xp machines generated the error above. The fix: i created my own domain name. The default "Workgroup" "MSHome" and "Homegroup" all resulted in an error while any random name i added solved the problem. Also need to add a password to both the client and server machines.

CNET Forums