Samsung forum

General discussion

Workaround for MKV Subtitle (LE32B650)

hi there,
for a couple of weeks i had the problem, that extracted subtitles didn't show up. after browsing in here a bit i got an understanding of the problem and with a little more research and some trying i found a workaround for it. i already tried it a couple of times and it works for me.

1. download and unzip mkvtoolnix on your system
2. start a command line and browse to the folder
3. use the following command: mkvextract tracks "<Path>" 3:sub.***
> Example: mkvextract tracks "C:\Video.mkv" 3:sub.***
> Another Information: if the file has more than only one subtitle and you may want to extract another, open up the mkvtoolnix gui program ( called 'mmg.exe' ) and drag'n'drop the video file in it. what you're now looking for is the ID of the subtitle you want to extract. check out the window for 'tracks, chapters and tags' and search for the subtitle. if it's the id 4 you was looking for, use 'mkvextract tracks "C:\Video.mkv" 4:sub.***' instead.
4. when done you have your subtitle file. normally it should work, if the name is exactly of the video file, but it doesn't, so get Subtitle Workshop and install it
5. open up the program, load the subtitle and save it as it is as a "SubRip". the file will have the extension ".srt".
6. place the file in the same folder as the Video File and name it exactly alike.
> Example: "Video.mkv" and ""
7. make sure no other files with the same name as the video file is at the folder and connect the usb/harddisk to the tv.
( 8. the subtitle might show up a bit to small, but via 'tools' and 'subtitle' on the remote control of your tv, you might enlarge it a bit. )

i hope this will help some users to get the wanted subtitles to show up. maybe this workaround may work for other systems, too, as there are no changes to the tv itself but only the video/subtitle file.

if you're beginners with the command line, copy this into an editor and save it as named. you should have unzipped the mkvtoolnix to the folder "C:\Program Files\mkvtoolnix" then.
cd C:\Program Files\mkvtoolnix
@echo off
echo HOW TO:
echo ~~~~~~~~~~~~~~~~~~~~~~~~
echo 1. mkvextract tracks "<PATH>" 3:sub.***
echo 2. open subtitle workshop, load file and save as SubRip ( *.srt )
echo 3. copy subtitle file to video folder and rename it exactly alike

the script file ended above. Wink


p.s.: if i find a way to implement those steps into one little program, i will edit this post with it.

Discussion is locked
You are posting a reply to: Workaround for MKV Subtitle (LE32B650)
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Workaround for MKV Subtitle (LE32B650)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
thnx for tip

In reply to: Workaround for MKV Subtitle (LE32B650)

sweet this works...gj on the tips

Collapse -
Awesome !

In reply to: Workaround for MKV Subtitle (LE32B650)

Awesome ! It worked for me. The only thing I did different was using MKVExtractGUI.
It outputted an .SRT file that did not have the same name as the movie.
So I thought I'd just rename it using Windows, but the subs didn't play on my TV.

After using the suggested Subtitle workshop it worked fine !!
I was wondering why manually renaming wouldn't work ??
The file is exactly the same size and looks exactly the same if I edit it.

Many many thanks. I'm finally enjoying Braveheart with Dutch subs !

Collapse -
Spoke too soon :(

In reply to: Awesome !

Damn. Tried the same with Sucker Punch and Harry Potter, and now the first few subs are showing,
and then suddenly they don't Sad

After 10 minutes or so they show up again. I checked the files in Subtitle Workshop, and they seem fine.

Any ideas ??

Collapse -
Firmware upgrade recommended ?

In reply to: Spoke too soon :(


I just found out I can download firmware. Is it a wise thing to install ?

It's a shame that there's no changelog Sad

Collapse -
For those that want more codec or such support.

In reply to: Firmware upgrade recommended ?

If you follow the postings it appears that firmware never adds more codec support but corrects a bug. There are some consumers that expected TVs to follow some upgrade path like our PCs. That appears to cause some a lot of pain.

Collapse -
But this is a bug isn't it ?

In reply to: For those that want more codec or such support.

But is this a problem with the codec ? IDK really. The strange thing is, for one movie it works and
for another it doesn't. That sounds like a bug to me.

An uncle of mine also has a Samsung tv, and had the same problems and
a firmware upgrade did fix his subtitle issues.

I'm just a bit reluctant to try it, because I'm reading some people have issues after upgrading.

Anyone else with an UE37D5720 who has the same issues ?

Collapse -
No it's not.

In reply to: But this is a bug isn't it ?

After fixing far too many subtitle files I can now write that it's no bug. That is, I had to manually comb over the file with a text editor and figure out why it failed.

But I agree that most folk would call that a bug but then again you could call the person who created the subtitle the source of the bug.

I also agree that most folk don't want to learn about this in any depth.

Collapse -
fair enough

In reply to: No it's not.

Ok, so what your saying basically, is that the .srt file is corrupt somewhere ?

I am not one of the 'folk' that's not willing to learn about this, and I'm searching for
hours every day, trying different things, but I simply cannot get it fixed.

You seem to be somewhat of an expert on the matter.
Could I bother you to take a glance at below file ?

It goes wrong at::

00:01:07,916 --> 00:01:10,428

This line doesn't show, and until about 10 minutes further there are no subs showing.
If looked to the whole file about 5 times, but cannot find anything strange unfortunately Sad

Collapse -
I fixed it !! Yay !!

In reply to: fair enough

I cannot believe it, I actually fixed it !
First I did a firmware upgrade, which didn't work.

Then I decided to give every movie it's own folder. After changing that it works !!
I guess the tv gets confused it there are different .srt files in one directory.

Never knew that. I always tough it would look if the movie filename and the subtitle filename were the same.

@R.Prroffit: I hope you haven't started combing through my file yet. There's nothing wrong with it.

Collapse -
Ahh. Multiple SRTs. There be dragons here.

In reply to: I fixed it !! Yay !!

There is only ONE srt allowed per movie. And to avoid the dragons I learned to keep the file names short. For example I might bet if the folder had....


That you could possibly cause a problem. Just we can't see behind the curtains to check if the man is pulling the right levers.

Collapse -
Had another odd encounter

In reply to: Ahh. Multiple SRTs. There be dragons here.

I was watching Sucker Punch(.mkv and this time after 20 minutes the subs vanished into thin air. It seems the TV does some sort of checking every 10 minutes..
I had the file Sucker in the same directory which I stored before fixing some really bad translations in the .srt file.
I think for some reason the Samsung freaked out because of this and stopped playing subs.
After removing the .org file all was good.

Really picky telly isn't it Happy

Collapse -
Sorry but that is too close.

In reply to: Had another odd encounter

We can't discuss content that is not available in MKV form. The forum policies mean that we'll just have to lock this. Feel free to discuss items not forbidden in your new post.

Popular Forums

Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.