You should research this on Google. A common comment is "WP 10 is not entirely compatible with XP"

As such, I'd move to something compatible.

Bob