Question

Wont start/post/boot, bad mobo?

About a week ago I spilled some koolaid on my computer (I built this computer about 8 months ago with 0 problems on my first build Happy. It didn't look like much got on my computer, but being safe I unplugged everything and waited for it to dry/wipe it up before turning it back on. When I turned it back on it was on for about 2-3 seconds then shut down. Ever since then it has not started up. I will get a single click noise from the PSU every once in a while, when pressing the power button. I have tried switching out the PSU and that does not change anything. I actually purchased a brand new one, originally thinking my psu went bad, and same result... However, if I unplug the 4 pin CPU power cord, all of the fans and power supply and everything gets moving and going, its just a black screen because no cpu power.Now I'm thinking it could be a bad connection on the mobo? Im not that tech savvy so be easy with me guys. Thanks!

Discussion is locked
Follow
Reply to: Wont start/post/boot, bad mobo?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Wont start/post/boot, bad mobo?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
One more test.

You proved there is some failure on the motherboard and what's on that board as a final test try a power up with just the board and the PSU. No CPU, memory, HDD, ODD required.

- Collapse -
clarification please

Can you be more specific? I already tried starting it up with just the psu and the 24 pin mobo connection, and everything started up with bells and whistles. Just when I plug in the 4 pin cpu power cord thing, not one thing happens when I turn it on.

- Collapse -
Then no.

It sounds like it needs repair. Get estimates. Or replace the parts that don't work.

CNET Forums