Windows Legacy OS forum

General discussion

wmpnetwk.exe keeps tying up my resources!!!

by NLFlower / January 1, 2007 3:28 AM PST

Hello to all and Happy New Year!!! I noticed lately my computer has been really dragging. At some point I decided to do the ctrl-alt-del thing and noticed in the "processes" list that there was something called wmpnetwk.exe that was using up all of the processor. I wasn't sure what it was at first (thought maybe malware), but after checking out some search links I'm under the impression it is something related to media sharing with WMP11. I've had WMP installed for awhile and this just started recently. Severaly times I've ended the process, but as soon as I notice my computer dragging again, I check and I see the wmpnetwk.exe process running. How to I shut it down? I'm guessing it is required for some things, but can I put it temporarily on hold until I actually need it? Thanks for any help you can provide. Consider me an intermediate level (in terms of knowledge) end user. Thanks again.

WinXP Pro SP2

Discussion is locked
You are posting a reply to: wmpnetwk.exe keeps tying up my resources!!!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: wmpnetwk.exe keeps tying up my resources!!!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Link to other discussion about this (fixed too)
by R. Proffitt Forum moderator / January 1, 2007 3:30 AM PST
Collapse -
reply to: wmpnetwk.exe keeps tying up my resources!!!
by noir_dreams / January 10, 2007 6:25 PM PST

I've had the same problem. Try one of three things

NOTE: Obviously you won't be able to share media with you xbox 360 etc if you do any of this or try TVersity (which I believe is much better).

1. In Windows Media Player turn off media sharing

in the library tab right click on it > click "media sharing" unclick the media sharing tab and click ok

2. Turn off the "WMPnetwk.exe" service
Under the "RUN" command in the start meni type "services.msc"
Scroll down to "Windows media player network sharing"
Double click and under startup type set to disabled

3. Uninstall Windows Media Player 11...I mean if after 11 versions it still doesn't work right then its probably not gonna is it!

Hope this helps

Collapse -
Windows Media Player
by angelia584 / December 7, 2007 7:24 AM PST

Thanks sooo much for the instructions on turning off media sharing..... My CPU usage was up to 100% and as soon as I turned media sharing off it dropped to 4%... I can't thank you enough..

Collapse -
Thank you!
by bephoebe / January 19, 2008 12:04 AM PST

I just found this message, same problem as original poster. Fix worked great. Thank you Thank you Thank you!!

Collapse -
Thank you
by Sunflower776 / February 16, 2008 11:07 AM PST

Thanks so much for you advice on disabling wmpnetwk.exe. My computer is running better already.

Collapse -
Thanks - good advice
by dowtchaboy / March 10, 2008 8:56 PM PDT

Thanks - I disabled media sharing - my XP is much snappier and happier now. Good tip. Maybe I'll dump Media Player soon too - rarely use it. P@

Collapse -
One possible cause of problem.
by rcorman / May 19, 2008 2:57 AM PDT
In reply to: Thanks - good advice

I just ran across this problem when I upgraded my system. After many hours I was able to fix it.

The problem on my computer was a corrupt .AVI file. Once I deleted that file, my wmpnetwk.exe stopped using 100% cpu.

From what I have read, Windows tries to read the information for the .avi file, and that info is stored at the end of the file. When the file is corrupted, Windows can't read that info and the computer goes into some endless retry mode, which causes it to use all the cpu resources.

Collapse -
rcorman you are alright
by lifeisinmotion / July 4, 2008 11:04 AM PDT

hi guys, rcorman is absolutely right about this issue. We have been streaming to our xbox360 for 6 months and can't go back. When our computer slowed to a REAL crawl and I found wmpnetwk.exe was working at 80%CPU it was frightening as we don't want to remove WMP11 (believe it or not, i know i never thought i'd be saying that).
In fact rcorman was right about it being a corrupt .avi file. The night before all this happened I d/loaded 2 torrents that were questionable (trying to utilize all my bandwidth) incl. the whole collection of Monty Python Flying Circus sketches. When my PC stopped working and wmpnetwk.exe was dragging it down, ending the process did not help. The wmpnetwk.exe would be back working hard as ever within 10-20 seconds. I must have removed it 50 times! After reading this I deleted the .avi files i got last night and at that moment the process began running normally, my PC is fine! I have re-enabled WMP11 media sharing now and everything is working fine. Thanks guys but the answer is not removing WMP11. I am however curious of the alternative app you mentioned.

Collapse -
rcorman & lifeis are correct
by jgl6606 / August 9, 2008 2:37 AM PDT

I also experienced the same issue after adding my 1st season of Hero's (in .AVI files) to the WMP11 library. Noticing my system running horribly slow, I checked the processes & found a process, wmpnetwk.exe running under NETWORK SERVICE consuming up to 99% of my CPU & the I/O Reads were through the roof!! After removing all the files, wmpnetwk.exe did not consume ANY of the CPU & the I/O Reads dropped to only 56 after about 15 min!! After replacing the files in the library one at a time, I found the file causing the trouble & re-ripped it from the DVD, put it back in the library & presto, the PS3 & WMP11 are in sweet harmony once again. Thanks for the help people.

Collapse -
trouble-making avi files
by alexdrudi / January 20, 2009 7:24 PM PST

Anyone has any idea on how to spot these files without checking them all one by one?

Collapse -
by 45YU5 / December 15, 2008 6:16 AM PST

If you are using a xbox 360 and do not want to disable this (there is no other way to stream in my knowledge) rcorman has the key to unlocking your cpu. In my case it was also an .avi file, after deleting the .avi and ending the wmpnetwk.exe process (it reboots in a few seconds) my cpu went from 99% to about 4% and PF went from about 750mb to about 400mb. Thanks again RCORMAN!

Collapse -
Sharing CAN be a problem..
by car4dave / August 17, 2008 6:08 AM PDT

Thanks for the instructions. I will not remove WMP but found out the cause of my problem.

Sharing must be a real problem for laptops, I assume the problem happened because I was sharing with another laptop on another network that I use when visiting my friend. The other laptop is her daughters laptop and obviously when I am 600 miles away, I am not on her network sharing video files. WMP is probably searching for her laptop to share files with.

Collapse -
by sensenetheru / September 4, 2008 4:18 PM PDT

omg this dude on our network installed vista, and my other computers have been draggin some serious boootay. Sinx he couldnt figure out how to shut it off, I changed my settings to disallow his computer. thank you so much! I was going to yank the cable to his computer.

Collapse -
by TheLast929 / October 3, 2008 6:05 PM PDT

Oh man! I was about to throw my computer against the wall with how much it slowed down and was "working" all the time!! I only have a 120gb hard drive that's almost full, so I figured I had too much junk in the trunk. I had backed up and deleted almost half, run every virus scan and cleaner out there and still my system was buzzing away 24-7. As someone else, I saw the wmpnetwk.exe running at full speed all the time and just now did the search and found you guys. I did not delete wmp from my system, but it is in total stealth mode again. THANKS!!!!!
What effect does the disable have??? Is it only on computers on the same network? Which I have none 'cause I cannot figure out how to link my 2 systems Silly

Collapse -
Thanks - this really helped
by ice_dog_fan / September 9, 2008 4:38 AM PDT

I had recently turned on this service in order to share pictures through Windows Media Player to a Kodak digital picture frame through our home wireless network. Like everyone else, my laptop was suddenly bit with something slowing it down which was this particular exe file. This little piece of advice did the trick. I took the first two steps but didn't uninstall Windows Media Player. I actually use it for work (I'm a sound designer). Thanks again!

Collapse -
Thanx rcorman!
by buytokyo / October 24, 2008 9:58 PM PDT

Thanx for the all the advice but especially rcorman!

Had the same problem that you've all been having, wmpnetwk.exe hogging all my resources.

I didn't want to disable WMP 11 because I share files with my Xbox 360 (awesome by the way!). Couldn't figure out why the process keep increasingly hogging my memory and CPU. After reboot it started fine but then kept growing.

Thanks to Rcorman, I located a corrupted AVI file; Heroes btw, what is it with that show? Deleted it, and now its running smooth, still using way too much of my memory,but hey what you gonna do?

Collapse -
Turn off media sharing
by gregrocker / February 5, 2009 4:35 PM PST
In reply to: Thanx rcorman!

or it will turn the WMP sharing service back on. Just study the sharing options and turn off the one that deals with sharing media only, not files or printers. It is a distinct choice in Vista and Win7 Network and SHaring Center>Advanced options. Then click on network in Start menu to make sure none of the machines on your network have the Media Sharing feature showing, or they will turn your WMP sharing service back on.

Collapse -
by mbigeau / March 10, 2009 9:26 AM PDT
In reply to: Thanx rcorman!

very helpful guys computers running way better but how did you find which avi.files were's a pain in the but to turn on and off the sharing everytime i wanna watch a movie on the t.v. through the xbox.thx

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?