Networking & Wireless forum

General discussion

Wireless router connects to one laptop but not another?

by InkSpilledxx / August 3, 2009 10:12 AM PDT

Hey everyone. My Linksys wireless router is giving me a headache.

The internet (through Verizon) is connected to the Westell modem. An Ethernet connects the modem's Ethernet port to the Linksys router's internet port. Port 1 is connected to a desktop computer which works perfectly.

Laptop 1 connects to the router and internet automatically and quickly, then stays connected to the internet. Works perfectly.

Laptop 2 manually connects to the router occasionally, the internet rarely, and disconnects after ten minutes.

Now I know enough to post specs. If there are any more you need, please ask.

Modem: Westell

Router: Linksys, Wireless-8 Broadband Router with 4-Port Switch, BEFW11S4 ver. 4.

Laptop 1: Acer Aspire 5920, Windows Vista Home Premium, 32-bit. It is my Mom's computer and has not had many things done with it. She doesn't touch advanced settings.

Laptop 2: Acer Aspire 5610, Windows Vista Home Premium, 64-bit. This is my computer, which I have tweaked.

I know both laptops are connected to the same router name, and it is unsecured so there is no password to get wrong.

When I can't connect Laptop 2 to the router, I click diagnose. It tells me that a time-out occurred due to user action.

Anything that anyone can think of is appreciated!

Discussion is locked
You are posting a reply to: Wireless router connects to one laptop but not another?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Wireless router connects to one laptop but not another?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Are you broadcasting the SSID?
by Coryphaeus / August 3, 2009 11:35 AM PDT

If not, do so.

Collapse -
by InkSpilledxx / August 3, 2009 12:38 PM PDT

It took me a while to find out what SSID means and to find how to check that. Yes, it is enabled and broadcasting.

Collapse -
by InkSpilledxx / August 3, 2009 1:07 PM PDT

Laptop 2 is also 32-bit. Sorry!

Collapse -
Not enough detail but here's 2 common issues.
by R. Proffitt Forum moderator / August 3, 2009 10:46 PM PDT

1. The router is not setup per our Networking forum admonishment. In a,b, and c.
a. Router defaults except for ISP requirements.
b. Broadcast a simple SSID. 8 characters and "simple".
c. WPA for security.

Do not use MAC filters.

2. The new machine is Vista. Googe the following:


Collapse -
Router is setup per admonishment, plus some more specs.
by InkSpilledxx / August 4, 2009 10:06 AM PDT

Router is already set to all defaults (ISP requires none so far as I know).
SSID is Holly.
WPA is being used.

MAC filters are already disabled.

What do you mean, new machine? Both are running Vista, Laptop 1 connecting and Laptop 2 not connecting.

I did the research looking up "disable vista broadcast flag." This led me to Microsoft's Help and Support page ( I wasn't sure which (of 3 listed) were the GUID I needed to edit. I added the Toggle to the first, restarted the computer and no change. The second already had the Toggle created and at 1. The third GUID had the Toggle set to 0, which I changed to 1 and then restarted the computer. Still no connecting.


Something I forgot to mention - I'm using an Ethernet cable to hook up to the router, which does work. I just can't connect to the router wirelessly and stay connected.

I have images of the router specs (uploaded through Badongo) if you need those, but I'm not sure how I can share them with you.

Collapse -
Sounds defective.
by R. Proffitt Forum moderator / August 4, 2009 9:07 PM PDT

This will likely end with the laptop being sent out for repair or replacing the router or in some cases, new router firmware.

To test the laptop I take it to other wifi hotspots. If those fail, I know to call its maker. Be sure it's loaded up just like it came from the factory without changes to firewalls or such because they will have you do that.

Nothing in your posts suggests it's your router.

Collapse -
Exactly what I'm afraid of..
by InkSpilledxx / August 5, 2009 6:27 AM PDT
In reply to: Sounds defective.

It works well with other wi-fi connections. Before here, I had my own router and modem that worked. It was a different model linksys with a different ISP. That just makes this all the more confusing.

It's not worth it for me to send the my lappy in to get fixed. Everything else works and I can still connect with an ethernet. I'll default Windows Firewall settings. I'll also try to default whatever other settings I can, since it seems to be this specific computer.

Thank you everyone for your help! If it does end up working, I'll post why.

Collapse -
May Be Fixed
by InkSpilledxx / August 24, 2009 7:43 AM PDT

I gave up for a while and just used the ethernet to connect. Then today I got annoyed and started with Google again. It led me to On the second page, EGao changed the wireless channel. It worked for me, too.

So just in case anyone else ever reads this, change the wireless channel!

If you don't know how -

1. Connect to the router via ethernet.

2. Find your router's IP address and type it into the address bar of your browser. My Linksys wireless router's IP address is

3. Click the Wireless tab. Then beside "Wireless Channel," there is a drop-down menu. Options are 1 (2.417 GHZ) through 11 (2.467 GHZ). Select 1 and then Save Settings. *NOTE: Remember the channel it was already set to in case this is not a fix for you.

4. Get the ethernet cable out of the port.

5. Try connecting wirelessly.

6. If channel 1 doesn't work, then repeat steps 1-5 with channel 2, 3, 4 etc until it works.

It worked for me, at least for now. =)

Collapse -
Similar problem solved with the above approach
by bshanky / January 20, 2012 6:09 AM PST
In reply to: May Be Fixed

had similar problem with one laptop not finding my home wireless even if I change SSID name, type etc..never checked channel as it was auto..

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.