Hi AneejThomas , I think the problem is because you put the web server from the internet behind your router. I believe setting up DDNS and applying static routing should do the works. You can read the router manual in the TP-Link website for this.

Hope this helps. Cheers!