First, I would access the router settings and make sure the SSID
broadcast hasn't been disabled.. For most, making sure it's "displayed"
is the best course of action. Next, I would access each of the other two
computers, eliminate the "old" access password and maybe even the
entire wireless connection setting in Control Panel/Network
Connections/Wireless Network Connection properties/Wireless Networks
tab, then attempt to access the wireless again, this time, using the
correct password/passphrase being used by the new computer....

Hope this helps....

Grif