General discussion

Wireless connection problem with BD-C6500

I can't hook up to the wireless network through this Blu Ray player. It keeps getting stuck on Gateway Ping. Any idea what I can do? Thanks!

Discussion is locked

Reply to: Wireless connection problem with BD-C6500
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Wireless connection problem with BD-C6500
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
Same Internet Connection Issue

I just purchased the BD-C6500 and I am having the exact same problem. It does not matter if I hook up wirelessly or wired. It goes through the network connection test and gets an error on the Gateway Ping. I have a Linksys Wireless-G router.

- Collapse -
Samsung BD-C6500 Internet Connection Issue

Samsung posted a firmware update for the BD-C6500 bluray player on their support website on 15 Mar. The update states that it is suppose to fix wireless connection issues. I downloaded the update, unzipped the file and put it on a USB device to transfer to the bluray player. Foolish me, I thought this would be the end of my problems. As the player goes through the update process it would never get above 50% complete before it would completely freeze. I could not even get the player to power down without unplugging it. I attempted to install the firmware update about four times before I just got too frustrated and quit.

- Collapse -

Well, I finally figured out how to fix the connection and firmware update problems. I returned my Samsung player and bought an LG BND570. I had it set up in less than 10 min with no problems.

- Collapse -
Samsung BD-6500 update requied to unfreeze new equipment

tried everything. save your money buy something else. My absolutely new Samsung blu ray equipment is totally frozen ( no buttons do anything to change status) display simply says "UPDATE". Disclaimer in user manual indicates Samsung knows they are taking money without hope that the equipment will work -- quote from page 57 of "Blu-ray Disc Player user manual" -- states "Samsung Electronics shall take no legal responsibility for player malfunction caused unstable of internet connections or consuner negligence during software upgrade." (note strange misuse of language in the disclaimer indicates disclaimer is written by a machine rather that someone who has second grade language skills.) In other words, Samsung knows the sytem permanently freezes never to function again. It keeps our money and programs the equipment to display "UPGRADE" on the machine as the metaphorical statement on the tomb of your Samsung purchase, and you kiss your purchase price and your time dealing with crap equipment goodbye. The equipment so frequentlyly does not work that
Samsung has tried to protect itself ahead-of-time by disclosuring that i needs to say in the user manual that "it's not our problem if something goes wrong in update process". To top off the great consumer experience, the published call-in number for reaching someone to talk to at Samsung has been constqantly busy for past two weeks.

PLEASE SAVE YOUR MONEY - NEVER BUY ANYTHING WITH SAMSUNG BRAND ON IT! If you are more frustrated than I am, just start a new "Samsung Sucks" website.

- Collapse -

I bought my BD-6500 on 12/10....a few days later, it got an update and then I started having issues connecting to the internet.


Hold down the "stop" button for 5 seconds. Everything works great for me now.

- Collapse -
possible solutions

Looks like Samsung did an update that messed up WEP connections.
Switching to WPA2 seems to resolve the connections issues - also seems to be a little faster. If using a linksys wireless g then also make sure you have the latest firmware - available on the linksys site for download. It is easy to install.
switch you security on the wireless route to WPA2 and validate the connection with another device. Then start up your Samsung Blue ray - wait a few minutes before configuring wireless. If it give you some issues trying to get to config power off and back on. Seemed to work fine after that.

- Collapse -
There are problems with WEP.

Since that is insecure you can never tell if it was Sam or not. Many devices need to be set up again after firmware updates. As quality is never a sure thing, my advice is to move to some secure protocol whenever possible.

- Collapse -
No wired connection

After trouble shooting only way to get internet is to use a wireless connection

Go to settings on your screen for device
At far right bottom

Go to network

It will say Wired

Change it to wireless

Enter password for yr wi fi
Best wishes

- Collapse -
Same issue

I tried setting up the machine today and I an having the same GATEWAY PING hang-up as you have described . I noticed that others posted similar problems with the BD-1600 model last year (2009). Did anyone resolve the issue then?

- Collapse -
"Easy" setup

I am having the same issue with the player not being able to ping the router. I've tried everything that is suggested on the Samsung site and still can't get a connection. I manually inpu every possible combination of IP, DSN, etc and nothing. I've been at it for 2 hours and am calling it quits for tonight. Any help would be appreciated!

- Collapse -
bd-c6500 connectivity

I had the same problem and it turned out to be that the router I was using was too old. I was using a Belkins b and g router. Got me a Linksys Wireless N router and bingo, no problem connecting.

- Collapse -

I was finally able to get mine to work, but I had to change the level of security on my Linksys WRT54GS router. I live in a pretty remote area, so I feel fairly comfortable that I won't get hacked. If I have concerns, I suppose I'll have to break down and update the router.

I was also unable to update the firmware successfully. it loaded to 50% and stopped for hours...

- Collapse -
Firmware update...

The BEST way to correct this problem is to called Samsung and have them send you a disc with the updated firmware. I called today, because I thought I had the problem resolved, but back to the original 'not working again.' Anyway, Samsung assures me that with this new disc, I will now be able to perform updates, without any problems. We'll see.

- Collapse -

Today, I finally received the firmware CD from Samsung (it took 3 weeks). Loaded it and it worked like a charm. It updated my firmware...and the new firmware allows my BluRay player to select movies directly from my TV. With the old firmware, I was not able to do this. So, I am very happy, thus far. Sure wish it would have worked wirelessly, but the main thing is...the firmware is now updated!

- Collapse -
Thank you so much !

I called Samsung got them to send me the firm ware disk. Here is their Number: Customer service: 1 (800) 726-7864

- Collapse -
re: Samsung: bd-c6500

had the same issue today with a linksys wrt54g router. was finally able to get it to gateway ping by turning the firewall off and turning broadcasting on in the router settings. after the wireless setup finished I turned both back (firewall on and broadcasting off) and it's still working. Samsung support was WORTHLESS on this.

Hope this helps...

- Collapse -

I had thought about turning the security encryption back on after making the connection. Good to know it worked for you so maybe it will work for me.


- Collapse -
BD C6500 Blu-Ray with wireless connectivity issues

I bought the BD-C6500 with integrated wireless and had a diffult time getting it to work. I was eventually successful, so thought I would share step by step...
1) Download latest firmware,version 1008.1, from the Samsung site to my PC, then copied to a USB drive.
2)Plugged the USB drive into the front of the C6500 and it updated the firmware automatically, following a couple of screen prompts. I see others have had issues wiht the firmward upgraded, but it worked fine on mine.
3)Entered Admin mode on my Linksys WRTP54G router ( type into a brower, address may vary depending on the router).
4) Disable all wireless security on the Linksys.
5) Press and hold the "Stop" button on the front of the BD6500 for 5 seconds. This does a factory default reset.
6) Followed the setup and choose "Auto" for the Ip configuration, it connected and has been working since.

Good luck!

- Collapse -
Firmware Update

There has since been ANOTHER firmare update, on April 2nd. It doesn't appear you can even download the 3/15-16 update. Does that mean all the updates are included in the most recent update? I dont think I complete the update accurately because I am still stuck at Gateway Ping, but I am going to try again in the morn.

- Collapse -
Need Firmware Update

Please attach the zip file or link to download.

Much appreciated.

- Collapse -
Firmware file

Can someone post the file here? It does not load from the Samsung website.

- Collapse -
Firmware file
- Collapse -

I have version 1002-5 loaded on my blu ray player and when I try to upload the one you have in your link I get the following error:

error is detected in teh update data


- Collapse -


What country are you in? Also, how are you upgrading, and does the option to upgrade through the network a possibility?

Sorry to ask, but this does make a difference for that firmware udpate.


- Collapse -

I am in Virginia, USA.. I have tried upgrading with the LAN directly to the Blu Ray unit and no luck. I cannot even get a resposne, and I know the cable is working ecause I have another item hooked to it an dit works fine..

Any other suggestions.. I tried the upgrades within this section but nothing has worked so far..

- Collapse -
- Collapse -
can't connect wireless router to BD-C6500

I purchased the Samsung BD-C6500, and have attempted to connect wirelessly, called Samsung's Support and spoke with them for almost an hour, and they assured me that it is the router's firewall that is not letting me connect. The blu-ray allows me to 'physically connect,' but that's it. Once the MAC is approved, the "IP Address, Subnet Mask, Gateway, DNS Server" will always fail. I'm using a Linksys WRT54G wireless router, and it is setup with a WEP password protection. I even went back into the router to see if by allowing other devices to be setup wirelessly would work, but still nothing. In the past I tried setting up the router to WPA, but the laptop wouldn't connect wirelessly, so I had to change it over to WEP. I don't know how to disable the firewall on the router (I've been trying to access it through Linksys - EasyLink Advisor) but no luck. I'm not sure if disabling the firewall will also disable the password protecton, but I do know that I don't want to keep that security, thus not allowing anyone (including neighbors) to use it.

I figured it might be a firmware issue, so I also attempted to download the updated .ruf file of the firmware on the Samsung website. I followed the pdf instructions, but it didn't work. I loaded the .ruf file (64 mb) onto the USB, and put it into the blu-ray player, which it recognized the USB, but that's it. It acted like it was just additional storage, and didn't upload the file. I tried putting the USB into the player when it read "No Disk," which it recognized it, and tried turning the player off then putting the USB in, which didn't recognize it by automatically turning on.

If it is just disabling the Linksys router firewall, how do I do it?

- Collapse -
Firmware support for WEP

My Wireless Router uses the most common security method for Wife .. i.e WEP.
The Samsung BD-C6500 doesn't not have a native option for WEP .. mostly WPA, and when I try to just set the security to OPEN, and then enter the WEP key, the system only allows for 25 charactors ????
Anybody working with Wireless knows that a 128 bit security WEP key is 26 HEX characters.

I am using the latest firmware: 1020.1 - Is there another way to setup WEP with a 26 character key ?? If not (Currently) is there a plan to support that?

Appreciate your response. Thanks.

- Collapse -
Or it's in code.

"Apple interprets inputs for WEP (note that I did NOT say WPA!) passwords as ASCII text that it converts directly to hex (it just collects the hex values of each character). To produce the equivalent hex key (which every manufacturer EXCEPT Apple uses as default) just look up the characters in your 25 character "WEP code" (which Apple calls a "network password") on an ASCII table and piece them together. Here's an ASCII table for you to do that with."

That is, folk complain about that on Apple too! is the lookup table.

Good luck!

- Collapse -
character limit

I just came across this last night after it lost connection to the router. It had ALREADY been connected using the 26 HEX characters, so I was surprised to find that trying to reset the password would not allow more than 25.

CNET Forums

Forum Info