Windows Legacy OS forum

General discussion

WinXP doesn't recognize my USB devices

by Mikel72 / November 5, 2007 7:53 AM PST

Hi!

First of all: I have an old Compaq Presario 5360 with Sis 7001 PCI to USB controller. This machine was working GOOD, I could work with my USB web cam, USB drive, USB digicam and others MP3 players.

BUT

I have reinstalled my WinXP with Service Pack 2.0 and now I CAN'T use any USB device, when I connect my USB drive this device is not powered, XP doesn't notify me for anything... simply this PC looks not to have any USB controller.

I have an DELL Notebook, I can use my USB devices on it.

I just reinstalled the OS in the same way how I did it before.

I think is something about drivers, the control panel (System devices) tells me everything is good and my USB controllers are working correctly.

I need your help

Thank you

Discussion is locked
You are posting a reply to: WinXP doesn't recognize my USB devices
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: WinXP doesn't recognize my USB devices
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
first of all....
by yprtb / November 5, 2007 8:02 AM PST

did you download all available updates from Microsoft at microsoft.com?
If not do so. another thing you can try, do any of the usb ports work with any other devices? if they do, then something is broken that your trying to make work. if none of the usb ports are working......
1.) visit Microsoft update as described above, however click custom when the page loads and install all hardware updates.
2.) if it still don't work, visit your website for your brand of computer, and click support on there page and type the problem your experiencing and see if they have a fix available.
3.) try right clicking my computer-properties-hardware tab-device manager-right click one of the usb main controllers, and click properties. then click driver-update driver. follow the wizard and have it search everything possible. install what is given.
try those solutions, if none work, contact your computer provider.

Collapse -
also try this google search
by yprtb / November 5, 2007 8:15 AM PST
In reply to: first of all....
Collapse -
Your motherboard drivers are needed first
by Steven Haninger / November 5, 2007 8:42 AM PST

These USB ports are part of your motherboard as are many other components that Windows cannot configure or cannot configure properly. You need the Compaq drivers for this. If you don't have them on a disk, check the manufacturer's website for them.

Collapse -
Thank you guys !
by Mikel72 / November 5, 2007 10:30 AM PST

Thank you guys...

I will try ALL these advices, at least I have more options now. About the manufacturer's drivers: I HAVE the two original discs for this machine and they don't have any driver for USB specifically.
In my last installation I have installed drivers for Audio and Video, I don't think this involve USB matters, is the only one difference between these installations.
I am sure, my USB devices work OK in my notebook

I am going to do this stuff, I let you know about results.

Collapse -
SOLVED !!
by Mikel72 / November 6, 2007 8:00 AM PST
In reply to: Thank you guys !

Hello friends !

I have done what you said, sadly everything was bad.


BUT

I went to the BIOS, first of all the PCI BUS controller was set in IRQ 11, I think it is the normal and default setting. I just changed this IRQ to 10 (from IRQ 11 to IRQ 10).

So actually I am using IRQ 10 for the USB Controller... AND IT IS WORKING GOOD ! I plugged my iPod, USB portable drive and my External HD drive using USB at the same time. So far everything is OK

Thank you for your valuable time.

Mikel

Collapse -
Good work and it still seems strange that
by Steven Haninger / November 6, 2007 9:01 AM PST
In reply to: SOLVED !!

all you did was reinstall Windows and hadn't mentioned changing anything in the BIOS. XP is usually good at managing IRQs. You could switch it back and go to device manager and check under resources for conflicts. That might offer a clue but, why bung it up now. Thanks for posting the solution.

Collapse -
Hey... ! again ?
by Mikel72 / November 6, 2007 9:40 AM PST

ok, I get it.

After three hours I came back to my PC, I connected my USB driver again with NO response, no energy, no notifications from XP, nothing...!

I reset the PC and after some minutes (XP already loaded) XP recognized my USB driver again, I think this is no normal, some time ago XP used to recognize my USB driver easy and fast.

I can see in Device Manager the resource for SIS 7001 PCI controller, device manager says this controller is using IRQ 5.

But BIOS set this device in IRQ 10 actually. What is happening? I am going to change this value, but my question is: This parameters (manager device / BIOS) are related? if YES: Why this device works even the IRQ value are different?

I am confused.

Is working but not properly.

Mikel

Collapse -
IRQs are like voodoo
by Steven Haninger / November 6, 2007 10:31 AM PST
In reply to: Hey... ! again ?

I'm not sure how it works today but was a throwback from old devices and was used to sort of set a priority for the use of CPU cycles or some such thing. The bus was scanned for interrupts (requests for service) and some had priority over others. Hard drives were a lower priority (they could wait) than com ports and system clocks. I remember the 16 interrupt limit that persisted for a long time and we were constantly dealing with IRQ conflicts until PCI and IRQ sharing came along. Some devices would not share and some would not move from a fixed interrupt so you had to work out a compromise to make all the devices happy. Generally with Windows XP and newer boards you don't have to do this but, if you find conflicts with resources, you can sometimes manually change them in Windows without messing with the BIOS. If you have constantly changing hardware, Windows will be constantly reallocating resources. From your other postings, I'm still not sure your motherboard devices and chipset are fully configured, however. This could still be part of your problem. These need to be locked down. Depending on how you reinstalled XP, this might or might not happen automatically. I am thinking that using just recovery media could cause some drivers to be missed. Using full version (retail, OEM, volume licensed) packages won't have drivers for proprietary hardware. Maybe knowing exactly how this was done might get a better answer. I'm not personally very experienced with installations using recovery disks. Each system and method is a bit different. I suspect it's a head banging experience to get it back to factory release configuration, updated, and personal software installed and running.

Collapse -
Mike, maybe you'll be able to find something here
by PudgyOne / November 6, 2007 7:44 PM PST
In reply to: Hey... ! again ?
Collapse -
ya, i would try those solutions the other ppl have offered
by yprtb / November 7, 2007 2:48 AM PST

and if still nothing works, i think your best bet is to take it to the computer provider or call them and explain your problem. hopefully a rly smart moderator will come and help you with your issue. best of luck man. Happy

Collapse -
I think now is solved, for real... !
by Mikel72 / November 7, 2007 8:18 AM PST

I have to thank to everybody for your valuable time!

But this time I think I got it !
Yesterday late I was checking my system, I saw in Device Manager IRQ 5 for this SiS 7001 PCI to USB controller, I said this parameter was in IRQ 11 before and then I set this parameter to 10, it worked just for a while, then... I guess after hibernation my PC lost any USB connections.
Finally I set my BIOS to IRQ 5 for this controller (matching with my OS)
NOW I made some tests: I was testing after hibernation, after some hours I have connected my devices, rebots , unplug and plug, I have connected two or three USB devices at same time, I think I made a lot of things trying to being sure.

I will be watching my system regarding this matter, I let you know if I have some inconveniences.


Thank you

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?