Windows Legacy OS forum

General discussion


by JLF47ME51 / January 25, 2006 12:57 AM PST

Got this error message while doing a photoshow:

Virtual Memory Minimu Too Low

And the system just fronze, what can I do to take care of this problem.

Thank you for your time and cooperation in this matters.

Discussion is locked
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: WINDOWS XP - VIRTUAL MEMORY MINIMUM TOO LOW
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Go to My Computer
by Ray Harinec / January 25, 2006 2:17 AM PST

select System, in there set the memory space available for the paging file [virtual memory] or probably best simply allow Windows to set it.

Collapse -
RE:Go to My Computer
by lhchemist / September 22, 2006 5:25 AM PDT
In reply to: Go to My Computer

Thanks for the info.

Collapse -
virtual memory
by glennlee / January 25, 2006 2:23 AM PST

Virtural memory is in Windows swap file on hard disc. You may need to free up space. CCleaner is very good for this and available on

Collapse -
Increase Page File
by Darton Fury / January 25, 2006 2:45 AM PST

You can increase the size of your page file if there is space available on the hard disk. Logon as an Admin, hold down the Windows logo key and press Pause/Break to open System Properties. Click the Advanced Tab. In the Performance section click Settings. Click Advanced Tab again. In Virtual Memory section click Change. Choose the appropriate drive in the first window. Below that choose Custom Size and increase the value in the Maximum Size(MB) box. Click set, ok, and then restart your computer.

Collapse -
Increase virtual memory/page file size.
by caktus / January 25, 2006 1:55 PM PST
In reply to: Increase Page File

Right click on My Computer > left click on Properties > Advanced > Settings > Advanced. Under Virtual memory left click on Change.

Select (left click) on the Drive on wich Windows XP is installed. In most cases this will be Drive C.

Under Drive:
Space available: Select the radio button labeled: Custom size:

To play it safe, in both the Initial (MB)size: and Maximun size: dialogue boxes type 2560 (i.e. allocate 2.5GB for the pagefile) provided you have the free memory space to spare. If you don't have enough free memory available enter the amount of memory you can spare, and meanwhile seriously consider getting a larger Hard Drive.

Mine is set to 4096MB (4GB), max. allowed by XP. This may seem like quite a lot, but the reason for this is that recent games now require a lot more real and virtual memory to function correctly, even if you have 2GB of RAM. Having a larger pagefile size does not hurt performance as such; it only takes up a bit of additional disk space.

After setting the new page file size left click on
OK > OK > OK. Then restart the computer.

Collapse -
Could be a deeper problem
by rlhanson / January 26, 2006 7:09 PM PST

We recently encountered this same message & lock up on my son's laptop and the whole browser was hijacked. A complete re-install of XP was required.

Collapse -
Changing the windows virtual memory.can be a big problem !
by s & company / January 27, 2006 4:26 AM PST

yes..i do agree that changing the virtual memory can be dangerous for you if you have anything important in your pc's data.
you can lose it.

i know this because i tried this and increased the pagefile from 190 mb to 250mb max.

when i restarted computer windows did not started instead an error was there.and i had to reinstall windows.and lost all my music over the years i had saved and much more.

so the message is dont try to touch virtual memory.
and then ofcourse if u dont touch you will not learn.

Collapse -
RE: problem !
by caktus / January 28, 2006 1:58 AM PST

Should have only cleard the pagefile unless the Initial pagefile size was set to zero or there abouts. Unless something else was amiss.

"dont try to touch virtual memory"

"touch"[ed] properly, it is not a problem.

Collapse -
This tip is excellent for those running Stardock software
by firedogs / January 26, 2006 8:58 PM PST

I never received error messages, but things always seemed slow all-away-around. Even with Process Tamer and FreeRam XP Pro; while it did help, this tip turned night into a bright sunny day. Thanks caktas! Now, we can use our computer like a race car...heheheh!

Collapse -
by caktus / January 28, 2006 2:05 AM PST

FreeRam utlilities themselves can often be a problem as they are capable of freeing RAM that one does not want freed.

Free RAM is only wasted RAM.

Collapse -
Thank you caktus. I followed your instructions and set mine
by biz888 / February 19, 2009 2:58 AM PST

I set mine to 4096 MB and NO problem. My Windows is NOT sluggish anymore and NO programs are affected. I didn't lose any files. Thank you again. I love forums and how people HELP one another.

Collapse -
Use a second HDD if possible...
by skycatcher / January 26, 2006 8:39 PM PST

I too would first of all check how much space is available on your HDD. Empty the Windows temp folder of all files (use Windows explorer) - empty the recycle bin (how many people never do this) - In IE go to Tools - Internet Options and Clear History - Delete Cookies - Delete Files (also check box for Delete all offline content) and, while you are there, click on Settings and re-set the 'Amount of disk space to use' to about 20 (yes- ?twenty? - if the IE cache is too big it actually slows down browsing speed as IE checks a gigantic cache to see if you've 'been there before').

By far the best way is to add a second drive (Slave HDD) - an old small one is fine, about 8 or 10 Gigs - and put the Swap file AND IE cache on there. In IE, tools, Internet Options, Move Folder, click on the slave HDD. For the Windows cache I can only tell you for 98se - Windows/Pause Break key, Performance, Virtual Memory, click the 'Let me specify my own virtual memory settings', change the drive letter to the slave HDD, the minimum size is usually 2 to 2.5 times the size of your real RAM. There is no speed gain using a partition on the same HDD but a separate HDD with work at the same time as your main HDD.

THREE separate HDDs are even better - one for Programs, one for Data and one for the Caches. Perhaps our Moderators would like to comment on this.

Collapse -
by JLF47ME51 / January 30, 2006 8:07 PM PST

I think I will take this idea and get a second hdd also I will add more RAM to my computer.


Collapse -
Virtual memory AND other factors
by kal9000 / January 27, 2006 1:14 AM PST

Virtual memory a.k.a. "swap file" "page(ing) file" is:
1- A file on your hard disk,
2- Used by the system (Windows) to store Physical memory (RAM) content when it (Windows) needs to make room for more content.
Therefore, it is:
3- Sensitive to available space on your disk (If your HD is almost full, Windows won't be able to expand that file to the size it needs).
4- Very sensitive to disk fragmentation,(more so if you use the FAT32 format).

So, if you have at least the minimum recommended RAM size for your Windows version, please DO increase the size of your Virtual memory to at least 2.5 times the size of your real RAM (256MB RAM = 640MB or more for virtual memory).

IMPORTANT: Setting the SAME Max. and Min. values to the virtual memory (and doing so after a disk defrag) (Min. size = 640MB AND Max. size = 640MB), will reserve that space for the file (even if your drive fills up, windows will have enough space for it) and, minimise fragmentation of the file, plus a noticeable speedup of startup and shutdown times.

Collapse -
Question about virtual memory and multiple partitions. . .
by humebudde / January 27, 2006 2:29 AM PST

I have 2 partitions on my hard drive, and have read several guides about increasing preformace for Win XP in general, and video games in particular, and was informed that using a seperate partition (different from the main/primary one) for your virtual memory would optimize preformance and using the same size for min and max of virtual memory is better as well. So I got rid of the virtual memory (paging file) on my C drive (the primary partition) and setup my D drive as min:2000 and max:2000. My question is, what would happened if I set it up so that both partitions had a paging file (of say 2000)? Would this cause conflicts? Would this increase preformance?

Thanks in advance for your help.

Collapse -
RE: Question about virtual memory and multiple partitions
by caktus / January 28, 2006 4:21 AM PST

If moving the pagefile to a different volume, better to move it to a different , and dedicated hard drive. Because the benefit is that the hard drives optical reader will not have to search through alot of system, program, and other data files before it can find and search the pagefile. May as well just leave the pagefile on the system volume (C volume/drive).

In either case it can be beneficial to still maintain a pagefile of RAM+1MB to maintain a crashdump. Crashdump is a helper tool used by the crashreporter daemon to create crash reports and notify the user of application crashes and sometimes possible solutions.

Even having pagefile split between hard drives, when the computer has to search/add to pagefile it will go to the least active volume wich would be a hard drive solely dedicated to pagefile.

Collapse -
False. Here's why.
by R. Proffitt Forum moderator / January 28, 2006 4:33 AM PST

The pagefile is never searched out more than once and then is open for the session.

-> What web site noted this (non) issue?


Collapse -
RE: What web site
by caktus / January 28, 2006 9:25 AM PST
In reply to: False. Here's why.

Don't recall. Was a Windows dev forum a few years ago. Actually I think it was a 200, 2003 Svr forum. Couldn't find it (if it's still out there). But did find quite an array of verying opinions.

Closest I come was TWEAK GUIDES TWEAKING COMPANION's ''should put the main pagefile on the drive that doesn't contain your Windows installation and applications/games. This will reduce hard drive head movement on the main disk and speed up access to the pagefile on the other disk''. If this is like what I read, then I got it twisted and stand corrected.

BTW, what are you referring to regarding ''open for the session''?

Collapse -
(NT) (NT) 2.5 times ROT, but the larger the PF the better
by caktus / January 28, 2006 2:18 AM PST
Collapse -
At the end of the day, adding new RAM..
by grannyQ / January 27, 2006 4:18 AM PST

Hello there,

I too, encountered your same problem. I followed the advice I received which was quite similar to what other posters here have suggested. At the end of the day, the best solution for me was to add more RAM. You don't mention how much memory you currently have. I only had the 256k that came with my computer. I learned that when running XP, photo programs, and other memory intensive apps, that it's just best to have adequate memory. I ordered another 256k, installed it, and all is better now. I hadn't realized how slow things had gotten until I added RAM. Might work for you, too. Good luck.

Collapse -
Increase virtual memory size...
by caktus / September 20, 2006 3:48 AM PDT

Right click on My Computer > left click on Properties > Advanced > Settings > Advanced. Under Virtual memory left click on Change.

Select (left click) on the Drive on wich Windows XP is installed. In most cases this will be Drive C.

Select ''No Page file''.

Left click on OK, OK, OK, ignoring any warning messages regarding no page file/virtual memory.

Restart the computer.

Recreate the page file. If the computer seems to become unstable while setting the new page file, again, restart the computer and perform the process in Safe Mode.

Under Drive:
Space available: Select the radio button labeled: Custom size:

To play it safe, in both the Initial (MB)size: and Maximun size: dialogue boxes type the maximum desired virtual memory/page file size (in MB's) provided you have the free memory space to spare. If you don't have enough free memory available enter the amount of memory you can spare, and meanwhile seriously consider getting a larger Hard Drive.

Mine is set to 4096MB (4GB), max. allowed by XP. This may seem like quite a lot (and probably is), but the reason for this is that recent programs/games now require a lot more RAM and virtual memory to function efficiently. This can also hold true when many processes\programs are running simultaniousely.

Having a larger pagefile size does not hurt performance, it only takes up a bit of additional disk space.

After setting the new page file size left click on
OK > OK > OK. Then restart the computer.

Hope this helps.


Collapse -
Fixing Virtual Memory.
by estein004 / June 24, 2007 10:39 AM PDT

What is the procedure?

Collapse -
Windows XP Virtual Memory too low
by Brian A J Mitchell / August 9, 2008 11:16 PM PDT

Hi, I have a Dell Latitude D810 with 2x 512mb simms I keep getting the error popup as above, could you point me to solving this problem.

I have Windows XP SP3 installed.

Regards, Brian Mitchell

Collapse -
This thread was created
by MarkFlax Forum moderator / August 10, 2008 5:19 AM PDT

over two years ago, and the last post was a year ago.

I am not sure you will get much help as the posters have probably moved on.

Best if you create your own thread/discussion and start afresh. Be sure to give more details, eg when does this message pop up?


Collapse -
by williamarnwine / January 14, 2009 5:22 AM PST

This problem causes me a lot of pain. What can I do to eliminate it?

Collapse -
windows virtual memory minium too low
by jbc702 / July 31, 2009 2:42 AM PDT

the virtual memory minimum message keeps coming up and my computer is running very slow. Can you give me any advise? I have windows xp dell 3000

Collapse -
How did you get on
by MarkFlax Forum moderator / July 31, 2009 8:42 PM PDT

with the other advice offered in this discussion?


Collapse -
erro on page, with yellow sign
by emve22 / September 4, 2010 6:05 AM PDT

I often get the message "done but with error on page" on task bar at bottom left. How do I fix that? Thank you. E a9/4/10

Collapse -
You Don't Fix That Particular Problem..
by Grif Thomas Forum moderator / September 6, 2010 4:24 AM PDT

...The "error on page" statement is usually the result of bad coding on the webpage you are visiting.. As such, it's usually not the fault of the user.. Occasionally, there may be a setting on your computer which blocks various scripting or a website redirect on the page and you'll see the same error message.. For example a HOSTS file will block advertising page redirects on a variety of webpages.. Sometimes the "error on page" message is thrown because of that blockage.. As such, there's nothing wrong with what is taking place..

For the most part, I ignore the message.

Hope this helps.


Collapse -
How to Increase Virtual Memory
by Writer98 / September 9, 2010 11:34 PM PDT
Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?