Windows Legacy OS forum

General discussion

Windows XP Update

by superclydes / January 24, 2009 12:55 AM PST

I am currently running XP Professional with Symantec anti-virus. I downloaded a virus, yes stupid, and had them removed. However, I now cannot update Windows. It opens a new window with Google English on it. I am pretty sure that doesn't even exist. When I go to the links, "Google" for the update, Google tells me that page can't be found.

I have the latest update and have run complete scans of the computer and it tells me everything is fine. I can tell something is operating in the background as my hard drive is working when nothing is happening on my end.

Any suggestions?

Discussion is locked
You are posting a reply to: Windows XP Update
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows XP Update
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Some Things To Start With
by Grif Thomas Forum moderator / January 24, 2009 11:49 AM PST
In reply to: Windows XP Update

Look for the file below and if there...:

C:/Windows/system32/wdmaud.sys

Delete it (or move/rename) and Reboot.
_____________

Next,
1.click start-->run-->devmgmt.msc-->ok
2.on the device manager, click view-->select show hidden devices/drivers.
3. then click on "non plug and play drivers/devices", and find TDssserv.sys
4. right click it, then select disable, then restart the computer.
5. then check if the problem still persists. good luck!

____________

And finally, to make sure other trojans aren't on the computer:

On a friend or family member's computer, download the Malwarebytes installer and update files from the links below, copy them to a CD or flash drive, then transfer the files to the problem machine and use them. If you can't start the computer into "normal" windows, try installing, updating, and running the scans AFTER the computer is started into Safe Mode.. I use the sites below to download the installer file and the manual updater:

Once downloaded and before transferring them to the problem machine, rename the program installer "mbam-setup.exe" file to something else like "Gogetum.exe", then copy the installer file and the update file to a CD or flash drive.. Transfer the file to the problem machine, then install the "Gogetum.exe" file, then run the update to get the program current.. After that, run a full system scan and delete anything it finds.

Malwarebytes Installer Download Link (Clicking on the links below will immediately start the download dialogue window.)
http://www.besttechie.net/tools/mbam-setup.exe

Malwarebytes Manual Updater link
http://www.malwarebytes.org/mbam/dat...mbam-rules.exe

Next, download the SuperAntispyware program and the manual updater from the links below. After running the Malwarebytes tool above, if you still can't download and install it directly from the problem machine, download it on a friend or family member's computer as well.:

SuperAntispyware
http://www.superantispyware.com/

SuperAntispyware Manual Updater
http://www.superantispyware.com/definitions.html
____________

In a few situations, in order for the program to run, it was also necessary to rename the main "mbam.exe" file also after installing it.. It resides in the C:\Programs Files\Malwarebytes Antimalware folder.
____________________

Hope this helps.

Grif

Collapse -
Didn't make it far
by superclydes / January 24, 2009 4:50 PM PST

I started what you said and typed it in and immediately got an error message of "The application failed to start because MSIMG32.dll was not found. Re-installing the application may fix the problem."

I Googled that file and the virus or whatever is controlling my computer takes me to all kinds of different websites not dealing with being able to download the file. Some sites it does take me to look somewhat real, but if I try to download it, I get the same error.

My anti-virus updates without a problem, so I know I have the most current updates and have scanned the computer numerous times and it says everything is clear.

Collapse -
Update
by superclydes / January 24, 2009 7:34 PM PST
In reply to: Didn't make it far

I was finally able to download the MSIMG32.dll file, but it was a zip file. I tried to extract it, but it won't let me do that because I am missing this file. Kinda frustrating I can't unzip the file I need because I am missing it.

I am not sure what this file is, I am not a computer expert by any means, but is this related to my Windows update as well? Google never used to open up a new window when I went to the link, but now it does everytime. It doesn't seem to matter which search engine I use either.

I would really hate to start over, but if I have to format, I will.

Collapse -
I Don't Think You're Following Instructions..
by Grif Thomas Forum moderator / January 25, 2009 4:34 AM PST
In reply to: Didn't make it far

One step at a time here..

It's not clear exactly WHEN you saw the "MSIMG32.dll" file error.. ? Please explain.. Have you checked to see whether the file is there? It's a legitimate file and should be on your computer somewhere.. If it's on the computer, you may need to register it but we'll need more information..

Next, back to the instructions I gave earlier... Restart into Safe Mode using the instructions in the link below:

How To Start In 'Safe Mode'

Once in Safe Mode, RIGHT click on the Start button, select "Explore" from the little menu.. When Explorer opens, looking on the left side of the window, click on the + sign next to the "Windows" folder, then the + sign next to the System32 folder.. Scroll through the various files and if you find the "wdmaud.sys" file, RIGHT click on the file, choose "Delete".

Did this work for you and did you find and delete a file?
______________

Next, while still in Safe Mode, follow the steps below which I posted earlier:

1.Click on the Start button, select "Run", then type "devmgmt.msc" in the blank area, without the quotes, then click on OK.
2. Once in Device Manager, click "View" in the upper left, select "show hidden devices/drivers".
3. Then click on "non plug and play drivers/devices", and find TDssserv.sys
4. If it's there, right click it, then select disable, then restart the computer.
5. then check if the problem still persists. good luck!

Did this work for you and did you find and disable the file?

Hope this helps and let us know more.

Grif

Collapse -
Thanks much!!
by superclydes / January 31, 2009 2:38 AM PST

Grif,

I would like to thank you for your help. THANKS!!

I was able to download the MSIMG32.DLL file from another computer and installed it on my computer just fine. I was then able to use other functions now that it was back on the computer.

I ran the malware and spyware programs and 14 different virus' and trojan horses and 243 adware tracking cookies later, I am able to update my computer.

I will be sure to frequent this website and spread the word so that others may get some computer help or offer others their knowledge.

Thanks again,

Mike

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?