If you are certain everything is in order, why not just turn off the automatic restart feature when system failure occurs?
Right-click My Computer - choose Properties - then choose Settings under the heading called Startup and Recovery - there you uncheck the the Restart button under System Failure., and the computer should stop that restarting business.