RIGHT click on a blank area of the desktop, choose "Properties", then click on the "Screen Saver" tab. Once there, UNCHECK the box that says: "Upon resume, password protect". Now, click the "Power" button, then the "Advanced" tab. When that opens, UNCHECK the box that says: "Always prompt for a password when computer resumes from standby". Now click on the "Power Schemes" tab and adjust the various power items to your personal preference.. It sounds like it's going into Standby too quickly and you may want to adjust the "System Standby" item to something better for you.. Personally, I'm not a fan of Standby and change that listing to "Never" but that's your personal choice. Once you're got your preferences set, click on "Apply", then OK.

Hope this helps.

Grif