Windows Legacy OS forum

General discussion

Windows Xp Firewall Annoyance

by itdoesntmatter84 / October 9, 2007 9:24 AM PDT

Ok, I am running Windows xp media center 2005 and everytime I start my computer up I can't connect to the internet. I have to wait like 2-3 minute then the windows firewall will pop up saying that your firewall isn't on click here to fix the problem and then it turns on automatically. After that I can get on the internet fine and everything! Is there anyway to stop it from doing that? I mean shouldn't it already be on when it starts up and I should be able to connect at anytime? I have cable for my internet if that helps!

Discussion is locked
You are posting a reply to: Windows Xp Firewall Annoyance
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows Xp Firewall Annoyance
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
reply to: Windows Xp Firewall Annoyance
by caktus / October 9, 2007 4:29 PM PDT

Make sure the Windows Firewall service is started and set to Automatic. Go to Start > Control Panel > Administrative Tool > Services. Scroll down to and double click on "Windows Farewall". Make sure the Startup type is set to "Automatic" and click Start > Apply > OK. It may be necessary to restart the computer for the change to take effect.

Even if you stop using/turn off the Windows Firewall, the service still needs to remain Started and set to Automaic in order for MS/Windows Update to work.

Hope this helps.

Charlie

Collapse -
The windows firewall is a joke
by tcantrelln / October 9, 2007 8:44 PM PDT

I much prefer something like Comodo, or the other good free ones. The new Zone alarm is no picnic, but if you can stand it, it's not bad. Myself, I had to remove it and go to Comodo after the new version wanted me to dump my anti virus (Comp Assoc.)

Collapse -
Not really.
by caktus / October 10, 2007 7:33 AM PDT

I prefer ZA for two-way minitoring, but the Windows firewall excellantly performs it's function.

Collapse -
windows xp firewall annoyance
by itdoesntmatter84 / October 9, 2007 8:53 PM PDT

thanks, I looked and it was already set to automatic so I don't really know what is going on with it...i'm so confused

Collapse -
Try this
by tomron / October 9, 2007 11:05 PM PDT

Start>run>services.msc>scroll down to windows firewall and highlight it>in the keft pane click on :restart service"

Start>run>control>windows firewall applet>general tab>is the ON ticked.

Tom

Collapse -
reply to try this
by itdoesntmatter84 / October 10, 2007 6:38 AM PDT
In reply to: Try this

I did what you said, but no luck still having the same problem when I start up the computer. Yes, the on is clicked!

Collapse -
ok
by tomron / October 10, 2007 7:17 AM PDT
In reply to: reply to try this
Collapse -
Re: what is going on
by caktus / October 10, 2007 8:49 AM PDT

You didn't mention if the Service is "started" i.e. the Start buton as in Go to Start > Control Panel > Administrative Tool > Services. Scroll down to and double click on "Windows Farewall". Make sure the Startup type is set to "Automatic" and click Start > Apply > OK.

If you have more than one firewall installed, uninstall the others. Otherwise, (or if this does not help) perform the next proceedure.

If "Start" is not the problem, check the following:
From the Task bar go to Start > Run > type "msconfig" w/o the quotes and click OK. This will open the System Configuration Utility. Click on the Services tab. Click on Disable All > Apply > Enable All > Apply > OK > and restart the computer.

If this does not fix the problem Check the following:
Create a System Restore Point.
Then go to Start > Run > type "regedit" w/o the quotes and click OK. This will open the Windows Registry editor. From the left window double click on HKEY_LOCAL_MACHINE > SYSTEM > ControlSet001 > Services > SharedAccess > Parameters > FirewallPolicy > StandardProfile. After you click on StandardProfile, in the right hand window see that EnableFirewall is set to 1 in the Data column.
If it is not set to 1 then double click on EnableFirewall.
enter 1 in the Value data box > select Hexadecimal > OK. Restart the computer.

If non of this works, Go to Start > Run > type
"sfc /scannow" w/o the quotes and click OK ( NOTE that there is a space between sfc and /scannow.) This will run the System File Checker which may take about 30-45 minutes or so to run. It may ask you to insert the installation disc. If your copy of XP was pre-installed and you do not have an installation disc, where it says Browse type the following:
"C\Windows\I386" w/o the quotes and click Continue.

If still nothing works it will probably be necessary to perforn a non-distructive System recovery. To do this go to Start > All Programs > System Recovery > System Recovery. Follow the prompts to perform a non-distructive system recovery. This should save all personal files, programs and settings. But you may want to backup anything that is important just in case as "stuff" does happen. Also, after this you [may] need to redownload MS/Windows updates, and your anti-virus definitions and any anti-spyware updates.

Hope something here is helpful.

Charlie

Collapse -
My My Charlie, what a great post
by tallin / October 10, 2007 3:30 PM PDT
In reply to: Re: what is going on

I will sure keep it for future problems if they arise, well done.

Collapse -
The windows firewall is no joke.
by R. Proffitt Forum moderator / October 9, 2007 11:12 PM PDT

It's often panned by those that don't look deeply at how firewalls work. Yes the Windows XP firewall is one way but so were most firewalls when they first came out.

To pan it sharply without telling why is not a good idea.

Today we like the two way firewall with some reporting. However with simple users some may debate if such is a good idea. Those messages and questions could confuse "users."

Bob

Popular Forums
icon
Computer Help 51,912 discussions
icon
Computer Newbies 10,498 discussions
icon
Laptops 20,411 discussions
icon
Security 30,882 discussions
icon
TVs & Home Theaters 21,253 discussions
icon
Windows 10 1,672 discussions
icon
Phones 16,494 discussions
icon
Windows 7 7,855 discussions
icon
Networking & Wireless 15,504 discussions

REVIEW

Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.