Windows Vista forum

General discussion

Windows Vista not connecting to internet

by needinghelp / March 18, 2007 4:09 PM PDT

I just purchased a new Sony Vaio laptop a couple of days ago.Its running the Windows Vista Home Premium program that was pre-installed on it from Best Buy. I hooked up high speed interenet on it via comcast cable connection. Everything was working fine on it the entire first day that It was hooked up. Internet worked fine through the Ethernet cable connection the whole time. I uninstalled the Norton Internet Security that was pre-installed on it and then I installed Mcafee security instead.Well the next morning I log onto the computer and everythng is working fine for a few minutes. Then I get this message in the lower right hand corner sayinng that a program from windows was trying to connect to the internet. I don't recall the message completely suffice to say that is said something about a UPnP client service or something. Mcafee asked me if I wanted to allow it to conncect to the internet though it was unrecognized. I didn't know what it was so thinking that it may have been something harmful I had McAFee block the access to it from the internet. Just then after I blocked it. Another box came up and said that windows was upgrading a one time change and would need to restart the computer. I was on the internet while it did like a two minute countdown to restart the computer. There was a lil green load bar in the box so I figured it was ligit. It finished counting and restarted the computer then when it came back to windows again I tried to get back online. It would not allow me to get online.

The small connection incon with the two computers on the lower right hand side of the toolbar on the bottom has a red X to show that it is not connected and the message that I get when I move the courser to it says

connection status: Unknown

Dependecy service or group failed to start


Also whenever I start the computer now. I get this little yellow lock symbol in that toolbar section and a box with a yellow triangle with an eclamation mark inside of it and the message says:

Failed to Connect to a windows service

windows could not connect to the System Event Notification Service. This problems prevents limited users from logging on to the system.As an administrative user, you can review the System Event Log for details for why it didn't start.


I'm unfamiliar with Windows so I'm not sure how to access the Event Log either. but ontop of all that when I look at the connectivity. It shows the Ethernet connectio as being enabled but not connected. I talked to the comcast internet service provider and she attempted to help me troubleshoot the issue over the phone but nothing was working.


when I attempt to connect to a Network I get a message saying that Windows cannont find any Networks. Even when I attempted to use a wireless router connection at my job to see if that connection would work instead it still says that its not accessing it. All the diagnostic test that windows does just ends up leaving me with the message; Windows cannot resolve the problem, please contact your network administrator or Internet Service Provider.

Then ontop of that when I attempt to click on the connect to the internet icon in the control panel it just gives me a message saying that the Wizard cannot continue:

The wizard is unable to continue and needs to be closed. You can try running it again later. If problem persists, please contact your system admin or tech support. when I click for more details it gives me this:


component GUID:{7071ECA3-663B-4BCI-A1FA-B97F3B917C55}
component file:[c:\windows\system32\connect.dII]
Error:(0x8007277B)< The error message could not be found>.

Additional info:
Failed to detect Internet connectivity


I have no Idea what is going on with my connectivity cababilities. Seems like everything was working fine up until that automatic upgrade that restarted my laptop happened. I don't know if me blocking that program that wanted to connect to the internet caused it or what.Even now while I'm writing this I just got a message on my laptop saying that there are multiple security issues with my computer. I clicked on it and it says that my windows firewall and automatic updating is off. I am unable to turn them back on...I'm so confused whats going on with my computer. I didn't get online until I was sure to have my security up and running so I don't see how it would be virus related and I've only had the laptop for like two days now.

I can't turn on the Windows firewall because it says that its not running and windows can't do it either...

The only thing that I can think of is somehow completely rebooting my laptop to start everything over from scratch. If you happen to have any input or suggestion that would help please reply to this....I have seen anyone with a post that was similar to my problem yet but hopefully someone can help...thanks

Discussion is locked
You are posting a reply to: Windows Vista not connecting to internet
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows Vista not connecting to internet
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Exactly the same problem on a Sony Vaio VGC-LS25E
by bill_weir / March 31, 2007 11:54 PM PDT

I have the same problem. It began after a blue-screen crash when I had just run (unsuccessfully) Norton 360's Internet backup for the first time. Has anyone found a fix?

Collapse -
McAfee
by mopscare42 / April 1, 2007 1:29 AM PDT

Beings you are a Comcast customer and they offer the free McAfee, is that the way you went or did you buy the program?
My daughter had a similar problem when she downloaded the free version.
She called Comcast tech. support and after an hour on the phone they get her going again. In any case, give them a call.

Collapse -
virus mabey?
by bman222112 / April 2, 2007 12:10 PM PDT

sounds somewhat like a virus. I have had alot of experience in these matters. Try downloading blacklight. See what it tells you and if it says there is a problem use a DIFFERENT computer to look up how to fix it

Collapse -
Fix command is "netsh winsock reset catalog"
by Digital_D / November 20, 2007 4:47 AM PST

I had this problem with Windows Vista. I fixed the problem from a command prompt. Type "netsh winsock reset catalog" without the quotation marks.

Collapse -
The right command
by Ranger1961 / October 24, 2008 6:10 AM PDT

You da man !!! I have scowered the internet and you are the only guru to have this solution, thanks a million dude.

Collapse -
Had same problem: accessing internet.
by maebob4 / December 24, 2009 9:47 PM PST
In reply to: The right command

You did not scour enough. Try asking google. My solution was to hit "Control, then F2" and my light went from red (no internet) to green (internet now possible). My laptop was one year old and I had no previous problems (a Compaq with Vista). Try googling ("My computer no longer has the switch on to access the internet")There should be a variety of answers.
Bob J.

Collapse -
Windows Vista: Windows Vista not connecting to internet
by destiny228421 / June 22, 2010 8:11 AM PDT
In reply to: The right command

He is the man dude it worked for my laptop outstanding

Collapse -
netsh command prompt does not work
by jasonwinkler / December 9, 2008 9:05 AM PST

netsh winsock reset catalog does not work.

"The requested operation requires elevation"

What now?

Collapse -
netsh command prompt does not work
by mabowen66 / December 21, 2008 12:10 AM PST

Bring up the command prompt with "Run as administrator". I did this and then it required a reboot. Now my connection is working. I'll be interested to see if this is a permanent fix. Or if the problem comes back tomorrow.

Collapse -
run as administrator
by gelani66 / March 17, 2009 10:40 PM PDT

could you please tell me, what do you mean by that and how do you do it??

Collapse -
How to...
by edenfijd / March 18, 2009 4:54 AM PDT
In reply to: run as administrator
http://support.microsoft.com/kb/305780

This tells how to run a program as administrator. mouse over the program (in this case, Command prompt), press and hold shift, then press right mouse button. It should open a menu list similar to just right-clicking on something. Run as administrator should be an option.
Collapse -
it's not working
by gelani66 / March 19, 2009 7:24 AM PDT
In reply to: How to...

i did run it as an administrator, asked me to restart then the problem not solved.

my problem is i got compaq presario CQ60 with vista home premium. internet was working at first, couple days later. the laptop doesnt connect to the internet at all. it connects to any network but shows as unidentified and never connects to the internet.

p.s now i have one more problem i got a virus i guess win32.zafi.B how can i get rid of it??


anyone please help

Collapse -
help
by astroliner / January 6, 2010 11:23 PM PST
In reply to: it's not working

I have the same situation. I have tried all of the fixes on here, but nothing works. I have the preloaded Vista on my Compaq Presario PC. I have not downloaded anything except Mozilla. Everything has been working fine for a year, and now I cannot connect to the internet. I have bright house networks, and they were unable to help. Any suggestions?

Collapse -
2 things.
by R. Proffitt Forum moderator / January 7, 2010 12:12 AM PST
In reply to: help

1. You didn't reveal if you used the advice given in this discussion.
2. You didn't reveal if you had norton which does cause this after one year.

Collapse -
identical problem!
by mrkolander / August 16, 2010 1:04 PM PDT
In reply to: it's not working

I run an HP, Windows Vista dv9208nr (Pavillion dv9000 series). Its one of the first Vista laptops, so I've had it a few years (read: NOT a "this happens with Norton after 1 year issue).

I believe my problems also started after a Windows automated reboot/update ("windows must restart, blah, blah...").

I can find my wireless network, connect to it, but cannot connect to the internet (however, my wife's HP Laptop, which I am writing from, has no trouble). Every time I try to connect, I get the message, "Internet Explorer cannot display the webpage."

I have rebooted the laptop, restarted the cable modem, restarted the wireless router, made sure the LAN Settings are set to "automatically detect settings," performed the "winsock reset" from the command prompt (as an admin), and dealt with the subsequent "elevation" issue. All to no avail. I've also tried others, but I've tried so many they're starting to blur together a bit.

I could really use a solution, please! My computer was fine when I went to work, I kept the computer on and let it do its automated restart thing while I left, and when I came home I can't hop online. My network or other local unsecured networks.

Muchas gracias in advance for any assistance or additional questions.

Collapse -
oh yeah
by mrkolander / August 16, 2010 1:22 PM PDT
In reply to: identical problem!

1. I have tried all suggestions on this thread.
2. I have an expired copy of Norton that bugs me all the time to renew it, but (as mentioned earlier) it has been doing that for quite some time with no issue.

Collapse -
What to Do with "The requested operation requires elevation"
by lukinmyeyes / January 23, 2010 4:00 AM PST
Collapse -
Thanks a Mill
by Enta 3umry / February 1, 2009 8:46 AM PST

This, "netsh winsock reset catalog" worked like charm.
Thanks a million,
Best Regards

Collapse -
Thank you!
by tpsf_8919 / February 24, 2009 12:19 PM PST

You just saved me a whole lot of money. Didn't know what to do and was scouring the internet trying everything, and then your suggestion worked!

Thanks.

Collapse -
Internet Connectivity problem
by Walgrom / May 4, 2010 9:04 AM PDT

Thanks - worked a treat!

Collapse -
Lost connectivity
by Zatufomo / June 23, 2012 1:48 AM PDT

Thank u, my friend. I was ready to put my lap top in the garbage but you saved it. You info. Really worked

Collapse -
Fixing it.
by stathisdjs / February 24, 2009 10:14 PM PST

I dunno much about that Laptop,but i do know,that there must be a CD coming with it for the motherboard.Go to device manager,and see at the Unkown Devices.From there start clicking onto the devices,and checking for Updates FROM THE CD THAT CAME WITH THE LAPTOP.If everything goes allright you should be able to connect to the internet after that.Otherwise connect from another PC to the internet and seek on how to see if you can access your router from your Laptop.If you can connect to it,then you might have to reinstall vista.

Collapse -
Almost the same problem.
by ThatEmoPsycoKid / November 30, 2009 7:30 AM PST

I have pretty much the same problem, I got a Blue Screen of Death and then bam all of a sudden Vista just started to block every program from the internet except Internet Explorer and all of the other Microsoft built programs on my laptop. I'm planning on doing the free Windows 7 upgrade so that it might fix my problem.

Collapse -
Fix command is "netsh winsock reset catalog"
by YELAIAH / November 29, 2010 9:51 AM PST

It worked for me very well, thank you very much!!!!

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?