General discussion

Windows Vista- Can't Print!

I have Vista installed on my laptop and neither printer than I own will work. My newest printer is a Canon Pixma iP2600. I installed the software successfully, but nothing will print. Through Control Panel I opened the printer (which is set as default) and attempted to print a test page. My printer is online and the document appears in queue. The print status bar goes green about a quarter of the way and I get an error. "Printer data cannot be sent because of the current printer status." I've run the troubleshooting included with the Canon software, updated the driver via Microsoft, restarted the computer, tried again with the firewall turned off. In short, I've exhausted all of the options that I can come up with. Help?

Discussion is locked

Follow
Reply to: Windows Vista- Can't Print!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Windows Vista- Can't Print!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Port

I also checked that the port was correct as I'm running through USB.

- Collapse -
driver

Have you tried updating the driver from Canon's website?

- Collapse -
Driver

Already tried to update the driver. Appeared to update successfully but the printer still won't print. I also can't get information on my printer status or ink levels but it says that the printer is online.

- Collapse -
me too

I have a similar problem with a Samsung ML-1740 printer on Vista. The control panel says it is "Ready", but even a test page will not print. It simply asks if I want to use the troubleshooter for diagnosing the problem. I've installed and re-intalled several times...with firewall off, as administrator...all I could think of.

any new updates to this problem....thanks.

- Collapse -
Question for both posters

Did you install the driver before plugging the printer into the usb socket on the PC?
If not or not sure, unplug your printer, delete all print tasks in the print queue and uninstall the software and delete the printer from contol panel/printers then reinstall the software and then plug in the printer.
HTH

- Collapse -
did that

I have done that several times. deleted re-installed etc. tried every which way, but no luck. Printer and cables have been tested as ok on other PCs. Installed different printer on this vista pc and it worked ok. Just can't get this samsung printer to work, with no real error messages.

- Collapse -
Is this Vista compatible?
- Collapse -
samsung has drivers for windows vista and win 7

Newest drivers on the website says it is. I also installed the printer on 2 other Vista pc's (my kids laptops) and it works fine. It is something on my vista printing process for this printer specifically. Let's try another approach, other than using the driver's uninstall tool to remove the driver (cause I already did that), is there a way to clean out the registry to make sure any remnants of this driver is out of my system so I can install clean again? Thnks.

- Collapse -
There are driver cleaners.
- Collapse -
i am downloading a cleaner now

I have no other printers installed and the port is set to USB....the printer is detected as I already stated. It is in a ready state. If I remove the USB cable (disconnect) the printer says offline. So there is obviously communication. It just won't print. I am going to try and clean out whatever previous information the registry has about this printer.

- Collapse -
fixed it myself

I knew the problem was in vista registry. I edited the registry myself, and deleted every instance of Samsung ML-1740 keys I could find. Long process. Rebooted and re-installed the drivers.

Works like a charm now.

- Collapse -
HPs have a similar issue.

HP FINALLY issued a printer driver cleaner for such an issue. It's a shame that 2 decades later and we still get problems like this.
Bob

- Collapse -
PS. Forum nesting.

The nesting only goes so far then you need to reply to the top post to start it again. Otherwise you get posts that you can't reply to.

CNET Forums

Forum Info