General discussion

Windows Update - Now sound doesn't work

I just installed a bunch of updates from Windows Update. Now my sound doesn't work. My volume icon has a red x on it, and when I right click, bring up the sound options, it says there are no audio output device installed????

What the heck! Should I do a restore?

Discussion is locked

Follow
Reply to: Windows Update - Now sound doesn't work
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Windows Update - Now sound doesn't work
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
How to restore (link only)
- Collapse -
Windows Update - Sound dosen't work

The exact same thing happened to me. When I went to my Device Manager, it first asked me to enable the drivers. When I did, it said that it failed, and wanted to resintall the drivers. After it searched, it said it had the most up to date drivers, but still asked to reintall them.

Does anybody have any suggestions?

- Collapse -
no sound

that problem usually happens with sigmatel audio drivers, what you have to do is, go to control panel, then go to programs and features, try look for sigmatel, if you see it delete it, then restart your computer and automatically will detect the audio driver native from windows vista and it will reinstall it by itself, that should resolve your problem, if not try this, right click on computer, then click on manage then on the left side double click on device manager, then go to sound , video and game controllers right click on sigmatel audio, select update driver software, after that there is going to be 2 options select browse my computer for driver software, now in the next window, select the option that lets you pick from a list of device drivers on my computer, then select high definition audio device and click on next, that will reinstall the driver that comes with windows vista by default and correct the problem, if not try updating the audio driver

- Collapse -
Fixed

I do not have sigmatel. I have conexant high def sound.

I just did a system restore and it fixed my problem. Man, I should probably get a Apple. :-S

- Collapse -
Sigma Tel Audio Not Working After Vista Update

I uninstalled the Sigma Tel Audio completely & then restarted my laptop. Success finally!! I've been trying to get the sound back for some time now. I'm not all the computer savvy and the info suggested by Microsoft Vista, Sigma Tel, Gateway only created more confusion and none of it fixed the problem. Your solution seems so basic I have to wonder why Microsoft doesn't offer it. I wanted to let you know how grateful I am, Thank you so much. In the future I will come to CNET first for help instead of Microsoft. Thank You again.
R

- Collapse -
audio problem solved

DUDE THANKS! MY SOUND DIDNT WORK FOR MONTHS AND YOUR INFO SOLVED MY AUDIO PROBLEM! I Updated high definition device on the Manage your computer window, and ta-da. Thnx again

- Collapse -
I know this was forever ago buuut...

So I was fixing my grandmas old laptop and I tried everything on here but it didn't work. But it was simpler than I thought. If you still have the speakers on there and it still doesn't work because it says that you don't have anything installed go click on computer, then click on manage then on the left side double click on device manager, then go to sound , video and game controllers and Disable...then enable again...And It worked for me..
Sorry I know this is real old news but it just happened so I felt like sharing just in case anybody came across this problem in the future...

- Collapse -
SAME PROBLEM

I HAD THIS SAME PROBLEM TODAY. I UPDATED MY CONEXANT HD-SMART AUDIO DRIVER VIA WINDOWS UPDATE AND MY SOUND DRIVER WAS CORRUPTED AFTER INSTALL AND RESTART. WEIRD STUFF GOING ON HERE. OH WELL, I WONT UPDATE UNTILL THE UPDATE IS POSTED ON HP'S WEBSITE SIMPLY BECAUSE I DON'T TRUST MISCROSOFT UPDATING OTHER MANUFACTURE'S PRODUCTS.......

- Collapse -
weird

I have an HP to. I have an HP Laptop DV6000

- Collapse -
Never update drivers via Windows Update.

That's an age old lesson. Sorry you had to learn it first hand.

- Collapse -
I didn't ask to update drivers

I never went to even try and update drivers. A bubble popped up and said "windows is ready to install new updates" let it do its thing and, bam, no sound. lol

- Collapse -
Use the fix above.

There is no drivers being installed that I know of. Please supply which KBxxxxxx numbers are being installed next time if you want forum members to dissect this.

In the meantime, use the above to fix.

Bob

CNET Forums

Forum Info