Resolved Question

Windows update broke my network connection

Aug 16, 2018 8:17AM PDT

So here's my situation: I have a custom desktop computer bought from iBuyPower years ago, which I use exclusively for gaming.  I turned it on yesterday, opened Steam to browse the storefront as I usually do, then stepped away to use the toilet.  By the time I came back, there was a perfectly ordinary Windows message saying updates had been installed and it was counting down to restart, so I closed Steam and clicked "Restart Now."

Immediately upon rebooting, my network connection has been broken.  The desktop has a built-in wireless adapter (802.11bgn 1T1R) which came free with the order but I never use in favor of an ethernet connection (Realtek PCIe GbE Family Controller).  It has always been plugged into the router via ethernet, just like the laptop I am posting this from.  The laptop, router, modem, and cables all work fine, and nothing physical seems amiss inside the desktop tower, so it is unlikely to be a hardware issue.  The Windows updates are literally the only variable between now and when everything was working normally.

My desktop runs Windows 7 Home Premium and the specific updates installed yesterday are KB4087364, KB4344152, and KB4343900.  If it helps, here are the hardware specifications:

Motherboard: ASUS M5A97 R2.0 -- AMD 970 w/ 2x PCIe x16, 2x USB 3.0, 6x USB 2.0
Processor: AMD FX-6300 CPU (6x 3.50GHz/6MB L2 Cache)
Memory: 16 GB [8 GB x2] DDR3-1600 Memory Module - Corsair Vengeance
Video Card: NVIDIA GeForce GTX 760 - 2GB - Single Card
Hard Drive: 2 TB Hard Drive -- 64MB Cache, 7200RPM, 6.0Gb/s - Single Drive
Sound Card: 3D Premium Surround Sound Onboard
Network Card: Onboard LAN Network (Gb or 10/100)

I know those last two are vague.  iBuyPower doesn't provide exact details here.  I'm not a techie, so I used their configurator when making the purchase and haven't made any modifications since then.

Windows Network Diagnostics can't identify the problem.  I opened the Network and Sharing Center, clicked on "Connect to a network" and get a message saying "No connections are available" even though it is still plugged in via ethernet.  Trying the troubleshooter here returns this error:

Package ID: Unknown
Path: Unknown
Error code: 0x80070057
Source: Command line
User: [Computer name]\[User name]
Context: Restricted

I made sure the Local Area Connection was enabled and that network discovery was turned on; no affect.  I tried using System Restore to rollback the updates, but it fails and returns “an unspecified error” code 0x80070005."  (Trying this from Safe Mode doesn't work either.)

I tried uninstalling the new updates directly, then reinstalling them through offline installers.  I tried downloading and repairing up-to-date network device drivers directly from the manufacturer.  I tried running a deep scan with my antivirus software (IOBit Malware Fighter 6.1 Pro), then disabling the antivirus to see if that was blocking something.

I tried running netsh command prompts to reset IPv4 and IPv6, and then sfc to find any corrupted files.  I tried restarting services and looking for errors in the registry.  I tried creating a new user with administrator privileges, but the Windows User Service fails at the login.  I even tried the old "unloading power" trick.

Nothing I've tried works.  Indeed, it seems like I'm only stumbling into more things that are broken.  Is there anything else I can do, short of formatting the HDD and reinstalling OS from scratch?

Discussion is locked

desatj has chosen the best answer to their question. View answer
Answer
Follow
Reply to: Windows update broke my network connection
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Windows update broke my network connection
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments

Best Answer

- Collapse -
Network
Aug 16, 2018 4:46PM PDT

Boot a linux live cd and see if that can access the web via wired.

If it can then I doubt there is any hardware busted.

Next step is to spin in your backup.....if your not making backups you just found out why you should.

The final step is a bare metal install.....painful.

Btw.....your doing that winupd stuff wrong.

Set winupd to just tell you there are updates don't download them.

Select the ones you want and hide the rest.

Then allow winupd to continue.

- Collapse -
I can't even
Aug 16, 2018 7:56PM PDT

Where do I get a Linux live CD? I have no experience with Linux.

And how would I even know what Windows updates to pass on? I'm little better than a layman at this stuff. I'm just Googling the errors I get and trying to follow instructions from people who seem to know better than me.

- Collapse -
(NT) Where do you get?
Aug 16, 2018 8:49PM PDT
- Collapse -
Trying again
Aug 16, 2018 9:26PM PDT

Where do you get?......you make it.

https://www.google.com/search?hl=en&ei=LEJ2W5-5HqWb_QaG0oaQDw&q=linux+mint+live+cd&oq=linux+mint+live+cd&gs_l=psy-ab.3..0l9.61272.65404.0.68845.8.8.0.0.0.0.129.924.0j8.8.0....0...1.1.64.psy-ab..0.8.918...0i67k1.0.k62GPRDc6SU

I see some videos there so do some watching and reading.

If a disc won't work for you put it on an usb stick.

Boot it up and test.......no need to intall.

Winupd.....when you get the list of what winupd wants to install just click on the first item and over on the right you will see a more info link.

- Collapse -
Clarification
Aug 17, 2018 8:03AM PDT

Ok, so I either need some DVD-Rs or a 8gb USB drive. Those are cheap enough, so I'll have to get back to you as to whether Linux can connect where Windows fails.

As far the the Windows Updates go, I know how to look up the details of what an update contains. I meant, how do you determine if something is worth installing? I thought the whole point of these is to patch issues and shore up security, to keep the OS running as smoothly as possible. It's to be expected that there will be mistakes sometimes. But I'm not a programmer, I have to trust that Microsoft isn't actively breaking the product they sold me. So what things do you look for in an update which make you think, "don't need it"?

- Collapse -
Update
Aug 17, 2018 9:09AM PDT

When you get the monthly quality rollup that you need.

Sometimes I'll get some oddball thing that when I read the description or run it through google it becomes something I don't need so I hide it.

There were a number of those during that push to get users to switch to w10.

- Collapse -
Windows 10
Aug 17, 2018 10:02AM PDT

What's your take on W10? Is it worth moving on from W7?

I resisted upgrading when it came out, since the first generation of anything new is usually a mess, but I've heard it has improved greatly. I had already to clean reinstall my OS once before this past year. If the increasing number of errors I'm getting is any indication, W7 seems to be hitting the end of its life cycle.

- Collapse -
W7
Aug 17, 2018 10:52AM PDT

In about 16 months you will have to do something as support for w7 will end.

The good news is that mobo shows support for w10.

I've run w7 on this machine for 8 yrs....I don't see any errors.

I do run regular full system backups because stuff happens.

- Collapse -
Linux LiveCD failed
Aug 18, 2018 8:32AM PDT

So I followed the instructions I found on the Google search link you provided and created a LiveCD with Mint 19. (LiveCD is a misnomer, btw, because the ISO is too big for a CD-R, so I picked up some DVD-Rs.) I tried two methods, Windows's built-in "Right Click>Burn disc image" and the Active ISO Burner recommended by Rick Castellini's video. Both produced the same result: a DVD containing the Linux Mint file tree, but no prompt to run or install. And because these aren't Windows files, there is no executable to manually double-click. (And before you ask, no, I didn't accidentally buy DVD-RWs.) Now what?

- Collapse -
I used IMGBURN from Ninite.com last time.
Aug 18, 2018 8:40AM PDT

I've never used the Windows method.

But there is usually no prompt to run it. We must set the PC to boot from CD/DVD or USB and then it runs. The reply above makes me think you are trying to run in from Windows.

- Collapse -
Tutorial omission
Aug 18, 2018 9:44AM PDT

LOL, of course. The tutorial video I was watching didn't mention booting from the disc, so I completely overlooked this most basic step. (Story of my life.) I was under the impression that it would run as a "shell" or whatever, as if the Linux OS could be run from within Windows OS.

Anyway, I was able to get Linux booted and it does indeed have network connections. So my problem is not hardware and is definitely something broken within Windows. The only thing of consequence on this computer are my games, all of which can reinstalled from Steam or backups, so I might just format the HDD and reinstall W7 or upgrade to W10 from scratch.

Thanks for swooping in there!

- Collapse -
Live cd
Aug 18, 2018 9:03AM PDT

Do either of these disc boot?

I'm not a linux user I just keep an old copy of zorin in a drawer as a quick OS I can boot and do basic stuff.

I made the thing years ago and I don't recall a problem doing that.

The w7 native burn iso worked fine.

Perhaps a linux user will be along or post over in the linux forum.

- Collapse -
My simple mistake
Aug 18, 2018 9:48AM PDT

As I usually do, I get hung up on details and forget the most simple things. R. Proffitt pointed out that I needed to restart the computer and boot from the disc, not try to run the Linux install from within Windows.

With Linux running, I had a successful network connection, so my problem is definitely a Windows OS error. I'll probably format the HDD and reinstall W7 or upgrade W10 from scratch. There's nothing important on there I don't have backed up and I want to make sure absolutely nothing gets carried over.

Thanks for all your help and patience.

- Collapse -
Same issue?
Jun 28, 2019 6:04AM PDT

Desat,
I just experienced the same issue with "strongly Recommended" Windows 7 update (June 2019). Lost internet connection capability. What finally fixed your problem?
russ

- Collapse -
Answer
Just a comment.
Aug 16, 2018 8:38AM PDT

After running into too many machines that arrived at the repair counter with IOBit that is also a source of issues.

We usually treat the machine as if it had a fresh Windows install. That is, we reinstall drivers in the order of motherboard, cards and apps as required by the PC maker. Usually that clears it up. If there's more involved like any VPN software that is ripped out with IOBit since we have to defer to that company when they break networking.

- Collapse -
Just a reply
Aug 16, 2018 10:33AM PDT

My laptop is also running a full suite of IOBit security software without any problems. And I don't use a VPN on my desktop. Aside from YouTube and GameFAQs, I don't even do any general web browsing on it. It really is just for running games; mostly Steam, but I have a couple from other sources like Uplay, Origin, and GOG.

- Collapse -
Then it's back to IObit support.
Aug 16, 2018 12:08PM PDT

Here we have a procedure but you seem to like IObit. Here, it creates work for the shops so we love it for that.

- Collapse -
IOBit's not the problem here.
Aug 16, 2018 7:49PM PDT

That aside, what antivirus would you recommend? I used to use Avast, but I got tired of the constant desktop ads and false positives (one time it thought Skyrim was malware).

- Collapse -
Since the office no longer runs W7
Aug 17, 2018 10:59AM PDT

We did the move of some hundreds of machines to W10 we just use W10's own Defender. I used to use what's up at Ninite.com.

- Collapse -
Answer
The remedy is to uninstall the bad update
Aug 18, 2018 7:03AM PDT

Hi, desatj

You're the victim of a defective Windows Update. Microsoft is actually aware of the issue, but the "fix" they're recommending (reinstall drivers for the Network Interface Controller) is easier said than done. You can find other examples of these symptoms on Google, but none of the proposed solutions works in this case -- at least not from one session to the next. The update breaks so many things that the only solution I could find was to uninstall it -- after which everything returned to normal.

The culprit is KB4343900. If you already know how to uninstall an update then don't bother reading the rest of this. If you're not sure, then do this:

1. Start > Control Panel > Windows Update
2. Click the "Installed Updates" or "View Updates" link on the left. A list of all installed updates will appear.
3. Make sure they're listed in order of most recent date first. If they're not, click the caption of the "Installed on" column to arrange them chronologically.
4. In one of the Microsoft sections, locate KB4343900 and right-click it.
5. Click "Uninstall" and follow the prompts
6. Once it's uninstalled, you'll be prompted to Restart. Go ahead and restart.
Hopefully, once you've scrapped that update you'll be OK.
WARNING: Now that it's no longer installed, Windows Update will keep nagging you to install it. Just right-click it and click "Hide Update".

- Collapse -
Not that simple
Aug 18, 2018 7:56AM PDT

Thank you, but I've tried that already and it hasn't fixed the problem. I've also made sure my network adapter has the latest drivers directly from the manufacturer's website and checked the device manager for conflicts.

- Collapse -
Tough one!
Aug 18, 2018 8:29AM PDT

Sorry, I didn't realize you had already uninstalled the offending update. On my system it was disabling various Windows Services, causing various drivers to "disappear", giving error messages saying it couldn't connect to the System Notification Service, etc., etc., etc., but the uninstall did resolve those problems for me.

FWIW, this is the website containing Microsoft's description of the known issue with that update and their recommendation for a fix. Personally I couldn't find the Device they're referring to, but you might have better luck.
https://support.microsoft.com/en-us/help/4343900/windows-7-update-kb4343900

I hope you're eventually able to return to normal. Sorry my solution didn't work for you.

- Collapse -
Answer
DNS errors for many websites after Windows update
Aug 25, 2018 12:55PM PDT

On my Windows 7 32bit, installed updates KB4087364, KB4344152, and KB4343900 yesterday (Aug24,201Cool and after rebooting, was having internet connection issues where I would get DNS errors for most websites I tried to visit. After reading this thread, I know that you tried uninstalling the KB4343900 update and that did not work for you so assumed it had to be one of the other updates causing my issue.

Knowing that my system was working ok before those 3 updates, I uninstalled KB4344152, (Programs and Features, view installed updates, click on KB4344152 to uninstall), rebooted and that fixed my internet connection issues. No more DNS errors, so it had to be that update.

I also had the same DNS error problem in the past with KB4074598 which also caused very similar internet connection issues. Uninstalling the update fixed that too.

Hope this helps somebody with similar internet problems after installing Windows updates.

- Collapse -
Dell Laptop Win 7 Stop responding after KB4344152 & 4343900
Sep 2, 2018 12:43PM PDT

I have 2 Dell laptops running windows 7 that stopped responding after the latest windows updates KB4344152, and KB4343900. They would stop responding and not shut down or log off without holding down the power button. Uninstalling KB4344152 seems to have fixed the issue, but I may uninstall the other for good measure. Shame on MS for not validating their updates!

- Collapse -
Answer
In the future
Oct 16, 2018 10:33AM PDT

I had the same thing happen when updating my Windows 7 in September 2018. In addition, my restore points (all of them) were wiped out. Personally I feel Microsoft is making an effort to interfere with Windows 7 to get people to go to Windows 10. Something I instituted a while back that has saved my bacon, especially this time around, is to use a cloning software. I have used NTI free for several years. Once a month I clone my SSD (solid state drive) to an external SSD. When this Microsoft Windows 7 update messed up my computer and erased my restore points I simply removed the current SSD, and popped in the SSD clone. Yes, I did have to update a few personal files from the early part of September from my data backups but that was easy enough.
I then immediately deactivated Windows Update this time. Enough is enough on these update problems. No more for me. Since Windows 7 is to lose support in January 2020 I am convinced Microsoft is on a mission to not make it easy on 7 users (my opinion). When I travel I use a laptop with Windows 10. In no way, shape, or form, is Windows 10 superior to Windows 7 when it comes to privacy, personal control, or system organization, and I know Windows 10 quite well. I love 7 and plan to use it until my computer hardware breaks, and I can't find another Windows 7 computer to replace it. One last note, I do prefer cloning to image backups. Over the years a small glitch or two has on occasion interfered with my ability to reinstall an image backup. I simply don't trust an image backup anymore like a clone.

CNET Forums

Forum Info