HolidayBuyer's Guide

Windows Legacy OS forum

General discussion

Windows service pack 3 - access denied.

by blom09 / December 4, 2008 7:05 AM PST

Hey people

I just bought the new GTA 4 and it apperently needs service pack 3, so i downloaded it from microsoft download center but in the middle of the install it stops and says access denied. It then continues to remove the service pack again and when it is almost done it said that it ways not removed corretly and that XP might not work optimatly.
So i tried all 3 solutions given to me on the support site that windows has on the problem,http://support.microsoft.com/kb/949377, and none of them give any result. So i try i pasting in :
cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose


in the notepad and save as reset.cmd but when I click on it opens and then closes again in less then a second. :/

Please help me here. I contacted microsoft support by email, but i still have to wait for their answer.

Thanks a lot.

Discussion is locked
You are posting a reply to: Windows service pack 3 - access denied.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows service pack 3 - access denied.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
That's what it's supposed to do
by Jimmy Greystone / December 4, 2008 7:35 AM PST

That's what it's supposed to do if you run that little script. It will execute the commands, and then once that's done, there's no reason for the command prompt to be open, so it closes.

Also, don't use the Automatic Updates installer for SP3, go download the 300 some MB "network admin" version. This way, little hiccups in your Internet connection won't potentially hose your entire system. It also just seems more reliable in a general sense. Loads of people have problems with the Automatic Updates version, while relatively few have problems with the full download version.

Just make sure your system is free of any and all viruses and malware before you install, or you may have problems of a very nasty nature.

Collapse -
.
by blom09 / December 4, 2008 5:46 PM PST

Are you sure it is supposed to do that? Because on different websites it says that this process might take some time so i just find i kinda wierd that mine completes in under a second. :/

and i have also tried and downloaded the 300 mb version,
http://www.microsoft.com/downloads/details.aspx?FamilyId=5B33B5A8-5E76-401F-BE08-1E1555D4F3D4&displaylang=en
,and the same thing happens to me allover again.
So i also tried finding out if the registry update thing failed as microsoft shows you how,http://support.microsoft.com/kb/949377, and mine has apperently failed and it says 'DoRegistryUpdates failed'.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

HOLIDAY GIFT GUIDE 2017

Cameras that make great holiday gifts

Let them start the new year with a step up in photo and video quality from a phone.