...downloading, including GIMP, have you done a full system scan with a good quality spyware program such as the free one in the link below? If not, spyware, trojans and such can cause media player issues and using the tool is a good idea.:

Ewido/AVG Antispyware 7.5 Tool

Next, to make sure WMP is the default player you'll want to open WMP from the Start Menu.. Can you do that? If so, you should be able to click on "Tools", then "OPtions", then the "File Types" tab (at least it's that way on WMP 10, then make sure all your preferred boxes are CHECKED.) You also might want to access Windows Explorer, click on "Tools", select "Folder Options", then the "File Types" tab.. When that opens, visit each of the file types for your clips, such as .asf, then make sure WMP is the preferred program.

Hope this helps.

Grif