Computer Help forum

General discussion

Windows Media Player has stopped working

by Freedom55 / January 14, 2011 9:03 AM PST

My Windows Media Player has just stopped connecting to the Internet. It will play the CDs that I have loaded previously but when I try to connect to Internet radio, I get an error message - "Line: 157" "Error: Expected ')' in regular expression". This doesn't mean anything to me. Oh, when the initial WMP page loads, it asks me if I want to debug the page (never used to happen). When I click "Yes" it tells me it can't be debugged (so why did it ask?).

I've tried a system restore - no joy - and run a full system scan - no malware. I don't know what to try next. Any thoughts from you wizards out there?

I'm running Windows Vista, SP2 and IE 8 on a Dell XPS 720.

Thanks in advance for any advice.

Discussion is locked
You are posting a reply to: Windows Media Player has stopped working
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows Media Player has stopped working
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
My first thought is "plugins."
by R. Proffitt Forum moderator / January 14, 2011 9:08 AM PST
Collapse -
No joy there
by Freedom55 / January 14, 2011 12:06 PM PST

Hi Bob,

Thanks for the comment. I checked for plugins but I only have the default visualization setup - which can't be disabled. My thought is a file or setting that has somehow become corrupted but I don't know where to look or how to restore - if that is the problem??

Most frustrating.

Collapse -
Then the next usual is the video drivers.
by R. Proffitt Forum moderator / January 14, 2011 12:28 PM PST
In reply to: No joy there

I read you suspect damage to WMP but you don't tell why. If it wasn't for that I would suspect video or audio driver problems. Some folk update those from Windows Update and report problems like this.

Ok, since WMP is part of the OS let's use SFC for Vista. Links about this at google or

It's very important to know if you are posting at since I need to know what else is being done.

Collapse -
Problem Solved - Sort Of
by Freedom55 / January 15, 2011 3:18 AM PST

Hi Bob,

Firstly, I suspected a corrupted file since the problem started just after I downloaded the latest update from Microsoft.

In any case, it's working now (after a fashion). I went into my anti-virus software (F-Secure)and changed the setting for WMP from "Allow" to "Block". Then opened WMP and tried to connect - same error message (no great surprise). I then went back to F-Secure and changed the setting from "Block" to "Allow". Re-opened WMP and it connected to an Internet radio site. Closed WMP and then reopened only to find the same error message - tried a different station only to have it connect just fine. Once a connection was established I could go back the the original station and connect.

So, it's working after a fashion, I just have to fiddle with it a bit. Strange beasts these computers.

Thanks very much for your time and comments.


Collapse -
by R. Proffitt Forum moderator / January 15, 2011 2:32 PM PST

That's a GREAT clue.

Here's what I'm encountering today. Firewalls and ESPECIALLY the new "privacy protection feature" of such antivirus suites are causing new and interesting failures. I can't say I know all of the suites that cause this but if you block a MSFT app, it can do very odd things.

Collapse -
by Freedom55 / January 16, 2011 9:14 AM PST
In reply to: AHA!

I'm guessing that the last MS update reset or changed something in the way the program reacts to the anti-virus software. Sure tough to diagnose some of these problems. Wouldn't it be so much easier if we didn't need anti-virus software!!

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.