If you're trying to play a mpeg online, which browser are you using? If you're using anything other than Internet Explorer, be sure the Windows Media Player plugin is installed.

Whether offline or online, make sure that Windows Media Player is the default player for the file extension you have chosen. Although I'm using WMP 10 here, it should be similar on your machine. Open Windows Media Player, click on "Tools" in the upper left, choose "Options" from the menu list. When the "Options" window loads, click on the "File Types" tab, then make sure that the box next to "mpeg" is CHECKED.

Another possible fix would be to reinstall the Media Player 9 codecs from the link below:

http://www.microsoft.com/windows/windowsmedia/format/codecdownload.aspx

Hope this helps,.

Grif