Audio & Video Software forum

General discussion

Windows Media Player 11 - Won't Open at all...

by st_loosh / June 2, 2007 12:32 PM PDT

I tend to use WMP for all my multimedia needs...I have other programs that either show video/DVDs alone, or play music alone, but have been a faithful user of Window Media Player for um-teen years now, and its never failed me ...until now.
The darn thing just won't open. I clicked on the shortcut on my Desktop; I clicked on it in the Programs List, the cursor changes to an hour glass for 2 seconds, then NOTHING HAPPENS..

I deleted it a few moments ago, re-installed it (from the Microsoft Home page), and still NOTHING! its like I didnt click on it at all....Please help / Feel like a fish out of water here...

Oper. System: Windows XP SP2 - Home Ed.
Computer: Dell Inspiron 1000 (nothing flashy, but it works for me)
Free Memory left: 20 Gb ( out of 30b...just got a new harddrive)
Length of Problem: Its only been acting up some 3 days ago...

Discussion is locked
You are posting a reply to: Windows Media Player 11 - Won't Open at all...
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows Media Player 11 - Won't Open at all...
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Finally!!
by alejaraluc / July 30, 2010 11:08 PM PDT

Genius solution! Quick and painless...

Collapse -
I got it,we are proud of you.
by leikaiyaoming / July 31, 2010 10:16 AM PDT

I got it,we are proud of you.

Collapse -
WMP 11
by fbolanos / August 14, 2010 2:12 PM PDT

Great!!! Very simple but I will never figure it out by myself...
Many thanks...
F.

Collapse -
It worked!!!! It worked!!!!!
by derrywallace / September 26, 2010 12:32 PM PDT

Thanks for the info!!!!! Finally after over a year!!!! It works!!!!

Collapse -
Worked for me!
by Armaitus / September 28, 2010 2:57 AM PDT
Collapse -
Windows Media Player 11 won't open
by elegantapproach / January 5, 2011 9:07 PM PST

You are a genius!!! My WMP was left for dead long long ago until I chance upon this
forum and your instructions and it worked! Although I have been using other media player
it's good feeling to know this pain is finally relieved.
Thanks a million.

Collapse -
it wrks
by blakey413 / January 12, 2011 10:22 PM PST

i've been having the same problem ever since i uninstall avast, i tried ur solution and it did.

thanks much

Collapse -
Hi
by noctrine / April 3, 2011 1:28 AM PDT

Thanks alot i had given up on my wmp after i installed norton 2011 its working now.Thanks

Collapse -
(NT) Thanks. Worked great
by jenn8206 / May 30, 2011 1:39 PM PDT
Collapse -
Thanks!
by Steve_El_Gato / June 18, 2011 3:42 AM PDT

That worked great!!! What are those mighty little commands? Can they be used to fix other such issues?

Collapse -
Thanks!
by dholmes10 / July 7, 2011 12:34 PM PDT

This worked for me!

Collapse -
WMP opens and closes right away
by nripenr / August 30, 2011 8:00 AM PDT

Your suggestion did not work. Any other ideas?

Collapse -
Thanks. This also fixed problems with my Visual Basic. Net
by swainjk / November 22, 2011 3:46 AM PST

Thanks. This also fixed problems with my Visual Basic. Net not being able to create new items in a project. I was about to start looking at all of the libraries. You just saved me a lot of time and frustration.

Collapse -
This worked for me as well!!!
by Frostblade10 / December 21, 2011 4:41 PM PST

Oh my god, thank you so much!!! My WMP just stopped working one day; it just wouldn't open. Whenever I would try to open a file with it through the 'right-click menu', it would give some sort of server error.

Your solution through the command prompt has worked perfectly! I haven't used WMP in over a year!

Thank you!

Collapse -
(NT) Bravo it worked beautifully. thank you
by iboya / May 24, 2012 3:01 PM PDT
Collapse -
Here is a fix
by OKHexe / October 13, 2007 2:55 AM PDT

Here is what you need to do...
Run Task Manager by entering CTRL-ALT-DELETE , once you are in this window select processes and check if Windows Media isn't still running, if it is, end the process! What is known to many people as a ghost process a sort of left over from the previous run --
That worked for me! Good Luck!

Collapse -
Nope :'(
by hocky_nutty / October 15, 2007 9:51 AM PDT
In reply to: Here is a fix

Thank you for trying Grin but it didnt work Sad

More information: my MediaDirect doesnt work either. And when there is a Windows Media Player plugin inside a website, my internet explorer will just vanish into mid air.

Collapse -
re: wmp 11 won't open
by jmurray2112 / October 25, 2007 12:15 PM PDT
In reply to: Nope :'(

I had the same problem using Vista, something got screwed up somehow, and wmp 11 wouldn't open from any short-cut. I could get it to open if I went to the executable in the WMP folder in Progam files, and right-clicked on it, and chose "run as administrator". So, I searched a <b>lot</b> of forums. In the end, the thing that worked for me (mentioned in another forum somewhere) was to go to Control Panel, User accounts, and turn off the User Accounts control. Now wmp will run from any short-cut again. It'd be cool if someone knows why this happened, and what I could do to fix it correctly. Hope this helps somebody, because it was bugging the "bleep" out of me.

Collapse -
New Problem
by bhw33191 / November 16, 2007 2:06 AM PST
In reply to: re: wmp 11 won't open

I turned off the user account control thing like you did and it said i had to restart my computer. I did so and then logged on, but after about 2 minutes, the taskbar and all of my desktop icons went away although i could still see my background. Then this little 2 inch wide thing that looked like a minimized window or something appeared at the bottom right. It said Microsoft Win.. and the rest was cut off because the window was so small, and then the computer logged off. I do not know if this is related to turning off the UAC but i managed to log on again and turn the UAC back on before the computer logged me off again and now it is fine. I still cannot open WMP without running as administrator though. I think something must have gotten deleted but im not sure. Someone please help.

Collapse -
THANK YOU
by southbank48 / December 29, 2008 4:39 AM PST
In reply to: Here is a fix

Have not been able to open my media player and use to have to restart to open it. This time it wouldn't open. Your suggestion was exactly what was happening. This ghosting I remember from a few years ago with this same player. Thanks for reminding me of that. It's now working.

Collapse -
Windows Media Player won't open
by uvsminer / March 4, 2009 12:57 AM PST
In reply to: Here is a fix

This worked perfectly and it was so easy. Thanks so much!!!

Collapse -
SAME PROBLEM
by bhw33191 / November 15, 2007 11:31 AM PST

WMP 11 came pre-installed on my vista 32-bit computer. It worked fine for a while then stopped working for no apparent reason. When i click on the shortcut the computer sounds as if it is going to open the program and then nothing happens. Although when i right click "run as administrator" it does open. The only problem is that i can only play what is already in the library and i cannot drag any new files whatsoever. This problem is making me really aggravated with windows as i also have problems with my flash player on internet explorer, but thats another article. Could someone please help me because i really dont want to have to restore to a previous point because that is too much of a hassle. I dont believe i have tried downgrading "which seem to be now a popular thing to do with the so-called new operating system". Somebody please help

Collapse -
I am no tech but....
by ntaccounting / November 29, 2007 10:58 AM PST

I am so tired of seeing people trying to answer this question. I spent 4 days reading all the garbage on this issue and not one of you guys got it right. I went to microsoft tech support and believe it or not - it was helpful. I still have issues but I am at the very least using my wpm11....so this is what I did

I logged in as administrator

To resolve this problem, reregister the Jscript.dll and Vbscript.dll files. To do this, follow these steps:
1. Click Start, click Run, type regsvr32 jscript.dll, and then click OK.
2. Click Start, click Run, type regsvr32 vbscript.dll, and then click OK.

I am now able to run this stupid program as the administrator but not as the user....I hope this works for you!!
now if someone can tell me how to get it working as a user, I would be thrilled.

Collapse -
Nice.
by R. Proffitt Forum moderator / November 29, 2007 11:01 AM PST
In reply to: I am no tech but....

"regsvr32 jscript.dll" and other fixes are noted at the web link I supplied. It's a shame that your fix doesn't always cure this one. Just yours...

Bob

Collapse -
I stick with the fix I found
by OKHexe / November 29, 2007 12:58 PM PST
In reply to: Nice.

It works for me everytime that darn media player won't open. I also noticed the other day when I was making a movie with the movie maker and tryed to import it to the dvd maker, it would not let me because it said it was still being used or something like that. I followed the same steps and guess what....my movie maker was still running, so I stoped it and DVD maker finaly let me import it. I guess everyones computer is just differant, but the fix I have found is working for me.

Collapse -
Tried your fix and of course encountered another problem
by bhw33191 / December 11, 2007 6:14 AM PST
In reply to: I am no tech but....
Collapse -
Similar Problem
by bulabone / December 20, 2007 5:06 AM PST

Ok I have a similar problem, When I open WMP11 in Vista Ultimate, it opens but then quickly says it needs to close or says not responding, then stops all my media sharing. Windows Media Center then does the same thing, opens then when i try to play a song says there?s and error. I just thought it was the same old crap with Vista. So I got fed up and installed XP. Did all the updates and everything ran fine for a day or 2. Then the same thing happened on XP!!!! It opens and 2 seconds of loading my library.."WMP has encountered an error and needs to close". I tried WINAMP on both Vista and XP works fine....here are my stats with all the latest drivers.

MSI K9A Platinum MOBO (using on board audio)
AMD Athlon 64 X2 6400+ Black edition
SAPPHIRE 100189L Radeon X1900GT
OCZ Platinum Revision 2 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800
WD 70GB Raptor
WD 160GB

Collapse -
Similar Problem
by northumbria61 / December 20, 2007 9:55 PM PST
In reply to: Similar Problem

Try this simple procedure if it has been playing and then suddenly stops responding.

Start Task Manager (control,alt,delete) and under heading "processes" look for anything referring to Windows Media Player -ie: wmp---- etc. - select those which apply and click "end process"

Then restart Windows Media Player. - Good luck !

Collapse -
Similar problem
by bulabone / December 20, 2007 11:32 PM PST
In reply to: Similar Problem

yeah i wish it was that easy.....i just think my computer doesn?t like WMP11....i reverted back to WMP9, works great...installed WMP10, works great.....then installed WMP11 again, and as soon as it opens "WMP has encountered an error and needs to close" I have built tons of computers and never had a problem like this. Anyone know of any hardware issues that i might be having?

Collapse -
WMP10
by bhw33191 / December 21, 2007 1:39 AM PST
In reply to: Similar problem

How were u able to install WMP10? I think i tried doing that but it doesnt allow me to download it somehow.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?