Question

Windows Explorer default action for Folders

Hi all

I recently received a tip on how to change the default view in Windows Explorer so that the pane on the left shows the folders tree rather than the tasks list. I did this via "Tools" -> "Folder Options" -> "File Types" -> "Folder" -> "Advanced" and changed the default to "explore".

This seems to have worked OK, as when I go to My Computer etc it does indeed open in the view I wanted.

BUT...

I also found once I had done it that if I double click a folder in Explorer now, it opens in a new window, which I don't want. This is despite the fact that in the "Folder Options", the selected option is still "Open each folder in the same window". I tried changing that option, changing it back, restoring defaults etc and it hasn't made any difference.

AND just to make things even more fun, at some point along the way things have changed further and now when I double click a folder it not only opens in a new window, it opens as a "Search"! I have no idea how this started happening, as the Folder Options don't even have Search as an option.

Any ideas how to get this sorted out? Or at least get back to where I started, I can live without the explorer showing folders by default if I have to!

Discussion is locked
Follow
Reply to: Windows Explorer default action for Folders
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Windows Explorer default action for Folders
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
I would return to the Task Lists view

and then use a different instance of Windows Explorer to manage your files.

Going back to Task Lists returns My Computer to it's default, and since this is a "System" instance of Windows Explorer, it may be better not to change that.

But Windows Explorer is available elsewhere, for example Start > All programs > Accessories > Windows Explorer, and you can right click that to send a shortcut to the Desktop. That instance of Windows Explorer should open in the 2-pane view which will enable you to manage your files easier.

I'm a little confused. I am on my Windows 7 system at the moment and this does not have the "File Types" tab in Folder Options. I would have to wonder if changing the default actions in File Types was the best way to go. I was always a little apprehensive in amending anything there, and in fact in Vista and Win 7 Microsoft removed File Types altogether because of the problems sometimes caused by amending things here.

So, I would go back to square one and try again a different way. If you can get that file type reversed, see if that solves the issue. If it doesn't, then hit the "Restore defaults" in the Folder Options dialog.

Does that help?

Mark

- Collapse -
Tried that, no luck...

Thanks for the reply.

I can change the default view back to Tasks, but it doesn't fix the the problem of folders opening in a new Search window.

The "File Types" tab is the one where you can set what is the default program for any type of file. I don't know where that is in Windows 7, but no doubt it's there somewhere.

Going back to square one is exactly my problem - I can't get there! Somehow the default action for opening a folder has become "Search" and I can't seem to change that back again.

When you right-click on a folder and get the menu up, the default action is at the top of the list and bolded. It's normally "Open". In my case now if I do that the bolded default is "Search".

- Collapse -
Any System Restore points available?

Sorry that didn't work for you.

Does this system have any System Restore points you can go back to? If so, I would try that first before attempting any other options. The one suggested below, (Copy/pasting that string into the explorer address bar), is one I haven't seen before, and the poster hasn't returned yet to explain more.

If System Restore fails, then move on to the suggestion in the link below. It appears to fit your circumstances exactly;

http://www.cambiaresearch.com/c4/6aea61a5-460b-4313-a167-4f3b06edd934/Windows-Explorer-Opens-Search-Window-When-Clicking-a-Folder.aspx

That suggestion involves amending the registry, but doing that can be problematic because a wrong move in the registry can cause real problems with the system. So please take care, and also read Microsoft's guidance on how to backup and restore the registry.

Good luck.

Mark

- Collapse -
D'oh!

Yes, I should have thought of System Restore already! Obvious solution is obvious.

But sadly that hasn't worked either as I don't have a Restore point that works which pre-dates my problem.

However that other link you provided does seem to be exactly the problem I have, so I'll give that a try.

I'm aware of the perils of meddling with registry entries! I have done some registry edits in the past, but only where the instructions have been very clear - I'd never try just fiddling around in there!

I'll let you know how I go - if you never hear from me again, you can assume it ended badly.

- Collapse -
Success!

The registry edit worked, and I am cured! Cool

Thanks a heap Mark for your assistance!


Jeff

- Collapse -
That's great

Glad you got it sorted, and thanks for letting us know.

I had every confidence! Devil

Mark

- Collapse -
Answer
Possible solution

Open My Computer. Paste the following into the Address Bar;
C:\WINDOWS\explorer.exe /e,/root,::{20d04fe0-3aea-1069-a2d8-08002b30309d}

Then drag the resulting "window" to your Desktop to create a Shortcut. When you click on the shortcut you'll get the desired window view.

- Collapse -
Tell us more about this

I wouldn't recommend using that suggestion until we know more.

What does it do? Where did you get this option from? What does it solve?

Mark

- Collapse -
Doesn't really solve the problem

My problem isn't opening Windos Explorer, it's the way Explorer behaves once it's open - specifically that the default action for selecting a folder has become "Search" and I can't find a way to change that.

CNET Forums