Windows Legacy OS forum

General discussion

WINDOWS COULD NOT UPGRADE THE FILE %1 FROM %2 %1: %2

by peggylenox / July 16, 2006 5:10 AM PDT

I have a Dell Dimension 4100, Windows ME, 512 RAM. Yesterday, I did an upgrade on Total Recorder and when I restarted, I got the error message above. It fills up the whole page, is repeated several times. It says if Windows doesn't start, rerun setup. I've tried hitting F2 and F8, but I can't get out of that screen. I have the reinstallation disk, but when I put that in, nothing happened. I don't have a boot disk. So what do I do?? I think I was told I could make one on the laptop I'm now using> Of course, I want to avoid reinstalling windows and losing everything. HELP!! peggy from lenox

Discussion is locked
You are posting a reply to: WINDOWS COULD NOT UPGRADE THE FILE %1 FROM %2 %1: %2
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: WINDOWS COULD NOT UPGRADE THE FILE %1 FROM %2 %1: %2
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Try this
by Blue_Zee / July 16, 2006 5:46 AM PDT

Courtesy of Mike Maltby, MS-MVP:

First boot to DOS using a floppy and check whether you have a WININIT.INI file in your C:\WINDOWS folder.

If present rename it to something like wininit.old and try booting again.

It is also probable that you will have to repeat the last software install or update that you made. See MS KB283069 - "Error Message: Windows Could Not Upgrade the File %1 from %2 %1: %2 (http://support.microsoft.com?kbid=283069).

If you can't find a wininit.ini file then I suspect your problem is due to the C:\_RESTORE\TEMP folder having around 64K files in it which is the limit (2**16) for the number of files that can be located in a folder using the FAT32 filing system.

This then results in the "Cannot upgrade file %1 from %2.." message when booting. I suggest you try deleting the _RESTORE folder with the loss of any system restore checkpoints you might have (not that I think they are now usable) and see if that solves the problem.

Delete the folder as follows:

a) Boot to DOS using a floppy. Do NOT choose "Minimal Boot" from the menu when booting from a floppy but rather choose "Start computer with (or without) CD-ROM support" otherwise the ATTRIB command will not be available.

b) At the DOS A:\> prompt, type:

ATTRIB -H -S -R C:\_RESTORE (press enter)

and then

REN C:\_RESTORE OLDREST

c) Remove the floppy

d) Reboot your PC

e) Delete the folder C:\OLDREST

f) Check that an automatic system restore checkpoint was created.

g) Finally adjust the space allocated to the restore folder: System | Performance | File System | Hard Disk and adjust the restore slider to your preferred setting. A figure of 200MB is normally more than adequate for day to day use allowing perhaps a week of checkpoints to be available although increasing this to perhaps 400MB for a few days during periods of
large installs such Microsoft Office is advisable.

Unquote.

Good luck,

Zee

Collapse -
Problem solved!
by peggylenox / July 17, 2006 9:05 AM PDT

After a very annoying, frustrating call to DELL where I was told they no longer support ME, not even paid support and that I should call a local technician. GRRR So, I did. And he was able to get me back in working order. Most important thing I learned that if you are using a wirelss keyboard, you can't enter safe mode or setup because the keyboard doesn't load under after Windows does. So, we attached a wired keyboard and discovered that the upgrade had hung up while downloading. After a few tweaks, it's working./ YAAY! But what about Dell? Don't you think they have a responsibility to offer support on one of their computers if you're still using it? I was willing to pay, but they still won't do it. As much as I love my Dell computers, it does make one think about future purchases. peggy

Collapse -
Not a dell exclusive issue.
by R. Proffitt Forum moderator / July 17, 2006 9:35 AM PDT
In reply to: Problem solved!

You would encounter this on any maker. At some point they must wind down and exit support for an old system or OS.

What's interesting here is your error is easy to find with google.com As to the keyboard, after this many years Microsoft and others expect you to learn about the OS and issues such as that.

I would not disparage them so quickly in this case.

Bob

Collapse -
Not a Dell exclusive issue
by peggylenox / July 18, 2006 12:50 AM PDT

That's a pretty snippy response! I've been messing with computers for years and consider myself petty knowledgeable. But, I never read anywhere about the wireless keyboard issue. Now that I know, I can take care of this should it happen again. I did do a Google search, but this, of course, wasn't mentioned. I think the most frustrating part of the Dell experience was that they took considerable time to sign me up for the service contract, after I had told them it was ME, and then sent me to a technician who knew that ME was no longer covered. They should communicate better!

Collapse -
Any USB device may vanish in Safe Mode.
by R. Proffitt Forum moderator / July 18, 2006 10:10 AM PDT

If you took that as snippy, so be it. But the reality remains that many are not happy with how companies are exiting from the older OSes.

You seem to be one of those and my point is that you would write the same story with most other makers.

Why is that snippy?

Bob

Collapse -
I sure
by Blue_Zee / July 17, 2006 4:57 PM PDT
In reply to: Problem solved!

believe that local technician is worth every cent you paid him.

Cheers,

Zee

Collapse -
I sure
by peggylenox / July 18, 2006 4:15 AM PDT
In reply to: I sure

He sure was! For $65 bucks, it was great. And now I know who to call if I need to. peggy

Collapse -
My post
by Blue_Zee / July 18, 2006 4:20 AM PDT
In reply to: I sure

is worth $60.00 (at least!)

Zee

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?