Windows Legacy OS forum

General discussion

windows cannot find c:\windows\system32\restore\rstrui.exe

by inmyheart / February 21, 2008 7:21 PM PST

I have Fujitsu Siemens Laptop and when I tried to open the system restore the following msg pop up windows cannot find c:\windows\system32\restore\rstrui.exe i thought the system restore is not active but it was already activated

I have tried many ways to solve the problem but none worked which are:

- Reinstall the Sr.inf in the safe mood
-Delete the rstrui.exe in safe mood and reactivate it by reinstall the sr.inf
-expand c:\i386\rstrui.ex_ c:\windows\system32\restore\rstrui.exe

and I use antivirus to find if there is any virus but it found none

so is there any way to solve this problem?

Best Regards

Discussion is locked
You are posting a reply to: windows cannot find c:\windows\system32\restore\rstrui.exe
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: windows cannot find c:\windows\system32\restore\rstrui.exe
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Check the paths.
by R. Proffitt Forum moderator / February 21, 2008 9:36 PM PST

Open a command window and see if someone alters the windows path to not include a path to that .exe.

Also, you didn't tell if the rstrui.exe existed. I see you "tried" things but didn't share much besides it didn't fix the issue. For example the output of the expand command could have been Can't find C:\i386\... Which would have me ask what's in your \i386 directory, etc.


Collapse -
windows cannot find c:\windows\system32\restore\rstrui.exe
by inmyheart / February 22, 2008 5:02 AM PST
In reply to: Check the paths.

( Open a command window and see if someone alters the windows path to not include a path to that .exe) i didn't understand how to go for command window or how does it work.

Well, the rstrui.exe is exist and when i double click it, it gives me the same msg which is windows cannot find c:\windows\system32\restore\rstrui.exe. for the C:\i386\.... there are no errors and didn't give me this error.

Collapse -
by R. Proffitt Forum moderator / February 22, 2008 5:14 AM PST

Open the cmd or command window. Type

CD c:\windows\system32\restore

press return
Now type


Now press return. What happens?

Collapse -
by inmyheart / February 22, 2008 6:33 AM PST
In reply to: So...

I tried what you typed and it gives me the same message which is

the system cannot find the file c:\windwos\system32\restore\rstrui.exe

and i go to the restore folder and rstrui.exe is still there but not working

Collapse -
Check the paths. (HOW!!!)
by R. Proffitt Forum moderator / February 22, 2008 9:03 AM PST
Collapse -
by inmyheart / February 22, 2008 8:33 PM PST

the path is normal and nothing wrong in it as i think

this what i found in the path box

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\system32\WBEM;C:\Program Files\QuickTime\QTSystem\

Collapse -
Now check the results of PATH
by R. Proffitt Forum moderator / February 22, 2008 10:47 PM PST
In reply to: well...

Open the command prompt and type PATH press enter and if you see those % signs I know the cure. I haven't found the cause yet.

Sorry if this seems drawn out but you are in an area some DOS skill is needed as well as you moving forward on your own. As you might have either we'll take it one step at a time.


Collapse -
by R. Proffitt Forum moderator / February 22, 2008 10:49 PM PST

Sometimes we go through a problem like this and at the end the member reveals that a "Bebel" virus had been on the machine. If only they had told that at the beginning, somethings we can just skip to the cure.

Collapse -
by inmyheart / February 23, 2008 6:02 AM PST

i typed PATH in the CMD window and the % didn't apear in it.

so how can we solve this problem?

Collapse -
2 more.
by R. Proffitt Forum moderator / February 23, 2008 6:56 AM PST
Collapse -
by inmyheart / February 23, 2008 4:58 PM PST
In reply to: 2 more.

the system restore is running but as i wrote before the same message still popup

the system was hited with a virus it was AUTORUN virus and i found it manualy and deleted it also manualy, this virus didn't allowed me to open the C & D drive with double click so when i deleted it the drivers worked normaly.

so is this virus still has the effect on my system restore?

Collapse -
Wish you revealed that in your first post.
by R. Proffitt Forum moderator / February 23, 2008 9:02 PM PST
In reply to: well....

Virus or worm removal does not remove the damage. Move forward to the repair install.


Collapse -
by inmyheart / February 23, 2008 9:07 PM PST

I did repair install but the same problem remains Happy

I think we are going for formate the laptop!

Best Regards

Collapse -
Last hurrahs.
by R. Proffitt Forum moderator / February 23, 2008 9:35 PM PST
In reply to: but

Try an old trick of mine. Install the drivers you would as if the machine was loaded with a retail version of Windows. That is,in order of motherboard chipset drivers, video, audio, etc.

Sadly we burned up all this time with me not knowing about the virus so I never used that nugget to look into what this worm does. Consider sharing such when you start such a discussion or those that help will try the usuals and not know to look into something specific.


Collapse -
This worked for me
by longer1181 / December 21, 2011 11:37 AM PST
In reply to: Last hurrahs.

I know this is an old post, but I had the same exact symptoms and found a solution and thought it might help someone. It was definitely a nasty virus . . . I found a way around it by going to C:\Windows\System32\, right-click the rstui.exe file and select "Run as Administrator". This seemed to bypass the virus's control and I was able to restore the system to a date before the virus existed.

Collapse -
Bless ya, longer1181
by rmg515 / January 2, 2012 5:00 AM PST
In reply to: This worked for me

longer1181 -- Thanks so much for adding to this "old" post. I was wrestling with the exact same problem, worked a treat, my blood pressure is slowly coming back down again. Cheers.

Collapse -
This worked for me too - a year later!
by newdaysun / December 17, 2012 11:31 AM PST
In reply to: This worked for me

Don't know what I would have done had I not found this thread. The right-click on the rstui.exe file and run as admin DID bypass whatever nasty thing had gotton ahold of my computer. Thank you so much!

Collapse -
got the rcmp cyber crime ******** virus
by jesses6669 / April 30, 2013 3:13 PM PDT

I restarted comp is safe mode got into the restore and it worked so I thought the next day went on and nothing would open even all the programs along bottom bar were no longer there tried the restore process again and had all problem listed above! Started my comp in normal mode got into control panel but ever thing I tried to go into would not open! After trying to open multiple things boom outs nowhere everything started working again! I'm confused! How do I make sure all problems/viruses are gone with out having to spend money as I can not afford to purcess any!

Collapse -
further details
by jesses6669 / April 30, 2013 4:45 PM PDT

Ran a full system scan using avast! It found one infected file (trj) could not repair so moved it to chest! Then continued to boot time scan! During this scan found same infection could not repair so deleted it! But found file c:local settings/temp/3397051458440390.tmpl dialogs/generaldialogstyle.CSS error 42125 (zip archive is corrupted) and. Temp/33933970551458189500.temple dialogs/newsearchprotectordialog/images/ok-button.PNG error 4125 (zip archive is corrupted.) And. Temp/GLB57.tmpl wise0003.bin error 42145 (installer archive is corrupted. ) how do I remove/fix?

Collapse -
I'd ask this in the AVAST forum.
by R. Proffitt Forum moderator / April 30, 2013 11:08 PM PDT
In reply to: further details

If folk don't find a way to clean it up, there's always the old fashioned, gets it clean every time answer which is "reload the OS" and restore your stuff from backup.
Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.