Thank you for being a valued part of the CNET community. As of December 1, 2020, the forums are in read-only format. In early 2021, CNET Forums will no longer be available. We are grateful for the participation and advice you have provided to one another over the years.

Thanks,

CNET Support

General discussion

Windows can't open Add Printer error 0x000000c1

Dec 1, 2010 5:41AM PST

I have Windows7 Ultimate 64 bit and recive the above error. I've tried Microsoft chat live and also received a hotfix for KB 981070 which describes similar errors but did not fix the problem. Some say it is a bad printer driver. I've deleted all printers, including those that were working perfectly. NOw I cannot add a printer thru the usual control panel means Or connect to a printer over rthe network

Discussion is locked

- Collapse -
The good news is that this has open discussions.
Dec 1, 2010 5:57AM PST
- Collapse -
tried that
Dec 1, 2010 11:12PM PST

I have been to the forum and the forum it refers me to, that which details how to clean out old print drivers. The instructions reference Win 2000 and XP. I'm on Win 7 64 bit, which seem to be the issue... any ideas for that?

I have twice bee led by goole to http://support.microsoft.com/kb/981070 which accurately describes what has been happening to me. My two attempts using this hotfix have not remedied the problem.

- Collapse -
Generic.
Dec 2, 2010 2:31AM PST

Sadly I don't have enough specifics to work this issue. For example HP has some tools and procedures to clean out their drivers when this happens.

Of course if that can't be done we re-image the system and carry on.
Bob

- Collapse -
corrupt ntprint.dll in system32
Jul 26, 2013 6:03AM PDT

I had the same problem and tried all the suggestions without success. I then tried to run printui from DOS window as admin (printui /il) and got a message that windows\system32\ntprint.dll was corrupt. I had to change owner so I could rename to printuiold.dll and I copied the file from another Windows 7 64 bit pro machine. SOLVED