More and more require 8.1 so while I've yet to see an 8 to 8.1 failure, I read about them. On yours there is no detail about the PC so for now, just turn off WU.