Windows 10 forum

Tip

Windows 10 Read-Only Problem Has A Solution

by YPCheng / August 17, 2015 8:03 AM PDT
http://answers.microsoft.com/en-us/windows/forum/windows_10-files/document-folders-marked-read-only-after-upgrade-to/4f00d3fe-82b0-4e6d-a92a-f81751aa6f51?auth=1

I spent countless hours in dealing with this problem after updating to Windows 10 and also spent countless hours is reading CNET forum for a solution. The problem is actually very simple to fix once we understand it. I'm just glad it is over for me for now and I hope this posting saves a lot of time for many unfortunate victims of Windows 10 upgrade. (Whenever I run into the permission denied due to "Read-Only", I just go to the file/folder Properties/Security tap to give myself "full control" and "modify" permission. Works every time.)
Discussion is locked
You are posting a reply to: Windows 10 Read-Only Problem Has A Solution
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows 10 Read-Only Problem Has A Solution
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
After beboot, it resets back to Read-Only
by YPCheng / August 19, 2015 11:52 AM PDT

I've seen the discussions of a problem of files being reset back to Read-Only after reboot. I finally experienced this problem personally. What I did was once again applying the Properties/Security fix by giving the owner "full control" and "modify" permission. It took care of the problem. But, I am unsure why Windows 10 behaves this way!

Collapse -
even if the folder says "read only"
by James Denison / August 19, 2015 12:08 PM PDT

If you already set it to "not read only" once and left that setting, even though it lies about it, the files inside will NOT be "read only" anymore. There's also 3 settings on that box, one is black square, one is empty box, one is a checkmark (for setting "read only"). Any of the Advanced Settings seem related to the black box, so I'm thinking the blank and the check are the NOT read only and the Read Only. It's probably something simple like using the wrong icon. I had a linux distro that would show the internet disconnected both when it was and when it wasn't. Of course I fixed it so the correct icon would be accessed later, but I suspect something similar may be happening with the indicator for "read only, and NOT "RO" on folders in win10.

Collapse -
This saved my sanity. RO issue SORTED. Thank you
by AngelPoohbear / April 14, 2016 8:32 AM PDT

You are a star! I had done everything. I had changed Admin accounts on a brand new pc even though I am the only one on it (if you don't count the all-powerful MS), changed permissions, made so many security changes I'd lost track and was desperately trying to resist being forced down the path of regedits.
"Even though it lies about it, the files inside will NOT be "read only" anymore" ........... the line that saved my sanity!
I opened my itunes which was trapped on an external HD and was on 'read-only' so that I couldn't make any changes or corrections to artists, listings etc and changed an artist as an experiment. FIRST TIME. NO PROBLEMS. NO RO ISSUES. SORTED!!
All this time I'd been believing what I could see - the RO box still checked when really it wasn't!! And the motto is 'Don't believe all that you see...'
You are a lifesaver. Many many thanks.

Collapse -
nice trick MS played isn't it?
by James Denison / April 14, 2016 9:16 AM PDT

Glad it helped. There's so many irritants like that, I never put it on my wife's computer, and I personally prefer and use Linux Mint.

Collapse -
Beware the Windows 10 Anniversary Update, build 1607
by nigelroot / September 23, 2016 10:13 AM PDT

I installed this update this morning and am now fighting to rotate photos. The best I can get with explicitly giving my user Full Control and Modify permissions (Full Control gives all the others), and setting my drive, folder, subfolder, subfolder below that for Full Control and read-write.
I CAN NOW ROTATE ONE PHOTO AT A TIME, IF I'M LUCKY - then I have to reset all the settings again. IT'S AN AWFUL STEP BACK.
Nigel

Collapse -
The cause is not easy to absorb.
by R. Proffitt Forum moderator / August 19, 2015 12:11 PM PDT

It's not only the permissions but the ACL and the new email login system clashing with an old local login.

The HOMEGROUP solution with the above seems to nail it here but folk have written they think it's broke. Without a long course in Windows, understanding of this will be elusive. Some folk flame on about this area so let them flame. Read the top post as well as the HOMEGROUP solution.

Here I can't use the email login. My choice and it neatly avoids this entirely.

Collapse -
Takeownship.zip and ACL
by YPCheng / August 19, 2015 6:05 PM PDT

Not being a programmer, I played the ACL, Access Control List, by clicking the "advanced" button in the file "Properties/Security". Surely enough, after running "takeownership" -- do google on takeownership.zip -- my name is displayed as the owner of the file/folder that I have "full control". A correction to my previous posting of "After Reboot, it goes back to Read-Only". That statement is untrue because I purposely rebooted a few times and file permission was not reset. So, I don't know what action of mine has caused the reset. However, one thing I am certain, when I have the ownership of the file/folder as shown in the ACL, the file stays writable to me. So, maybe the best solution is to run the takeownership thru all our files to fix this problem once for all. By the way, the Read-Only attribute in file Properties always has a black square. I simply can't get rid of it. So, it carries no information as far as I am concerned.

Collapse -
Then be sure that all owners are listed.
by R. Proffitt Forum moderator / August 19, 2015 6:12 PM PDT

Remember that if you are using the email login, you want to try the homegroup method as well.

As to ownership, ACL and such I have not found an autofixer for that.

Collapse -
Changing permissions works!
by MKorkowski / October 31, 2015 5:33 PM PDT

YP nice post. I ended up going in to the "hidden administrator account" and giving the users permissions. My machine is NOT on a corporate network. It simply is my home PC. Having to do this is and was a LOT of extra time. This problem READ ONLY thing was not an issue with previous upgrades. One thing as well. All the folders on the PC were set to "READ ONLY" AFTER the upgrade. This was not the case before the upgrade and even after changing permissions and changing a few files in a folder I still get the "READ ONLY" box active that says "only applies to files in folder". Other "experts" have said this is to protect during the upgrade. O.K. fine but they (Microsoft) let us all find this. Why couldn't they write a script or at least post an official response to help us? Truthfully, under normal circumstances we shouldn't be changing permissions on a whim. But if your system worked perfectly before the upgrade and then doesn't after, well we are all trying to make it work. I feel we should be informed by the "maker" which is Microsoft. it is only fair that way. Clearly doing this (changing permissions) works and my system is working fine now.

Collapse -
Windows 10 Read-Only Problem
by Skunkyman / January 6, 2016 1:12 AM PST

Hi,
I rencently met this problem on my computer. After hours of research, i didnt found any solution.. Even in superadmin mode, commandline...
But finally i arrived to find where does this problem come from:
=> Hard disk failure
And so the best solution might be to change it..!

Collapse -
got the same copy
by drues1986 / January 6, 2016 1:38 AM PST

got the same copy file to desktop change name, delete original and put copy back that is what i have been doing.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GIVEAWAY

Turn up the volume with our Apple Byte sweeps!

Two lucky winners will take home the coveted smart speaker that lets Siri help you around your connected house. This sweepstake ends Feb. 25, 2018.