Windows 10 forum

Question

Windows-10 changed all my documents to "Read-Only"

I have a PC, and have been using Windows-7 until today, when I started using the free Windows-10 instead.
One huge problem is that Windows-10 changed all my documents to "Read-Only."
(Regarding my documents, I use "Microsoft Office Word 2007," which has been working great, and I use it daily!) What can I do to fix this situation?

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Windows-10 changed all my documents to "Read-Only"
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows-10 changed all my documents to "Read-Only"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Did you make a backup before going to 10?

In reply to: Windows-10 changed all my documents to "Read-Only"

If so, restore from the backup. If not, now you know why you should.

Collapse -
Back ups Not Needed and Won't Help Here

In reply to: Did you make a backup before going to 10?

No good because it's a safety feature in Windows 10.
Though a backup helps for corrupt files even dropping a backed up file in the folder will convert it to Read Only. The folder itself is the issue because it sets all it's files to Read Only.
The files are not corrupt or broken. You can still Save As to Desktop.
You just have to change the attribute for the Document folder located in C:\users\user.
Deselect Read Only and apply to all files and subfolders.
It's more an annoyance then an effect safety feature.

Collapse -
Fixing "read-only" helped my docs issue!

In reply to: Back ups Not Needed and Won't Help Here

I had a slightly different (I think) problem, but looking for that pesky "read-only" box under properties and unchecking helped me (again, I think). I migrated to Win 10 and also networked my partner's laptop and an older desktop (all switched to Win 10). But lately, I found that all the "documents" on my laptop were only findable on my laptop if I went to Homegroup and clicked on "Me" under "Mycomputer" (names changed), clicked on "Public" and then saw all my old docs (which were on the machine when I went from Win 7 to 10). WTH? But finding the "library" or whatever they call that and right-clicking to get to properties and unclicking "read-only" and it seems like all my docs are available from my Documents shortcut, and I don't have to go into an explorer page and a couple more clicks to get to my documents under Public under Me under Mycomputer under Homegroup.

Why all the docs and pictures under all the computers are not sharable when I've checked full sharing and admin privileges for all users on all machines is a topic for another day. I can get through most problems when they occur on a single machine, but networking/workgroup/homegroup issues make me want to drive to Redmond and set up a picket line.

Collapse -
Before giving patrionizing Answers, read the question.

In reply to: Did you make a backup before going to 10?

Your answer, aside from being patronizing is useless as it fails to address the problem.

Did you fail to really read the message or don't you understand what you are talking about or both?

Collapse -
RU Serious?

In reply to: Did you make a backup before going to 10?

Why is that necessary? One can revert to Win 7, 8.1 from within Win 10 and reinstate again provided its done by end of Aug 2015. Haven`t you noticed the windows.old folder yet?

Collapse -
HELP HELP HELP please.

In reply to: Did you make a backup before going to 10?

i upgraded to this nightmare also. My problem is that I have three flash drives I used for business, some are contracts that i would go into and change wording and resave as something else, sorta using as a template. However, now when I save things to the flash- if I go to open the flash on another computer that does not have W10- it will not open the files AND anything I created on Windows 10 i can not open on any other computer without windows (the file name has .docx) I tried to find the Windows.old file and could not I can not locate it., I do not have any of the Word, Excel etc disc or any other disc for that matter, I did a system back up but apparently it did not save correctly and then i did a back up on windows 10 (just in case) but nothing I have done will open these files. I tried saving as a PDF. I tried changing the properties (it is not read only or archived, it is not blocked, it is not encrypted and I unchecked and rechecked all the other options under advanced attributes). How can I make all these files open on computers without Windows or how do i fix this major life threatening issue. (My job depends on it) Thank you so much

Collapse -
For .DOCX files, you can use LibreOffice

In reply to: HELP HELP HELP please.

LibreOffice is a free download. It will open .DOCX files which are created by MS Office 2007 and later. There are numerous suggestions for other read only files in this thread above. You can download LibreOffice from here:
https://www.libreoffice.org/download/libreoffice-fresh/
I also found one here in the MS Windows 10 forums that seems to've worked for several people here:
http://answers.microsoft.com/en-us/windows/forum/windows_10-files/document-folders-marked-read-only-after-upgrade-to/4f00d3fe-82b0-4e6d-a92a-f81751aa6f51?auth=1
`
Good luck.

Collapse -
Try this...

In reply to: HELP HELP HELP please.

The solution is an easy one. Say you can't add photos to the photos folder because you don't have permission. simply right click on the photo's folder and select "properties", then select "security"...

Find your username in the list of :"group or user names"... and select it. Then click "edit" to change permissions and make sure all check boxes are checked. In particular "full control" and "read" and "write". Even if you are an administrator on your computer and Administrator permissions has all checkboxes checked.... you need to make sure your individual username ALSO has permission boxes checked in the security tab. Be sure to hit "apply" after you check all the boxes and then go back in and make sure all the boxes are checked.

That should fix the problem.

Collapse -
That fixed it for me!

In reply to: Try this...

Thank you.

Collapse -
Were you drunk?

In reply to: Did you make a backup before going to 10?

I had never read, before, such a stupid reply to a legitimate question!

Collapse -
Clarification Request
Any other solutions?

In reply to: Windows-10 changed all my documents to "Read-Only"

Does anyone have any other answers to this problem short of reverting back to Win7? None of the above solutions are working for me, and it's affecting not only Office 2007, but quite a few video games as well that use the Documents folder for save states or user accounts.

Collapse -
reverting doesnt help

In reply to: Any other solutions?

reports from other users that reverting back to previous versions doesnt work unless you are restoring from a systems disk backup

Collapse -
Clarification Request
It gets worse folks....

In reply to: Windows-10 changed all my documents to "Read-Only"

My problem has gone beyond Read only on folders, I have three drives which I was quite able to move folders about in until a day or two ago (I've been running since the release date) and now everything is read only.... I have 3 terabytes of data, 5 partitions and no way of filling anything, at this rate my drives are going to be a mess. Does anyone know of a registry edit that would disable read only permanently????

I'm clued up on this crap and all the functions that would work for this issue in XP, 7 and 8 do not work on 10: period. As the poor OP has re-iterated countless times - please don't state the obvious as that will just make you as useless as Win10 currently is! I've tried altering and adding my own user with full permission to all my drives, after clearing them first, but no joy, I am administrator and even in safe mode it still doesn't work. I've tried the removing the read only tick once this has been done and still no joy. When you check back all the setttings have returned to their old states and if one or two do change they still behave the same. Meanwhile, cmd line tells me that my folders do not exist - seriously Mircrosoft? Gotta say, this has to be one of the most patronising issues within any iteration of Windows - it's like its just patting you on the head every time that bleeding apply bar pops up, meanwhile it sits there in the background picking its nose and having hissy fits over context menus crahing explorer.

I think I've finally hit the wall with Microsoft, this is a deal breaker and their ignoring tweets about it as well - in fact I just looked for mine and it looks like they've removed it! I'm seriously considering partitioning my C drive and dual booting with a Linux OS - 8 was bad enough this is just sheer incompetence. Any recommendations Distros?

On a completely different note did you know windows 10 will check you PC for any cracked software and if you upgrade your hardware it could prevent it from being used without paying full whack for a new windows key? Microsoft would be evil if there weren't so incompetent!

Collapse -
I see a lot about this in this thread.

In reply to: It gets worse folks....

Here it's working great and no one at the office has run into this issue of read only.

However.
1. Most of us are programmers.
2. No one used Microsoft's email login system.
3. We know about junctions vs folders.

This appears to be your first post so maybe you are ranting a little. That's OK.

I think the technicals are beyond most folk. Maybe this will be a boon for Apple but here it's all good.

Collapse -
Oh Dear!

In reply to: I see a lot about this in this thread.

To quote John McEnroe: You can`t be serious! From the respondent condescending posts I`ve seen on here, you all sound more like Administrators rather than programmers' And, I might add, not very good ones at that. I haven`t seen one clear and concise instruction from any of you.

Collapse -
I agree. A lot of folk are admins, compsci majors

In reply to: Oh Dear!

This one is really wiping every day folk. I did write who the folk are at the office are. Programmers and more.

I do see some great advice here but "clear and concise" would be spot on for every day users. No one expects every day folk to understand or follow the instructions so far.

Again, your reply is why I think I need to rethink my Apple and Microsoft stock positions.

Collapse -
Oh dear!

In reply to: I agree. A lot of folk are admins, compsci majors

Well thank you for considering us 'every day folk'. I get read only words documents...it reset my computer to 2 reformat ago and now asked for an administrators password. Lucky I found one. If I want to save tells me I need administrators code? My Toshiba screen, XL and word doc are distorted. Google eart is a Rugby ball?! only have 2 choices..1024 or 800? if I double click to open a file it freezes. It is only starting now...and seems to be getting worse. very sad..I should have stayed with W7 till I could afford a new PC.
The fact that Microsoft disregards our working day and decides to upgrade in the middle of a phone call...is commercial dictatorship.

Collapse -
Now let's pivot to the fixes found so far.

In reply to: Oh dear!

1. Change to a local login. https://www.google.com/#q=windows+10+change+to+local+account

2. Use the HOMEGROUP as noted in discussion.

3. Take ownership of the files as noted in discussion.

Remember these are a little too much for everyday or new users but the issue did occur on 8 but 10 seems to catch a few more unaware.

Collapse -
BINGO!!!

In reply to: I see a lot about this in this thread.

I was running FINE on Windows 10 until I signed in to my Microsoft Account. Is there a way to undo that?!?!

Collapse -
The Homegroup is one workaround.

In reply to: BINGO!!!

The other is to copy it to a folder in your new account.

For me, I can't use the Microsoft email sign in system. TL;DR why.

Collapse -
(NT) Yes, if you've activated System Restore or have sys. backup.

In reply to: BINGO!!!

Collapse -
Dude pull your head out; your superiority complex is showing

In reply to: I see a lot about this in this thread.

@ R. Proffitt
I don't use Microsoft's email login because I am not a moron. I have also switched every privacy option to off as I don't trust Microsoft with anything let alone my keystrokes - look at Google! (I have security before anyone lectures me and yes I disabled the usual unnecessary background services). Still not quite sure what the email login has to do with this issue though? Considering the read only/file ownership issue has been around since XP (and probably as far back as NT), decades prior to Microsoft going on its current data collection orgy.  So if your implying it has something to do with authentication with the Microsoft servers, I cannot see your logic considering the issue pre-exists that being part of the OS and when a lot of peeps were still not online or had dial up.  Nor have I seen any mention of this in any of the 30+ articles I read in trying various different fixes.  Secondly, I object to being spoken to like a noob, I build PC's and have fixed gods know how many machines from those at various places of work, to friends, to friends of friends and the odd charity, as well as doing builds for other people. I am not a bloody noob!

In response to ranting - that's expected in these sorts of threads so either don't read them or try not to patronize, if you find the later impossible, then don't say anything as it will not be appreciated.  Also, I love how you completely ignore my question on distros - I thought you developer types loved linux but apparently you love belittling people more so well done on the later point - objective complete!  Also, as much as it's really fantastic that you know about junctions, that comment is as about as helpful as a chocolate teapot - so unless you want to link to a nice easy to digest article for non-developers, then I would stop **** swinging about your IT prowess. We get it, you know your windows, however at no point have you uttered anything considered remotely useful for the average user so here have my wrath.

To my fellow windows 10 sufferers:

I have, reinstalled win10 and once I had installed anti-virus and anti-malware, I immediately disabled UAC via a registry edit that also disables the metro apps - what an unexpected bonus! It also nerfs some of their tracking, apparently, but that could change with the constant updates.   NO PROBLEMS SINCE DOING THIS THOUGH, HURRAH!! Happy

To FIX: Google the registry edit if you like guys (a link follows) cos it stops this happening, I've been running fine from not long after my last post, as that's when I bit the bullet and started over.  There's load of great articles online no matter what your PC proficiency level for tweaking other windows 10 bits and bobs (and general annoyances) but yes it is a bit of a ball-ache if it's not something you are familiar with. I've linked one here for a starting point, the UAC hack instructions follow first (there's some pic's on the website if you are unfamiliar with the registry, which will help):

"To disable UAC via the registry, you’ll need to head to the start menu search box and type in regedit.exe and browse down to the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Over on the right-hand side, you should see a setting for EnableLUA, which you’ll want to customize as follows:

UAC Enabled: 1
UAC Disabled: 0"


link to page:
http://www.howtogeek.com/howto/4820/how-to-really-completely-disable-uac-on-windows-7/

And yes it works for windows 10 not just 7 - most of the registry hacks do from what I've found.  Just don't fiddle randomly with the registry though, if you are unfamiliar make sure you follow trusted instructions as it could result in you needing to reinstall a now bricked OS.  If you back up the registry before editing that's always a good fail safe, as it can always be restored in normal or safe mode, another link for that too:

http://www.howtogeek.com/197785/how-to-backup-and-restore-the-windows-registry/

This can be done with an individual registry string (or section) rather than the entire hive, if you're only editing one thing like the UAC string.

The How to geek site is pretty good for uncomplicated instructions, I definitely recommend it.

Good luck!

Collapse -
Thanks for sharing this.

In reply to: Dude pull your head out; your superiority complex is showing

There are a lot of folk that are very upset about W10 and your anger is showing.

Thanks for sharing but chill man.

Collapse -
Re: disable UAC

In reply to: Dude pull your head out; your superiority complex is showing

What's the use of disabling UAC? I don't really mind Windows asking me if I'm sure to want to copy something to Program Files folder. It's not something I do often, so I like the extra precaution.
And what's the use of disabling 'modern' apps if you use Classic Shell and don't see them at all unless you really want to. Nothing wrong with the Weather app in the list of 20 most used programs, is there?

Collapse -
does this work?

In reply to: Dude pull your head out; your superiority complex is showing

does the UAC edit work for this issue?

Collapse -
Have you tried this?

In reply to: It gets worse folks....

Had the same problem UNTIL tonight. Here`s what I did: Please bear in mind I`m a Home User so have only a local network.
1. Right click your Doc Folder
2. From the scroll down list select Properties.
3 You should then see the Documents Properties dialog box open.
4. Select the Sharing tab which should present you with the path to your doc folder. Mine reads something like Network Path :\XXXXX\Users\xxxxx\Documents.
5 Click on the Share button and then Apply.

Worked OK for me as I hope it will for you.

Collapse -
Windows-10 changed all my documents to "Read-Only"

In reply to: Have you tried this?

I too am a home owner who has had no problems saving files/documents until I updated to Windows 10 ...I could not save any file unless I saved it to the desktop. I have been using a computer since 1984 and have never ran across this problem. As Stunun wrote, right click on documents; left click on property; left click on the "Sharing" Tab; left click on Share, open up the file sharing dialoge box, left click on everyone, left click on add and finally left click on the share bottom at the bottom of the page. I agree with Stunun "Your answer, aside from being patronizing is useless as it fails to address the problem."

Collapse -
This Read-Only Problem Has Been Solved on My Computer

In reply to: Windows-10 changed all my documents to "Read-Only"

It looks like Windows 10 changed C:/users/my-name folder to Read-Only -- do check the folder properties. Unfortunately for me, all my working files are in this folder. I un-checked the read-check in "Properties" and it ran over 10 minutes as I got 80,000 files and it came back saying something like you are not the Admin. So I tried real hard to become an Admin, which will be another story, repeated this thing. It ran another 10 minutes without complaining. Then, I displayed the folder property, it was still in Read-Only. Talked to a guy at Microsoft who downloaded a "takeownership.zip" from somewhere and ran an .exe file to change the folder ownership back to "my-name". (I suspect the file owner was changed to "system" by Windows 10. This .exe file changes the Windows Registry.) Now, I went back to un-check the Read-Only in Properties again. It ran another 10 minutes over my 80,000 files, WALLA, the problem was fixed.

Collapse -
Read only and something else

In reply to: This Read-Only Problem Has Been Solved on My Computer

Sure didn't do a thing for broke windows 10. The hunt continues.

Collapse -
This worked for me

In reply to: Have you tried this?

Thank you thank you

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GIVEAWAY

Enter to win* a free holiday tech gift!

CNET's giving five lucky winners the gift of their choice valued up to $250!