Windows 10 forum

General discussion

WIN 10 Homegroup issues

by Papa_Paul2 / August 2, 2015 5:32 PM PDT

I just updated 2 desktops and 2 laptops in my home to windows 10. 1 desktop was Win & and 1 was Win 8 and the same for the 2 laptops. Everything looked good until I tried to use my home network (Workgroup & Homegroup). Now the 2 formerly Win 7 units can see each other but not the formerly Win 8 units and vice versa. When I try to use Homegroup it says there is an existing Homegroup and invites all 4 units to join. But after awhile I get a message that says the Homegroup no longer exists and to start a new one. But none of the units has the ability to start a new one, only join the unknown old which doesn't exist on any of these units. It might have been on the WIN8 desktop prior to a harddrive failure and a clean re-install.

Anybody have any ideas how to totally delete an old Homegroup and start over. I really don't want to have to do clean re-installs on 4 PCs. I would hope somebody from Microsoft can help.

Between this issue and the fact that you can't synch favorites on EDGE, I can no longer recommend the Win 10 upgrade to anyone with more than 1 PC.

Post a reply
Discussion is locked
You are posting a reply to: WIN 10 Homegroup issues
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: WIN 10 Homegroup issues
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I've had this problem too. It started w/Insider Preview
by wpgwpg / August 2, 2015 5:43 PM PDT
Collapse -
no Microsoft support.
by lucazeta / January 23, 2016 7:55 AM PST

Microsoft support staff gives always obvious answer like "Plug your ethernet cable in" or "Exit from a homegroup and start a new one".
They don't conceive your network is totally rotten.

Collapse -
WIN 10 Homegroup issues
by Papa_Paul2 / August 3, 2015 2:06 PM PDT

The issue for me is solved. Here are the steps I took, but I'm not sure they were necessary. I would try step 3 first and if that doesn't work, try 1 & 2 and then 3 again.

1) Deleted the idstore.sset file found in the \Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking folder of your system drive (for example, drive C). It was really idstore.sst.

2) Went to services.msc and enabled (automatic):

"peer network grouping"

"peer network identity manager"

"homegroup listener"

"homegroup provider"

3) Steps 1 & 2 didn't seem to be working so I shut down all 4 PCs and went to bed. In the morning I only turned on my newest formerly WIN 8 laptop. I knew that this PC never hosted the "Ghost" HOMEGROUP. I opened HOMEGROUP and it allowed me to set up a new one and gave me a new password. I turned on the other 3 PCs and HOMEGROUP connected with the new PW. So I think the issue may be is that if the PC that created the "ghost" HOMEGROUP is powered up WIN 10 sees the "GHOST" as active and tries to connect to it.

Now if I could just get EDGE to synch my favorites I'd be a believer again.

Collapse -
Good to hear you got it working.
by wpgwpg / August 3, 2015 2:27 PM PDT

However I don't use a homegroup. I've had networking working since the Windows 98 days, long before MS came up with homegroups, and have never seen why I'd need it. I've only got 10 installed on my test computers, so I'm not really hurting for printer sharing, but you can bet I'm not about to put 10 on any of my main computers until this gets fixed for me. Besides I haven't seen anything in 10 that I need or want. I'm perfectly happy with 7, and I do have 2 copies of 8.1 running on my test computers in multiple boot configurations along with 10. Maybe 11 months from now I'll see things differently, but right now I'm in no hurry at all, and don't know why I should be. For me Windows 7 "ain't broke" (and it's very stable), so I have no reason to try to "fix" it.

Collapse -
Papa_Paul2 is correct
by VivamexLimited / August 29, 2015 3:16 PM PDT

Was chasing myself round in a circle over this but Papa_Paul2 is correct - as long as even one PC from the original homegroup is online some kind of "ghost" of it remains and therein lies the problem.

Assuming network settings are otherwise OK it really is a matter of 3. in his solution...

a. Remove ALL machines from homegroup
b. Turn ALL machines off
c. Turn one machine on
d. Create a new homegroup on that machine
e. Turn on others one by one and join them to it

Thank you for the steer towards the solution. It is ridiculously annoying that this problem exists - agreed.

Collapse -
homegroup solved
by kaelong / December 11, 2015 7:28 AM PST
In reply to: Papa_Paul2 is correct

I of course had the same issue as eveyone else. But my issue with MS is that they don't have any instruction on this. But similar to Papa_Paul2 solution, here is what worked for me.

The key is for all the machines to be In the same "WORKGROUP". Once I got that done, I went back into joining the HomeGroup and it didn't even ask for the password. But what I saw was that I could then delete and create a new HomeGroup. I hopes this helps.

Collapse -
Maybe a dumb question but......
by ubermik / December 27, 2015 1:48 PM PST
In reply to: Papa_Paul2 is correct

Only having a moderate amount of detailed network knowledge this might slide under the wire and win the dumbest question of the year award but here goes (well its actually two questions really, so one should be in with a chance)

1. When I go to the link to allow/dissallow access to ALL devices on the network I can see the names of computers that were either just briefly on my network when setting them up for others, or ones that havent been on the network for literally years and years. Despite deleting everything in the roaming folder (rather than just the idstore,sst) theyre still there, even on the new PC that has never ever seen any of them on the network at all ever.

So where exactly is that all coming from and what needs to be deleted to clear it? Because its most definitely not just the idstore file as I have deleted that and the entire contents of the folder (but not subfolders with names like "afcjfdwe5453fetdfgdfgdgddfg" on all machines before shutting them down,

Yet somehow dozens of PCs are listed despite only 4 being present

HOW?

2. I did wonder how much information is propogated to "devices" rather than just computers, I have 4 gigabit hubs and a DVR (CCTV recorder based on some kind of thin linux client), Despite shutting them all down I was beginning to wonder if they could be storing some kind of list that the older machines past on before I cleared out the roaming folders and which is then sent back to the cleared machines when they first start their discovery?

Is that a possibility or just clutching at straws? If so then I really dont know how I can clear out the DVR (hikvision DS7200 series)

I might try the entire thing with a different hub on an isolated test network, but my gut makes me feel that the real problem is with windows and some other file that needs to be removed.

Also, my network has IPv6 protocol automatically installed, but no machines seem to be able to get any addresses from anywhere and dont even pick up DNS servers either, And as some ISPs arent even supporting IPV6 yet it seems a bit silly for anything to have to "depend" on an optional, or potentially unavailable item, hell why dont they also make you HAVE to be running a token ring network too just to set the bar even higher?


2.

Collapse -
Stored computer lists??
by ubermik / December 28, 2015 7:15 AM PST
In reply to: Papa_Paul2 is correct

What else "can" store a list of computers? Or where else in windows might they be stored?

When I go to the allow all devices to connect link I get PCs that I haven't had for many years showing up even though all machines had ALL of the contents in the idstore directory deleted

How about Linux based DVRs like the hikvision DS7200, gigabit hubs or a virgin router or an xbox? I did power everything down but I still have dozens and dozens of PCs listed on a network with 3 of them connected so its being propagated from somewhere or the idstore file isn't the only copy that windows stores

I have been trying to sort this out for almost 2 weeks now which is ridiculous and am pretty much ready to just go back to windows 7 and give up on 10 completely

Collapse -
Homegroup
by Rockit68 / January 13, 2016 2:40 PM PST
In reply to: Papa_Paul2 is correct

I have tried doing this 3 times on two different laptops. And each time i go to join the network it asks me to create one. Then I go back to the original laptop I created the homegroup on it asks me to login. At that point i type the password that the original homegroup laptop created and nothing. When I close all windows and go back into homegroup settings it asks for a password again. It shows that there is a home group to join but nothing happens when i type the password. I have tried this on both laptops.

Collapse -
Yes after all these years it works!
by MjrTom397 / December 11, 2016 10:50 AM PST
In reply to: Papa_Paul2 is correct

Thanks every 9 months or so Microsoft does an update that corrupted my home group. After many complex process changes this works. The key is:
1. To remove all devices from the home group 'unjoin' (probably one of many homegroup ghosts, you can not delete a homegroup, they just disappear after the unjoin).
2. Turn off all devices.
3. Turn on ONE device to set up the homegroup and password.
4. Turn on each device and join the new homegroup
5. Wait a few minutes or reboot the devices so that Microsoft can do it's thing.
6. If you want update privileges I had to right click the library and update the share the home group to edit.
7 Voila now every 9 months or so I can replace my homegroup. Happy

Collapse -
Thanks Papa_Paul2
by TinksMeOff / October 24, 2015 10:59 PM PDT

I have two laptops and desktops W7/W8 OS on one each and upgraded them all to W10. Ran into a issue of a W7 Laptop that started the Homegroup that was given to charity to Africa. Anyway, no PC after upgrading to W10 could see each other because this laptop doesn't exist on my home network any more. Banged my head, read google searches, banged my head some more. Well, your post got me methodical in my approach. This is what I did methodically on all four PC's after W10 upgrade.

On the keyboard, select Windows Key and quickly press R key (or just search and type) netplwiz and go to Advance tab - Manage Passwords - Windows Credentials icon - and remove all PC's (some of which were older OS named ones or I don't have anymore). This didn't hurt my network associations btw. After closing those windows when finished.

I then select Windows Key and quickly press R key (or just search and type) services.msc and STOP (by right clicking) on
"homegroup listener"
"homegroup provider"
"peer network identity manager"
"peer network grouping"
"peer name resolution protocol"

I then closed out services.msc.

I went to \Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking folder and deleted everything in this folder. If you can't see the path to this folder, you will need to go to Control Panel - File Folder Options - view tab - select Show hidden files, folders and drives - select Apply button and close everything and shut down each PC (don't reboot) and kept them shut down.

I booted back up my newest PC (a laptop) and then select Windows Key and quickly press R key (or just search and type) services.msc and Start (by right clicking) on
"homegroup listener"
"homegroup provider"
"peer network identity manager"
"peer network grouping"
"peer name resolution protocol"
and enabled (automatic) by right clicking - properties - arrow key change to automatic.

Let it sit for a few minutes - went to Homegroup and I was given a prompt button to create a Homegroup (rather than just to Join one). I created one and was given a key by W10 for the password. Documented it and rebooted my other 3 computers and performed the above services.msc start services with automatic settings enabled. After about ten minutes, I went to Homegroup and Join with the password provided Homegroup creating laptop PC. They all join just about immediately and synced within 5min.

Couple of side notes: My laptop that first created the Homegroup after the fixes created it just fine, but W10 reported that another Homegroup was created first to this laptop in the Homegroup page. I just ignored this message and booted up my other PC's and joined with the newly provided password. After the other three PC's were connected, I tested them as good, but the primary laptop would not expand the tree in my Homegroup. I rebooted the laptop after the other three were clearly connected (and seeing the primary laptop without issue). The primary laptop was fine after a reboot in the Homegroup seeing everything just fine with no reported conflicting Homegroup or error.

Second side note: I have my primary laptop and a desktop using the same W10 PW to login. Both these had a fresh install of W8 which required a MS Live (or Hotmail) login so the PW is the same while the PC usernames are different. When I joined the Homegroup with that desktop, it never prompted for the Homegroup password that was just issued by the laptop and knew it by my MS Live (or Hotmail) login password.

Collapse -
Do you want to be an official MS beta tester? Then use Win10
by ubermik / December 27, 2015 1:33 PM PST
In reply to: Thanks Papa_Paul2

I have been trying this for about a week with no success with two win32 and one win64 Win 10 machines and the two 32 bit installs can see each other but cant be browsed by nor browse the 64 bit one. Some "clever" idea to have seperate networks on the same wire that wasnt thought through perhaps?

Anyway, for the IDstore files rather than changing permissions its easier to just copy the past from a page like this then open the administrative dos box, type CD then a space then paste

This puts you in the right folder, you can then do a dir (return) to show files in the folder, and then del idstore.* or even just *.* and return then close the window

I found this quicker and saves having to alter settings and then change them back when finished


I am personally thinking about just flipping all of my machines back to windows 7, as working as an unpaid microsoft beta tester isnt my idea of fun at all. I wish they would actually FINISH their shovelware before releasing it

I do understand the sheer size and complexity of modern operating systems will make it impossible to have no problems, but this is BASIC networking, and its a problem that has been around since the pre release trial versions were available and STILL hasnt been fixed, this is akin to releasing a car for sale that works perfectly in every way except getting the wheels to rotate. So you can sit on your drive listening to the new posher radio, see the awesome windscreen wipers in action and enjoy the more comfy seat,

But you just cant actually drive it anywhere, and where the manufacturer just keeps on selling it anyway whilst claiming that the problem might be the tarmac on your drive (they seem to keep suggesting driver problems even though most peoples drivers are provided by windows itself,,,,,awesome technical support guys!!!!!)

Does anyone know if this problem also exists on clean installed machines? Or is it just a problem with updated ones from a previous incarnation?

Collapse -
I feel your pain
by Smerfblah / February 16, 2016 11:43 PM PST

After an hour of trying to get "homegroup" to work I ended up using a thumb drive to copy a file to my daughter's laptop. It used to be a simple matter of mapping a network drive, as far back as Win 3.1. Why they decided to invent something called "homegroup" and make it so opaque is beyond me.

Collapse -
Confirmation of clean install issues
by Xephan / February 25, 2016 11:11 AM PST

After having exactly the same issues you had with 2 newly upgraded Win 10 machines, one 64bit and one 32.
I didn't pay too much attention at the time, but I got a new hard dive for the 64 bit machine and did a clean Win 8.1 install followed immediately by a Win 10 upgrade.
The ghost homegroup still requested the 64bit PC to join while the 32bit had the create option. Neither could browse each other.
After the frustration sank in all the way to the bottom I decided to re-install and up grade both machines.
Miraculously! The issue persists.

Collapse -
Problems...Win 10 homegroup issues
by CubbyB1 / January 1, 2016 11:24 AM PST
In reply to: Thanks Papa_Paul2

I attempted to follow your directions on clearing/stopping the various services but it choked.
1. Peer Network Identity Manager - Get error message " Error 1061 - The service cannot accept control mesage a this time.
2. Peer Network Grouping - stopped
3. Peer Network Resolution Protocol - "Stopping" (all options are greyed out)

Quite and rebooted - same situation.

At this point I cannot start/stop anything.

Help!

Collapse -
Ghost Homegroup fix didn't work
by bill4645 / October 24, 2016 2:34 PM PDT
In reply to: Thanks Papa_Paul2

Followed your instructions to a T. Still have the ghost.

Collapse -
Ghosts can't hurt you.
by R. Proffitt Forum moderator / October 24, 2016 2:38 PM PDT

I've seen the ghost PC on Windows since about Windows For Workgroups 3.11. We learned decades ago to not worry about ghosts if the networking is working.

However some get OCD about it and they claim it shouldn't be like this. Agreed, but you tell it to Microsoft.

Collapse -
That worked!
by n1ukx / February 6, 2017 2:33 AM PST
In reply to: Thanks Papa_Paul2

TinksMeOff's solution worked perfectly. After all these months searching, finally works as it should. Thànks!

Collapse -
You must leave home group with all computers to set up a new
by FSBassman63 / November 18, 2015 8:00 AM PST

I think the reason that you were able to create a new home group is that when you shut down and everyone leaves the home group, it is not seen by the network anymore. Then, when you turn on a computer you are allied to create another. According to Microsoft, you cannot delete a home group, it just goes away when everyone leaves it. Stupid design of the software. There should be a proper control panel for deleting and setting up home groups. I hate windows home networking, it is awful. Hasn't been good since XP.

Collapse -
But how!?
by peter wassink / February 9, 2016 4:51 AM PST

"you cannot delete a home group, it just goes away when everyone leaves it"
This in itself is a perfectly fine idea... if only MS would make it possible to leave!
just a simple "leave this homegroup" option would be all i need.
But the way it works now i cannot get my machines to network...
cannot delete the homegroup,
cannot get the password,
cannot change the password,
its driving me bonkers Sad

Collapse -
leaving homegroup
by yarpos / February 21, 2016 10:16 PM PST
In reply to: But how!?

If you look in Control Panel/Network and Internet/Homegroup the 3rd last selection under "other homegroup options" is "leave the homegroup...."

Collapse -
You must leave home group with all computers to set up a new
by FSBassman63 / November 18, 2015 8:05 AM PST

I think the reason that you were able to create a new home group is that when you shut down and everyone leaves the home group, it is not seen by the network anymore. Then, when you turn on a computer you are allied to create another. According to Microsoft, you cannot delete a home group, it just goes away when everyone leaves it. Stupid design of the software. There should be a proper control panel for deleting and setting up home groups. I hate windows home networking, it is awful. Hasn't been good since XP.

Collapse -
Yes Papa_Paul2 it worked
by akjalewa / December 14, 2015 8:50 PM PST

I was so frustrated when I lost homegroup due to some change in computer names on my win7 pcs and shifting to work network etc ... Now this ghost homegroup from my Win10 pc did not allow me to quit or join to a new homegroup after I reverted to original settings ..... my connection to printers lost...

I tried all advise - 1 , 2 , 3 but all in vain... Finally I closed all pc and followed advise 3... Keeping shut the pc which I believed was hosting the ghost homegroup... Yes this time I was successful in creating homegroup on pc I wanted... connected other pc to that homegroup and finally put on the pc with win10-- supposed to be hosting the ghost...... The ghost disappeared this time and i was able to join hostgroup on my win 7 pc and share the printer too...
Thanks Papa_Paul2

Collapse -
This worked, Thanks!
by dsl15 / January 29, 2016 1:42 PM PST

I just upgraded 2 laptops and one desktop. Systems were 5 years old , one laptop was overheating the other the HD was failing. On the desktop I was starting to have unusual problem with the network, home groups and hard drive. So all of these replacement machines were shipped with windows 10 however one of the laptops is for our security cameras and was up and running sooner than the next two. Depending on the system it either said I was invited to join a home group (but it would tell me it was no longer there when I tried, yet still gave no other options. The cam laptop allowed me to create one but no one else could use the password successfully. So none of my computers could talk to each other, very frustrating. I had performed step 1 as I had found it in a different blog but it alone did not work, there were also references to step two in other blogs also unsuccessful. However when I performed all three steps (including booting up the two old computers to have them leave their home groups) it worked! I was very happy. Thank you.

Collapse -
Delete ALL files from the PeerNetworking folder
by Wilfried1958 / March 24, 2016 4:59 AM PDT

Thanks Papa_Paul2. Your method worked for my but only after several iterations. Finally, I deleted ALL files from all \Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking folders on the PC's to be added to the home group. This worked! The folders contained multiple files: idstore.sst but also similar with .new at the end and ones with long names: maybe due to the fact that I had VMware virtual network adaptors active and they have been adding ghost home groups.
I also shut down all VMware vm's and deactivated all vmware virtual network adaptors.

Collapse -
Same issue
by Faseout / September 26, 2016 9:55 PM PDT

Thanks for the help!
i shut down all pcs and did step 1
then ran the homenetwork troubleshooter
got the new homegroup and password right away and setup all other pcs (4)

Collapse -
Win10 Homegroup issues
by kdoggy325 / August 10, 2015 11:56 AM PDT

I went to 4 different forums to look for answers because I couldn't find the idstore.sst files to delete them. I finally got tired of messing with it and turned off the laptop. I took a last shot at the PC and tried to delete the homegroup or network, even though the system told me that the homegroup had been created by the laptop. I couldn't delete the network, but it would let me change the password. I turned the laptop back on and entered the new password. The PC and laptop recognized each other and even connected to OneNote. Hopefully this holds. These little tweaks are just annoying.

Collapse -
Windows 10 bugs
by neilbuss / August 16, 2015 3:47 PM PDT

I upgrade a Windows 7 computer to Windows 10 and a Windows 8.1 laptop to Windows 10. I cannot connect to home groups. I have tried the home group wizard to try and fix the problem, but that does not work. It appears every body who I know who has upgrade to Windows 10 from 7 or 8 is having this same problem.

When I upgraded from Windows 8.1 on my laptop Windows 10'intially crashed. I have also had problems with sending Outlook mail on my desktop and laptop. I used sfc /scannow in Oos administrator to find errors and correct them. I also reset my accounts in Outlook from scratch. I have now got my email working again.

When I ran sfc /scannow in Dos Administrator on my Windows 7 PC after upgrading to windows Ten it stated there was some corrupt files it corrupt not fix.

I like Windows 10 but there needs to be more work on it getting the bugs out. I don't regard this operating system ad a fully completed product.

Collapse -
It may be the end of Windows for many. Here's why.
by R. Proffitt Forum moderator / August 16, 2015 3:57 PM PDT
In reply to: Windows 10 bugs

Last week I worked with a few folk on the email issues and in 10 cases it was some entry in the email app settings. All 10 had upgraded to 10 and all had finger pointing at 10. Not that I disagree but today I think it's a lot to ask folk to setup email. Maybe the time has come to change email so you don't have to set server names, port numbers and more?

Post was last edited on August 16, 2015 3:57 PM PDT

Collapse -
Windows 10 Homegroup solved ,no file deleting .
by janrdoh / September 9, 2015 6:47 PM PDT

I to was frustrated by this problem but it turns out the fix is not a fix at all but merely MS being stupid .Here is what you do .
Make sure only one pc is powered on ( join will no longer be an option ) Create HomeGroup and wait for the password box to show up . Now start up your other pc's and click Join HomeGroup .
Enter the password from your main pc and suddenly all the others can join the group .Now reboot the first pc and they are all happily connected .

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?