I've yet to find any support for anything past 1803 (the version out now.)

For Insider that's BETA and prone to be buggy. Why would I want to run a buggy beta?