Mac Hardware forum

General discussion

Why won't my iPod Touch connect to my wireless network?

by seanm924 / February 9, 2008 4:50 AM PST

I have a 16GB iPod Touch that connects to other networks just fine, but it won't connect to mine. I've tried restarting the router and the ipod, and nothing seems to work.

Would it have something to do with my network being password protected? I enter the password on the ipod and it all works just fine, and it connects, except I can't actually use the network to do anything. I just get the error message "not connected to wireless network"

Discussion is locked
You are posting a reply to: Why won't my iPod Touch connect to my wireless network?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Why won't my iPod Touch connect to my wireless network?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Check our other forum sticky.
by R. Proffitt Forum moderator / February 9, 2008 4:53 AM PST
Collapse -
It also may depend on your security
by tleMega / February 9, 2008 7:53 AM PST

if you explain what type of encryption you use, then we might get somewhere. The iPod Touch supports WEP and WPA. WPA2 does not work. Try disabling security if this is what you are using and see if it makes a difference. It could be the router at fault if not the iPod.


Collapse -
by seanm924 / February 27, 2008 6:01 AM PST

WEP...The router is a Gateway 2Wire 2700HG-D

Collapse -
(NT) WEP can be an issue. Now try it per the forum sticky.
by R. Proffitt Forum moderator / February 27, 2008 6:11 AM PST
In reply to: re
Collapse -
My iPod touch is doing the EXACT same thing!
by 7AmandaBoruff7 / August 9, 2011 2:09 PM PDT

My iPod thouch is doing the exact same thing!
Did you ever find out what was wrong with it?
It's driving me nuts, I can't check Facebook, or any other internet sites.
I have to use my laptop instead.

Note: This post was edited by a forum moderator to remove email to prevent abuse and spam harvester from picking it up on 08/10/2011 at 10:53 AM PT

Collapse -
How about you supply more details,
by mrmacfixit Forum moderator / August 9, 2011 9:56 PM PDT

what you have tried,
what the configuration of your wireless network is
if the iPod works on other wireless networks
and any thing else you can think of that may help.

Collapse -
Having problems connecting to my wireless router.
by kittyangel222 / September 18, 2012 1:25 AM PDT

Hi, I am having problems connecting to my wireless router through my iPod Touch 4th generation. My wireless router is Asus RT-G32. My iPod Touch can find find it and it says it's connected but has a loading sign on my iPod Touch. My sister's iPod Touch can't connect to the wireless router either. This started yesterday. The wireless router is in my room. Well thanks.

Here's a picture of my iPod touch trying to connect to my wireless router:
Here's a picture of the wireless router:

(Sorry, I had to cover the name of the connection.)

Collapse -
Fixed my problem?
by kittyangel222 / September 18, 2012 1:51 AM PDT

Uh.. .o.o I think my problem is fixed...

Collapse -
Good to read.
by R. Proffitt Forum moderator / September 18, 2012 1:57 AM PDT
In reply to: Fixed my problem?

Please don't use old discussions. Start a new one if you must continue.

Collapse -
Wish I could edit my posts..
by kittyangel222 / September 18, 2012 5:21 AM PDT

Actually it still doesn't work. .-. T_T It had a check mark, so I thought it was working then went to YouTube and other apps that need wifi and it didn't work.

Collapse -
This is an old discussion
by R. Proffitt Forum moderator / September 18, 2012 5:24 AM PDT

And is not well suited to host your new discussion.

Again this discussion was by seanm924 - 2/9/08 so it's now closed.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.