Question

Why is my system and compressed memory maxing out my "disk"

Dec 8, 2015 9:46AM PST

I have a issue. I will be playing a game or just surfing the internet, then out of nowhere my computer starts to freeze up (it does this for about 2-3 minuets) When i am able to access my computer again, i open the task manager to end the task causing the issue. I find out that it is "system and compressed memory" and it is making my disk stay at a constant 100%. After about 3 minuets it will die back down to around 2%-6%.

If you have any solutions, please reply.
Thanks.

Operating System - Windows 10
Mobo - Asus P8Z77-V ATX LGA1155 Motherboard
GPU - MSI GTX 780
RAM-32gb corsair vengeance 1866 ddr3

Discussion is locked

Follow
Reply to: Why is my system and compressed memory maxing out my "disk"
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Why is my system and compressed memory maxing out my "disk"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
I found this link.
Dec 8, 2015 9:58AM PST
- Collapse -
Answer
And last few months, a lot of weird Seagate failures.
Dec 8, 2015 10:15AM PST

One of the signs it was a drive issue was the disk use went to 100%. You didn't list the HDD. Is it a Seagate?

- Collapse -
Yes
Dec 8, 2015 1:18PM PST

I am sorry that i forgot to mention my HDD. Yes it is a Seagate.

- Collapse -
In line of my findings over the past year.
Dec 8, 2015 1:45PM PST
- Collapse -
Answer
Solution! Worked for me..
May 24, 2016 8:40AM PDT
- Collapse -
Seagate Memeo cased my problem
Jun 20, 2016 6:04AM PDT

In my case it was Memeo Instant Backup that was causing system and compressed memory to use all the Disc activity. Constantly at 100%. Memeo wasn't even working as the Seagate GoFlex network drive is at a different site and stopped working two months ago. I unistalled Memeo but kept the backup settings. Within a minute the drive useage was down to 5%.

Hopefully they will repair the drive and I'll get my offline storage back but that's another issue.

- Collapse -
Answer
Turn off Notifications
Aug 22, 2016 5:06AM PDT

Hi! Found this solution somewhere on forums:

Start --> System --> Notifications & actions. On the right panel you will see Notifications on\off. Try turning them all off.

My disk usage went from 100% to 0, fan noise disappeared and my laptop cooled down.

- Collapse -
Answer
Task Manager shows the disk to be at 100% utilization despit
Sep 23, 2016 9:13AM PDT

Task Manager shows the disk to be at 100% utilization despite a light or no workload, and the system may experience lag or become unresponsive. In addition, the system event log contains numerous events with Event ID 129, which represent resets of the disk controller.


Cause

While device resets can be caused by a varying number of factors, we are aware of issues with some Advanced Host Controller Interface PCI-Express(AHCI PCIe) models that causes these symptoms in Windows 10 when running with the inbox StorAHCI.sys driver. Due to a firmware bug, the Solid-state drive (SSD) does not properly complete input/output when Message Signaled Interrupt (MSI) mode is enabled. As a result, the Windows storage stack attempts to reset the device after waiting on unresponsive reads or writes for a period of time.


Resolution

MSI mode can be disabled for specific devices via the registry:


Identify if you are running the inbox AHCI driver (StorAHCI.sys):

Open a command prompt with administrator privileges. Then type the following command in the command prompt window and hit Enter: devmgmt.msc
Under IDE ATA/ATAPI Controllers right-click on the AHCI controller node and select Properties. This node is usually called “Standard SATA AHCI Controller.”
Navigate to the driver tab and click Driver Details.
If you see “StorAHCI.sys” in the list, you are running the inbox driver.

Disable MSI for the controller in the registry:
In the same properties window opened in step 1.2, navigate to the Details tab and select Device instance path from the Property drop-down menu. Note this path.
Open the registry editor by typing regedit in the previously opened command prompt.
Navigate to: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\PCI\ <AHCI Controller>\Device Parameters\Interrupt Management\MessageSignaledInterruptProperties, where <AHCI Controller> refers to the device instance path you noted in step 2.1.
Change the value of the MSISupported key from “1” to “0”.
If you don’t know which controller your boot device is attached to, repeat steps 2.1 through 2.4 for all AHCI controllers found under 1.2.

Reboot the machine.

CNET Forums

Forum Info