Windows 8 forum

General discussion

Whenever my laptop boots i got the blue screen with sad face

OS:windows 8.1
I made the dumbest thing i've ever did.From MSconfig i changed maximum memory allowed to 256mb....And now when windows boot i got "BAD_SYSTEM_CONFIG_info" error.Please help me.

Discussion is locked
You are posting a reply to: Whenever my laptop boots i got the blue screen with sad face
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Whenever my laptop boots i got the blue screen with sad face
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: bad config

In reply to: Whenever my laptop boots i got the blue screen with sad face

First thing to try: see If you can't change it back if you boot into Safe Mode.

If not it's time to go back to factory conditions from the recovery disks you made, the recovery partition or the refresh or reset options offered after you boot from your Windows 8 install or recovery disks.
Since all of that is rather depend on the make and model of your laptop, I can't be more specific.

Kees

Collapse -
no I cant boot

In reply to: Re: bad config

No,I cant boot windows even in safe mode.

Collapse -
(NT) Then go to the second paragraph of my answer.

In reply to: no I cant boot

Collapse -
re

In reply to: Then go to the second paragraph of my answer.

And what if i dont have any recovery disks?Btw i have access to cmd from troubleshoot in advanced options.

Collapse -
Re: advanced options

In reply to: re

If you can go into the advanced options, try System Restore first. That should restore the registry that contains that fatal value of 256 MB.
https://www.winhelp.us/repair-your-computer-in-windows-8.html gives other options to try.

Also somthing to try: edit the registry from the command prompt. That's discussed in http://www.techrepublic.com/blog/windows-and-office/use-the-recovery-drive-command-prompt-to-edit-the-registry-or-recover-data/
But you have to find out where that 256 MB is stored. It might be in some other place than the registry. In older versions of Windows it was some ini-file, that you can easily edit.

Kees

Collapse -
re

In reply to: Re: advanced options

System restore didnt help.I tried some commands to change the number 256mb but nothing.Now im trying to find that number in regedit.

Collapse -
re

In reply to: re

I found potential problem.In cmd i typed "bcdedit /enum all /v".In the second section i found "truncatememory. 0x10000000"is that the way it should look and if not how should it?

Collapse -
re

In reply to: re

Ok found it and changed it but still nothing.Maybe the only way is to re-install windows

Collapse -
your laptop lost it's boots?

Maybe it wanted sneakers instead. Wink

http://www.tomshardware.com/forum/9775-63-changing-msconfig-windows

I ran into the same problem and solved it...

The correct syntax should be:

bcdedit /deletevalue {default} truncatememory

where "{default}" is the name of the identifier where "truncatememory" is listed by "bcdedit". Also set it to something else by typing:

bcdedit /set {default} truncatememory 0x100000000

Remember to always take a backup before you start:
bcdedit /export c:\bcd_backup
To restore it type:
bcdedit /import c:\bcd_backup

and a help file can always be found when typing
bcdedit /?
or more specific help about an option:
bcdedit /? <option>
e.g. "bcdedit /? /set"

Now my Windows is booting without a BSOD..
Cheers!
//StarChild
=============================


atul_45
January 26, 2013 2:36:16 AM

Thanks Starchild for sharing your solution !! It worked just fine for me and am really really glad that I came across this thread. Thanks to all the people associated with this forum where such solutions are shared for really nasty issues and which are not provided by the manufacturer/creator of such softwares !!!
===============

Collapse -
another

In reply to: your laptop lost it's boots?

http://forums.techguy.org/attachments/173243d1276798363/truncmem.jpg

http://forums.techguy.org/windows-7/929591-msconfig-max-memory-problem.html


In the command Prompt, type bcdedit
Look for the Windows Boot Loader entry that contains an item named truncatememory
Note the identifier for that entry, it may be {default} or {current}, or may be a long GUID like {8eea9b82-d5b1-11de-9d24-80972e3a13c7}
Enter this command:
bcdedit /deletevalue identifier truncatememory
replacing identifier with the correct one you noted for that entry.

The screen shot is when booted to Safe Mode with Command Prompt.
Accessing the Command Prompt by booting to the DVD and choosing Repair your Computer, the identifier for that same entry is shown as {default}

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.