Windows Legacy OS forum

General discussion

What is the right way to copy files from

one Hard disk to another device - and put it back without the need of 'take ownership' step?

Pentium 4 2.4ghz, 256mb memory, 64mb VGA, NTFS, Windows XP-Pro-SP2 + most of critical updates, NAV, Adaware Se, Spybot SD, Spywareblaster (all with the latest updates- run all + online scan, found nothing bad)

Situation:

Copying files from a computer to another storage device (Hard disk, CD, external storage device etc.)

Reformat (NTFS) and Reinstall the computer... (windows XP Pro + including SP2 and most of the critical updates + all needed application)

Copy back the files...

Everything seems OK.

Problem:

On the newly reformat/reinstall computer...

I can Open and Edit the files, BUT I can not SAVE it, I can not Delete (any files or folder)

with a message Access denied and/or files being use..

Solved the problem by 'Taking the ownership' of those files and folder.

Question:
How to copy the files and folder, so I don't have to do 'Take ownership' ritual?

Thank you for any information and help.

Discussion is locked
You are posting a reply to: What is the right way to copy files from
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: What is the right way to copy files from
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
This maybe the cause

In reply to: What is the right way to copy files from

When you copy files to a CD they become read only - sometimes when you copy them back to a disk they remain "read only" - this can happen particularly if you copy folders at a time and the whole folder becomes read only. Simply click on the folder and reset properties - It will ask you if you want to change the properties of all the files and sub files in the folder.
The only other cause I can think of is that you haven't set your account with full admin privilege.
Also why not use the "settings and transfer wizard"
Peter

Collapse -
I wish its that simple

In reply to: This maybe the cause

Its not read only problem... its ownership problem.

Maybe I left some more info.. here it is..

The PC (before reformating) have 4 accounts which are 1 Administrator, 1 user with admin priviledge and 2 limited users.

The files are located in a folders is created by all tree users.

The copying step was done using the Administrator (ctrl-Alt-del .. twice)

After reformating and reinstall, there are also 4 users (using the same name)

The copying back was done using the Administrator account.

The Administrator can do anything to the files, but the limited user only able to open, No saving, no delete, no moving, eventhough those files are originally created by that user.

Currently I have to make all users as administrator, then doing the 'take ownership' step, then make the users back to limited account.


Thank you

Collapse -
Wishful thinking on my part as well!!

In reply to: I wish its that simple

I was hoping for a simple solution to this one - haven't taken a trick all day!!
However.... I think there is a way around this from memory ...and is it has something to do with using regedit to change folder permission by right clicking on the mouse. Go to regedit and right click on any folder and select permission - from here its just a matter of finding the right place in the registry to change things. I'll do a bit of searching and get back to you.
Peter

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.