may be there is a save password setting..