Storage forum

Question

Weird IDE Controller Device Driver Missing (Error 39)

by Aeschylus_Nyx / August 25, 2011 1:20 AM PDT

In my device manager under storage controllers, I have an IDE controller listed with error message 39 (Windows cannot load the device driver for this hardware. The driver may be corrupted or missing.) I've tried running the driver update but a driver can't be located.

Here's the weird part; I tried uninstalling & reinstalling (by scanning for new hardware in device manager) the controller and when it reinstalled, the name of the hardware was completely different from the first time I uninstalled it. For example; Before uninstall it'll be something like AQXFHYW2 IDE Controller & after reinstall it'll be a completely different series of random numbers & letters. In the properties of the controller, the driver provider, date, version etc. are all unknown.

Anyone ever hear of anything like this? Thanks in advance for any help

Here are my system specs

HP Pavilion Dv5t 1000 cto
Intel Pro Core Duo 2 2Ghz
4GB RAM
nVidia GeForce 9200M GS Graphics Card
Windows Vista Home Premium 32bt Service Pack 2

Discussion is locked
You are posting a reply to: Weird IDE Controller Device Driver Missing (Error 39)
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Weird IDE Controller Device Driver Missing (Error 39)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Yup.
by R. Proffitt Forum moderator / August 25, 2011 1:37 AM PDT

But driver update is the last tool I suggest using. If you keep at this you learn to find the driver from the maker first.

Also, CODE 39 is one of the well discussed failures. If it's working don't fix this. Also 4GB on 32 bit OSes tend to do this a lot. Chalk it up to bad choices made years ago.
Bob

Collapse -
My bad choices or HPs?
by Aeschylus_Nyx / August 25, 2011 1:57 AM PDT
In reply to: Yup.

This is actually a manufacturer replacement for the the first computer I ever owned (that was an older Pavilion series). That one kept crapping out so they finally replaced it with this, & everything, including the RAM, was installed by HP. I haven't upgraded it @ all.

That aside, how do I fix this? What will this problem effect? Can I just disable it & forget about it? There is another device listed under storage controllers: Microsoft iSCSI Initator & it's working fine.

Collapse -
Sorry.
by R. Proffitt Forum moderator / August 25, 2011 5:47 AM PDT
In reply to: My bad choices or HPs?

But a few owners go looking at the device manager and find things like this EVEN IF the machine is working fine.

In those cases my advice is to ignore it.
Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GIVEAWAY

Turn up the volume with our Apple Byte sweeps!

Two lucky winners will take home the coveted smart speaker that lets Siri help you around your connected house. This sweepstake ends Feb. 25, 2018.