General discussion

weird favorites (IE8) behaviour

WinXP home, SP3
IE8 (version 8.0.6001.18702)
MS Office 2003


If I save a page in my favourites, sometimes (but not always) two links appear, one with a plain English name & one with the URL.

Mike Lin's Home Page

Usually (but not always) the plain English link will give this error message: "The target ""of this internet shortcut is not valid. Go to the internet shortcut property sheet and make sure the target is correct" (the ?? after target is not a typo). This has also happened with pages with html/htm suffixes.

Something similar seems to happen if I change the name of a favourite?s shortcut from a URL to plain English i.e. something I?ll recognise later.

I think this was happening before I upgraded to IE8, but I can?t remember for sure. It was definitely happening before I upgraded from office 2000 to 2003, a few weeks ago.

Anyone know what?s going on & what I can do about it?



Discussion is locked
Reply to: weird favorites (IE8) behaviour
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: weird favorites (IE8) behaviour
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
addition to my "weird favorites (IE8) behaviour" post

(1) Suffixes is meant to be extensions

(2) I can't insert images here, so a description of the shortcut property sheets:

The plain English shortcut property sheet just has a general tab with 'Mike Lin's Home Page' in the box (what's this box called?) & as the description.

The URL property sheet has general & web document tabs. The general tab has in the box & as the description. The web document tab has this as the URL.

I just tried deleting the plain English shortcut & changing the contents of the box on the general tab of the URL property sheet to Mike Lin's Home Page. It only worked when i changed Lin's to Lins - i.e. got rid of the apostrophe.

Is windows/IE/one of the protocols/something else (?????) reading the apostrophe as if it's code rather than treating it as text?


I might have found a way to stop this problem reoccurring, but i don't know why it happened in the first place, so any feedback/comments much appreciated.


- Collapse -
Let us see an example

You're right that these forums do not allow the posting of images, but you can get round this by uploading a screen print of what you see to an image hosting site like ImageShack, PhotoBucket, Flickr, or similar, then posting a link to the full sized image in a post here.

That way we can click the link you give and see an image of what you mean.

It would help us see what you are seeing.

Hope that helps.


- Collapse -
weird IE beahviour - screenshots on flickr
- Collapse -
I think I see.

And I think I may have to pass on this.

In your first post you mentioned favourites, but what I think see in those Flickr images are "Saved web pages". So, can we sort this out immediately?

What do you understand to be Favourites? What I understand is using IE 8's option of saving web site links to IE 8's own Favourites folder so that, at some future time, I can just open the Favourites listing from within IE and click on the web site I want, and IE will take me there.

But what I see in those images are saved web pages, perhaps saved to your Desktop or similar place. What others think of as Shortcuts to web pages.

Is that what you are doing?


- Collapse -
favorites vs saved web pages

i think understand favorites the same as you do.

just now i deleted the Mike Lin shortcuts from my favorites folder to start afresh. i then opened IE & typed into the address bar, which took me to Mike Lin's Home Page. I clicked on favorites>add to favorites>add. this is ALL i did, which is what i've done for years when saving a link in IE favorites. i.e. i'm not saving the web pages via file>save (or save as), which is what i think you were wondering.

i then checked my favotites folder & both the shortcuts that i mentioned in my previous posts are there, with the EXACT same properties sheets you've seen screenshots of.

Does this clarify the issue at all?

Thanks, Jeff

- Collapse -

With that clarification, I understand what is happening, though I have never seen that particular issue before. I do, however, have a few thoughts:

1.) Try dragging the site's favicon from the IE8 address bar to the desktop and see if the issue is duplicated. (It's an uncommon but useful way to save an internet shortcut.)

2.) Under Internet Options, tell us about the third-party plug-ins (add-ons) you have installed. Also, try disabling all of them temporarily to see if one of them is the source of the issue.

3.) Try uninstalling IE8 and seeing if IE7 persists with the issue. If so, then try reinstalling IE8 to see if the issue remains.

4.) Look over the cases where this issue arises and see if there is a commonality, such as the apostrophe in the Mike Lin site's title.

Let us know what you find.

- Collapse -
Me too.

I also understand the difficulty now, with your clarification. Thank you.

Like John, I have never seen this problem before. Using IE 8 I've just been to Mike Lin's home page, (I used his Startup Monitor for years on my XP system), and saved the home page to Favorites, and only got the one link. Going back to your Flickr images, I can't see any significant differences, except that Vista offers other tabs for these shortcuts, so this is, indeed, very strange.

I've never seen a "Plain English" version of a favorites link before, and I don't understand what it is for or what it means. I don't suppose this has anything to do with language does it? I mean are you using a standard USA language system?

Other than that I agree with John's suggestions.

Let us know how you get on.


- Collapse -
Plain English...

It's just a reference to the title/shortcut name. If the webpage creator does not give the webpage a title, IE will use the URL as the name of the shortcut. If a (plain English) title is set, though, IE will use it since it's more readable and recognizable. For some reason IE8 is being excessively 'helpful' for Jeff, unnecessarily creating two shortcuts, with the 'plain English' one (the only one that should actually be created) often being broken/non-functional.


- Collapse -
resolved (sort of)

Sorry about the delay in responding, I've been away.

The shortcut worked fine if I dragged the favicon from the address bar to the desktop (ditto if I dragged it into any other folder) & I couldn?t see any commonalities between the various instances

I was reluctant to disable all the add-ons & have to go through them re-enabling, so I went straight onto uninstalling IE8 & it worked ? when I save Mike Lin?s Home page to my favorites just the one link appears, with both the general & web document tabs. I still don?t understand why this was happening, though it does seem to have been related to IE8.

As I?ve read some pretty negative reviews about IE8 anyway, I think I?ll stick with 7, for a while. If you look into this further & figure out the problem you could post something here, if you wanted - I?d be interested to know what it was.

Thanks for your help,


- Collapse -
Glad you got it sorted, and thanks for reporting back.

You may want to try IE 8 again in the future. It is more secure than IE 7 anyway, but I would bet that there was some corruption, or some add-on that didn't fit well into IE 8, and that caused this problem.

But good work on solving that strange problem.


CNET Forums