...turn off and clear "Autocomplete" to prevent it from "suggesting" listed items. As far as the website is concerned, Cookies are used to "remember" such passwords.

On Windows XP, for Internet Explorer, open the Control Panel, select "Internet Options", then click on the "Content" tab. Depending on which version of IE you have running, you can then click on the "Settings" button in the "Autocomplete" section and UNCHECK all the boxes to prevent it from remembering future entries. Then delete all the "History" options there or in the "General" tab (Browser History in IE7.).

Hope this helps.

Grif